Основные возможности

SpRobot - это система автоматизированного управления входящими и исходящими телефонными звонками. В ее состав входит Автосекретарь и Автообзвон.

Автосекретарь

Применение: Автосекретарь можно использовать в качестве автоинформатора, автоответчика с возможностью записи сообщений, для автоматической переадресации на внутренние номера организации и др.

Основные возможности:

  • круглосуточно обрабатывать входящие звонки
  • соединять абонента с сотрудником или отделом, минуя оператора
  • контролировать вызов внутреннего номера (различает результат соединения: занято, не отвечает или вызываемый абонент взял трубку)
  • работать с голосовой почтой
  • обрабатывать входящие звонки, поступающие в нерабочее время
  • организовать справочную службу (автоинформатор)
  • выполнять SQL запросы к пользовательским базам данных
  • выполнять скрипты Visual Basic

Отличительные характеристики:

  • составление голосового меню любой сложности (нет ограничений на количество меню и их вложенность)
  • графическое представление алгоритма голосового меню (наподобие блок-схем)
  • одновременное выполнение нескольких голосовых меню на телефонных каналах
  • работа с голосовой почтой через телефон или компьютер
  • неограниченный размер почтового ящика
  • многопользовательский интерфейс с разграничением прав доступа
  • получение отчетов (статистики) о работе Автосекретаря
  • встроенный звуковой редактор, позволяющий быстро составлять звуковые фразы
  • управление Автосекретарем через IP-сеть (локальная, Internet)

Автообзвон

Применение: Автообзвон позволяет проводить опросы, информировать клиентов о задолженности, оповещать сотрудников организации при возникновении аварийной ситуации, рассылать рекламные сообщения и др.

Основные возможности:

  • автоматически информировать (оповещать) абонентов о чем-либо
  • запускать оповещение при срабатывании датчика, по расписанию или вручную
  • просматривать состояние номеров, статистику и результаты обзвона абонентов
  • экспортировать отчеты и статистику в MS Excel, OpenOffice.org Calc
  • выполнять оповещение на нескольких телефонных каналах
  • выполнять SQL запросы к пользовательским базам данных
  • выполнять скрипты Visual Basic

Отличительные характеристики:

  • высокая скорость оповещения большого количества абонентов
  • импорт списка абонентов из любой базы данных
  • подробное протоколирование процесса оповещения
  • гарантия доставки сообщения (запрос подтверждения о получении сообщения)
  • запуск оповещения при срабатывании датчиков
  • произнесение любых данных (номера телефона, чисел, даты/времени, суммы в рублях)
  • одновременное выполнение нескольких программ обзвона
  • многопользовательский интерфейс с разграничением прав доступа
  • управление Автообзвоном через IP-сеть (локальная, Internet)
  • подтверждение поднятия трубки абонентом, если в линии вместо гудков звучит мелодия, или отвечает робот сотового оператора.

Программный комплекс SpRobot может работать только с устройствами SpRecord модели AT.

Смотрите также:

Состав SpRobot


Состав SpRobot

Программный комплекс SpRobot состоит из следующих модулей:

  • Сервер
  • Клиент Автообзвона
  • Клиент Автосекретаря
  • Звуковой Редактор

Сервер является центральным модулем в системе SpRobot. Он выполняет на телефонных каналах алгоритмы голосового меню Автосекретаря и Автообзвона, используя программные и аппаратные возможности устройств SpRecord, взаимодействует с базой данных и следит за выполнением различных запросов от Клиентов в рамках тех прав, которые им назначены. Сервер является службой Windows, которая запускается при загрузке компьютера. Он должен быть установлен на компьютер, к которому подключены устройства SpRecord типа АТ.

Клиент Автообзвона - это приложение Windows, в котором пользователь формирует список абонентов для оповещения, создает алгоритмы оповещения, запускает их на телефонных каналах, выполняет администрирование пользователей и т.д. Его можно установить на те компьютеры, на которых предполагается работа пользователей с Автообзвоном.

Клиент Автосекретаря представляет собой приложение Windows, в котором пользователь может создавать алгоритмы голосовых меню, запускать их на телефонных каналах, выполнять администрирование пользователей, прослушивать голосовые сообщения, управлять настройками Сервера, создавать отчеты и др. Его можно установить на те компьютеры, на которых предполагается работа пользователей с Автосекретарем.

Звуковой редактор используется для составления голосовых фраз, которые впоследствии можно применять в алгоритмах голосового меню. Он устанавливается вместе с Клиентами.

Смотрите также:


Информация о производителе

Программный комплекс SpRobot изготовлен ОOO "Сарапульские системы".

Почтовый адрес: 427960, Россия, Удмуртская Республика, г. Сарапул, а/я 91
Телефон/факс: +7 (34147) 2-56-92, 3-72-82
E-mail: info@sprecord.ru
Web-сайты: http://www.sprobot.ru, http://www.sprecord.ru

Технические вопросы:
Поварёнкин Александр Владимирович
Телефон: +7 (909) 713-74-60
ICQ: 433-267-044
E-mail: sann-x@sprecord.ru
Skype: sann-x

Общие вопросы и сотрудничество:
Телефон/факс: +7 (34147) 2-56-92, 3-72-82
E-mail: zakaz@sprecord.ru

Смотрите также:

Основные возможности


Установка SpRobot

Программа инсталляции SpRobot позволяет устанавливать на компьютер либо Сервер и Клиенты (Автосекретарь + Автообзвон), либо только Клиенты.

Перед установкой Сервера SpRobot на компьютере уже должна быть установлена программа SpRecord версии 3.9 или выше.

Настройка Сервера

Во время установки Сервера необходимо указать порт TCP/IP, через который Сервер и Клиенты будут обмениваться информацией, и источник данных: локальные таблицы или MS SQL Server. В случае использования MS SQL необходимо указать следующие параметры:

  1. Имя SQL сервера (например, SQLExpress)
  2. Идентификацию (тип проверки подлинности): Windows или SQL Server
  3. Имя базы данных (БД)
  4. Если в п. 2. была указана идентификация «SQL Server», то в полях «Логин» и «Пароль» необходимо указать соответственно имя пользователя и его пароль. Эти данные Сервер SpRobot будет использовать для подключения к MS SQL. Указанный пользователь должен иметь права на создание БД, таблиц внутри БД и модификацию содержимого таблиц.

Если в качестве источника данных выбран MS SQL Server, то возможны следующие варианты подключения к данным:

  • Указанная БД не существует. В этом случае при запуске Сервера SpRobot база данных будет создана автоматически.
  • Указанная БД существует. При запуске Сервер SpRobot проверит целостность БД:
    • если БД целостна, т.е. содержит все необходимые таблицы, то Сервер SpRobot будет использовать ее как источник данных.
    • если она не целостна, то Сервер SpRobot будет использовать локальные таблицы.

Настройки ТCP/IP и источника данных также можно изменять и после установки SpRobot (см. «Настройка Сервера»).

Замена локальных таблиц

Если используются локальные таблицы, и необходимо заменить все или некоторые из них, то нужно установить опцию «Заменить локальные таблицы». В этом случае во время инсталляции указанные таблицы будут удалены (вместе с содержимым) и заменены новыми. Это может потребоваться, если локальные таблицы были повреждены.

Активация

После указания настроек Сервера можно ввести ключ активации. Этот ключ снимает ограничения на те устройства SpRecord, для которых он был сформирован. Также этот ключ содержит максимальное количество каналов устройства, на которых одновременно могут выполняться алгоритмы голосового меню.

Для Автообзвона и Автосекретаря вводится отдельный ключ.

Не активированные устройства имеют следующие ограничения:

  • алгоритм голосового меню можно выполнять только на одном канале
  • максимальное время выполнения алгоритма – 2 часа
  • алгоритм можно запускать только один раз

Также ключ активации можно указать после установки SpRobot (см. описание главного меню в Клиенте Автосекретаря или Автообзвона).

Смотрите также:


Настройка устройства SpRecord

Если в Автообзвоне и в Автосекретаре не отображаются телефонные каналы устройства SpRecord, то, возможно, необходимо настроить их, чтобы Сервер SpRobot мог получить доступ к каналам.

Выполните следующие действия:

  1. Запустите программу SpRecord (она, как правило, находится в меню «Пуск/Программы/SpRecord 3/SpRecord 3.xx»).
  2. В меню «Настройки» выберите пункт «Параметры»:

  3. Выберите закладку «Общее/Программа», установите галочку в пункте «Разрешить подключение библиотеки оповещения»:

  4. Выберите закладку с устройством и каналом, на котором предполагается работа SpRobot, нажмите кнопку «Дополнительно»:

  5. В закладке «Библиотека» установите галочку «Разрешить подключение к этому каналу через библиотеку SpRecord»:

  6. Нажмите «ОК» в окнах «Дополнительные настройки» и «Настройки».

  7. Выполните шаги 4 - 6 для всех каналов, которые будут использоваться программой SpRobot.


Клиент Автосекретаря

Клиент Автосекретаря - это программа, с помощью которой выполняются различные задачи, например: составление алгоритма голосового меню, запуск алгоритма на телефонном канале, работа с голосовой почтой, администрирование пользователей и др.

Окно состоит из нескольких рабочих областей.

1. Главное меню

Главное меню состоит из следующих пунктов:
  • «Система»
    • «Параметры»:
      • установить время ожидания ответа Сервера на запрос Клиента (сек.).
      • проверять обновления автоматически (спустя 3 минуты после запуска Клиента).
      • Окно сообщения. Эта группа параметров устанавливает внешний вид сообщений, выводимых командами «Показать сообщение» и «Показать HTML страницу»:
        • Закрыть окно сообщения спустя (сек.).
        • Вид окна: обычное или всплывающее. В последнем случае можно указать позицию на экране, направление появления окна, ширину, высоту и смещение по Х.

    • «Авторизация» - повторно войти в систему.
    • «Выход» - завершить работу Клиента.
  • «Роли» - название и содержимое этого пункта меню зависит от выбранного раздела. Как правило, его содержимое совпадает с контекстным меню и панелью инструментов (см. далее). В данном случае отображается раздел «Роли».
  • «Инструменты»
    • «Звуковой редактор» - открыть Звуковой редактор.
  • «Справка»
    • «Справка» - открыть справку SpRobot.
    • «Быстрый старт» - начать обучение по использованию Автосекретаря.
    • «Ввести ключ активации» - снять ограничения демо-режима Автосекретаря (см. «Установка SpRobot»).

    • «Проверить обновление» - проверить, появилась ли новая версия SpRobot.
    • «О программе» - узнать текущую версию программы.
2. Панель инструментов

Панель инструментов содержит функциональные кнопки. Набор этих кнопок и выполняемые ими функции зависят от выбранного раздела.

3. Панель разделов

В этой панели отображаются разделы, которые позволяют пользователю выполнять различные задачи. Перечень доступных разделов зависит от имеющихся у пользователя прав (см. «Администрирование пользователей/Роли»). В контекстном меню этой области пользователь может обновлять ее содержимое.

4. Рабочая область выбранного раздела

В этой области отображается содержимое выбранного раздела, например: список, алгоритм голосового меню и др.

5. Контекстное меню

Контекстное меню вызывается нажатием правой кнопки мыши в рабочей области. Содержимое контекстного меню зависит от выбранного раздела.

Смотрите также:


Вход в систему (авторизация)

Для того чтобы начать работу с Автосекретарем, необходимо войти в систему (выполнить авторизацию). После запуска Клиента появляется окно входа в систему. Если запуск был первым после установки SpRobot, то окно входа будет иметь расширенный вид:

При последующих запусках окно входа отображается в сжатом виде:

В полях логина и пароля необходимо ввести логин пользователя, зарегистрированного в системе, и его пароль. После установки Автосекретаря в системе заведены два пользователя: «ADMIN» (пароль «ADMIN») и «USER» (пароль «USER»).

Если Клиент Автосекретаря находится на том же компьютере, на котором установлен Сервер SpRobot, то необходимо в настройках соединения отметить пункт «Сервер на этом компьютере». Для того чтобы установить связь с Сервером, находящимся на другом компьютере, необходимо выбрать пункт «Сервер находится в сети» и нажать кнопку «Обзор». Далее в открывшемся окне нужно выбрать компьютер, на котором расположен Сервер SpRobot.

Номер порта1, через который Сервер и Клиент будут обмениваться информацией, указывается в поле «Порт».

Чтобы проверить соединение с Сервером, необходимо нажать на кнопку «Тест».

Кнопка «Соединение» расширяет или сжимает окно входа в систему.

После успешной авторизации программа запоминает логин, пароль (если была выбрана соответствующая опция), адрес Сервера и номер порта.

Смотрите также:

Администрирование пользователей
Настройка Сервера

Прим. 1. Если на компьютере Сервера или Клиента работает брандмауэр (фаервол), то его необходимо настроить так, чтобы Сервер и Клиент могли беспрепятственно обмениваться информацией по TCP/IP протоколу. В случае установки Сервера программа инсталляции автоматически выполняет необходимые настройки брандмауэра Windows.


Быстрый старт

Обучение «Быстрый старт» поможет освоить основные правила создания и запуска Автосекретаря. Процесс обучения займет 10-15 минут.

Структура голосового меню:

Возможности голосового меню:
  • предоставление информации о товарах компании;
  • соединение с оператором;
  • запись голосового сообщения, если оператор занят или не отвечает.

Входные данные: аудиофайлы
  • «Компания АБВГД. Прослушать информацию о товарах - нажмите 1. Соединиться с оператором - нажмите 2»;
  • «Наша компания выпускает карандаши и линейки. Прослушать сообщение снова - нажмите 1, вернуться в предыдущее меню - нажмите 2»;
  • «Оператор занят. 1 - оставить сообщение, 2 - вернуться в главное меню»;
  • «Оператор не отвечает. 1 - оставить сообщение, 2 - вернуться в главное меню»;

Звуковые файлы и конечный результат Дерева Меню можно найти в папке установки «..\SpRobot\Client\Samples\Автосекретарь\Быстрый старт».

Условия запуска: выполнение алгоритма голосового меню на 1 канале с 9:00 до 18:00 в будние дни.

Шаг 1. Создать «Главное меню»
Шаг 2. Создать «Меню 1»
Шаг 3. Создать меню «Оператор занят»
Шаг 4. Создать меню «Оператор не отвечает»
Шаг 5. Сохранить алгоритм голосового меню в базу данных
Шаг 6. Добавить задание к плану


Быстрый старт

Шаг 1. Создать «Главное меню»

1. Откройте раздел «Программы», вкладку «Дерево меню»:

2. Добавьте 3 общих меню:

3. Переименуйте их как «Меню 1», «Оператор занят» и «Оператор не отвечает»:

4. В «Главном меню» укажите файл приветствия:

5. Установите количество значений «2»:

6. В первой строке таблицы в столбце «Действие» выберите «Перейти в меню...»:

7. В открывшемся окне укажите «Меню 1»:

8. Во второй строке таблицы в столбце «Действие» выберите «Набрать номер...»:

9. В открывшемся окне укажите номер телефона оператора, контроль «ЕСТЬ», логин «USER», занят «Оператор занят», не отвечает «Оператор не отвечает»:

Шаг 2. Создать «Меню 1» >>

Смотрите также:


Быстрый старт

Шаг 2. Создать «Меню 1»

1. Перейдите в «Меню 1» и укажите аудиофайл, содержащий информацию о товарах:

2. Установите количество значений «2»:

3. В первой строке таблицы в столбце «Действие» выберите «Прослушать снова», во второй строке таблицы в столбце «Действие» выберите «На уровень вверх»:

Шаг 3. Создать меню «Оператор занят» >>

Смотрите также:


Быстрый старт

Шаг 3. Создать меню «Оператор занят»

1. Перейдите в меню «Оператор занят» и укажите аудиофайл, содержащий «Оператор занят...»:

2. Добавьте меню «Записать ГС» и укажите «%@VarLogin%»:

3. В меню «Оператор занят» установите количество значений «2»:

4. В первой строке таблицы в столбце «Действие» выберите «Перейти в меню...»;
5. В открывшемся окне укажите «Записать ГС»;
6. Во второй строке таблицы в столбце «Действие» выберите «На первый уровень»:

Шаг 4. Создать меню «Оператор не отвечает» >>

Смотрите также:


Быстрый старт

Шаг 4. Создать меню «Оператор не отвечает»

1. Перейдите в меню «Оператор не отвечает» и укажите аудиофайл, содержащий «Оператор не отвечает...»:

2. Добавьте меню «Записать ГС» и укажите «%@VarLogin%»:

3. В меню «Оператор не отвечает» установите количество значений «2»:

4. В первой строке таблицы в столбце «Действие» выберите «Перейти в меню...»;
5. В открывшемся окне укажите «Записать ГС»;
6. Во второй строке таблицы в столбце «Действие» выберите «На первый уровень»:

Шаг 5. Сохранить алгоритм голосового меню в базу данных >>

Смотрите также:


Быстрый старт

Шаг 5. Сохранить алгоритм голосового меню в базу данных

1. Проверьте получившийся алгоритм голосового меню на ошибки:

Если проверка не обнаружит ошибок, то переходите к следующему пункту, иначе исправьте найденные ошибки.
2. На панели инструментов нажмите «Скомпилировать и сохранить дерево меню»:

3. Введите имя новой программы или укажите уже существующее имя, затем нажмите «Сохранить»:

4. После того как Автосекретарь сохранит алгоритм голосового меню, нажмите «Закрыть»;

Шаг 6. Добавить задание к плану >>

Смотрите также:

Дерево меню


Быстрый старт

Шаг 6. Добавить задание к плану

1. Откройте раздел «Список каналов»:

2. Нажмите кнопку «Добавить задание к плану»:

3. Укажите сохраненную программу, отметьте будние дни и укажите время старта (9:00) и длительность (9 часов):

4. Нажмите «ОК». После того как наступит условие запуска (будний день, время 9:00), запустится алгоритм голосового меню, указанный в задании (см. пред. пункт):

Вернуться в начало обучения >>

Смотрите также:


Список каналов

В разделе «Список каналов» отображаются все каналы устройств SpRecord, подключенных к компьютеру, на котором находится Сервер. Этот раздел позволяет управлять каналами устройств: назначать, запускать, останавливать и планировать выполнение программ.

По умолчанию в списке каналов отображаются только те устройства, которые подключены к Серверу. Отображение каналов отключенных устройств включается/выключается нажатием на панели инструментов кнопки [image] или через пункт меню «Показывать отключенные устройства».

Каналы устройства могут иметь следующие статусы:

1. При определении статуса произошла ошибка. Такое состояние могут иметь каналы, к которым запрещено подключение через библиотеку SpRecord.

2. К каналу устройства не подключена телефонная линия.

3. Телефонная линия подключена, трубка находится на аппарате.

4. Телефонная линия подключена, трубка поднята.

Обновление списка устройств и каналов происходит автоматически при изменении состояния или их подключении/отключении к компьютеру. Для принудительного обновления списка используется кнопка «Обновить» [image] на панели инструментов или соответствующий пункт в контекстном меню.

Смотрите также:


Выполнение программ на каналах

Запуск программы на канале выполняется следующим образом:

  • выберите канал в списке
  • установите на канале программу, которую необходимо выполнить:
    • для этого на панели инструментов нажмите кнопку «Связать канал с программой» [image] или в контекстном меню списка каналов выберите пункт «Связать с программой»
    • в появившемся окне выберите программу и нажмите «ОК». Если выбрать «[--нет--]», то канал не будет связан ни с одной программой.

  • на панели инструментов нажмите кнопку «Запустить программу на канале» [image] или в контекстном меню списка каналов выберите пункт «Запустить программу».

После успешного запуска выполняемый канал будет показан жирным шрифтом, и в столбце списка «Программа выполняется» будет отображаться «Да».

Чтобы остановить выполняющуюся программу, необходимо на панели инструментов нажать кнопку «Остановить выполнение программы» [image] или в контекстном меню выбрать пункт «Остановить выполнение программы». После успешной остановки программы выполняемый канал будет показан обычным шрифтом, и в столбце списка «Программа выполняется» будет отображаться «Нет».

Смотрите также:


Планирование выполнения программ

Автосекретарь имеет широкие возможности по планированию запуска программ на каналах. На каждый канал можно установить несколько заданий. А каждое задание имеет свое время запуска и связано с программой. Задания, привязанные к определенному каналу, отображается сразу после выбора канала в списке. Добавление, изменение и удаление задания выполняется через контекстное меню или нажатием на функциональные кнопки, находящиеся слева от списка заданий.

При добавлении или изменении задания необходимо указать программу и тип запуска (см. далее). Если параметр «Активный» включен, то данное задание считается активным, и при наступлении условия запуска выполнится назначенная в задании программа. Выключение этого параметра делает задание неактивным, т.е. это задание не будет выполняться при наступлении условия запуска.

Существует 3 типа запуска программы на канале:

  1. «Дни недели». Этот тип позволяет запускать программу по дням недели в определенное время. Например, можно задать, чтобы Автосекретарь запускал программу по выходным или в будние дни после окончания работы и т. п. Минимальная продолжительность выполнения программы составляет 3 минуты, максимальная - 23 часа 59 минут.
  2. «Период». Этот тип позволяет выполнять программу на канале в течение определенного периода. Начало и конец периода можно задать по дате или по дате и времени. Разница между началом и концом должна быть более двух минут.
  3. «После перезагрузки компьютера». Если задать этот тип планирования, то программа запустится сразу после включения или перезагрузки компьютера, на котором установлен Сервер. Программа на канале запустится даже в том случае, если при загрузке компьютера операционная система ожидает выбор пользователя и/или ввода пароля для входа.

При добавлении и изменении заданий важно учитывать совместимость заданий, а также необходимо обеспечить правильность задания времени запуска и остановки (продолжительности). Задание с типом запуска «После перезагрузки компьютера» не совместимо с другими типами. Таким образом, в списке заданий активным может быть задание только с этим типом запуска, остальные задания должны быть неактивными. Типы запуска «Дни недели» и «Период» совместимы друг с другом, но они не должны пересекаться во времени с точностью до минуты.

ПРИМЕР 1.
Пусть для некоторого канала назначены два задания:

  1. ПН-ВТ-СР-ЧТ-ПТ, начало 8:00, продолжительность 9:00
  2. ПН-ВТ-СР-ЧТ-ПТ, начало 17:00, продолжительность 8:00

В этом случае первое задание заканчивается в 17:00, т.е. тогда, когда начинается второе задание (17:00). Для правильной работы Автосекретаря задание должно оканчиваться всегда раньше начала следующего. Таким образом, эти два задания необходимо скорректировать так: либо установить продолжительность первого 8:59, либо указать начало второго в 17:01.

ПРИМЕР 2.
Пусть для некоторого канала назначены два задания:

  1. ПН-СР-ПТ, начало 8:00, продолжительность 9:00
  2. Период, начало 13.04.2009 15:00, окончание 13.04.2009 22:00

Второе задание начинается 13 апреля 2009 года. Это число соответствует дню недели понедельник. Получается, что второе задание начинается в понедельник 15:00, т.е. в то время, когда выполняется первое задание (понедельник, с 8:00 до 17:00). В этом примере время заданий также пересекается. Для правильной работы Автосекретаря эти задания можно настроить так: либо изменить дни недели первого задания, либо изменить его продолжительность, либо изменить день второго задания (например, на 14.04.2009, вторник), либо изменить начало второго задания.

Сервер начинает выполнять задание, если текущее время больше или равно начала задания и меньше окончания (начало в задании ≤ текущее время < окончание в задании). Например, если задание начинается в 8:00 и длится 9 часов, то при включении компьютера, на котором находится Сервер, в 10:00 запуститься это задание. Если же он будет включен в 17:30, то задание выполняться не будет.

Таким образом, ручная остановка выполняющейся по заданию программы не приведет к желаемому результату: Сервер снова запустит программу. Чтобы остановить эту программу, сначала необходимо соответствующее задание сделать неактивным, а потом остановить канал (кнопка [image]).

Также для активации и деактивации всех заданий на канале можно нажать на кнопки [image] и [image] соответственно, расположенные на панели инструментов или в контекстном меню канала.

Смотрите также:


Программы

Основная функция Автосекретаря – выполнять на телефонном канале заранее подготовленный алгоритм. Составление и разработка таких алгоритмов выполняется в разделе «Программы».

Этот раздел состоит из трех взаимосвязанных разделов:

  • Список, содержащий перечень имеющихся в системе программ и подпрограмм;
  • Дерево меню, позволяющее быстро и легко составлять голосовое меню любой сложности;
  • Конструктор, представляющий собой инструмент для составления алгоритма в наглядном графическом виде (наподобие блок-схемы).


Список программ и подпрограмм

В этом разделе описывается ведение списка программ и подпрограмм, сохраненных в базе данных Автосекретаря.

Программы

Список программ находится во вкладке «Программы». Каждая программа содержит алгоритм, разработанный с помощью Конструктора, и дерево голосового меню.

Удаление программы производится нажатием на панели инструментов кнопки «Удалить программу» [image] или через контекстное меню (пункт «Удалить»). Программа будет удалена из системы, если она не связана ни с одним каналом. Изменение свойств программы выполняется нажатием на панели инструментов кнопки «Свойства программы» [image] или через контекстное меню (пункт «Свойства»).

Обновление списка вызывается нажатием кнопки «Обновить» [image] или выбором соответствующего пункта в контекстном меню.

Подпрограммы

При формировании голосового меню с помощью дерева пользователь может встраивать в общий алгоритм свою подпрограмму (одну или несколько, один или более раз). Благодаря такой возможности дерево меню является гибким инструментом разработки алгоритма голосового меню.

Ведение списка подпрограмм в основном не отличается от ведения списка программ.

Смотрите также:


Соединения с БД пользователя

Программа SpRobot имеет функции, которые позволяют обращаться к любым базам данных (MS SQL, MySQl, MS Access, MS Excel и др.). С помощью команд алгоритма «Выполнить SQL запрос» и «Получить значение из SQL выборки» можно извлекать и изменять данные. Для того чтобы соединиться с БД, необходимо установить параметры связи в разделе «Программы/Список/Соединения с БД пользователя».

Добавление, изменение и удаление

С помощью главного и контекстного меню и панели инструментов можно выполнить следующие действия:
  • Добавить соединение с БД.
  • Изменить свойства соединения с БД.
  • Удалить соединение с БД.
  • Обновить список соединений.
Свойства соединения с БД

  • Имя соединения. Каждое соединение должно иметь имя (псевдоним), которое используется в команде алгоритма «Выполнить SQL запрос».
  • Тайм-аут (сек.). Определяет максимальное время выполнения SQL запроса.
  • Параметры соединения. Содержит строку подключения к БД пользователя. Строку можно заполнить вручную или с помощь интерфейса Windows «Свойства связи с данными», вызываемого кнопкой

Смотрите также:

Список и описание команд алгоритма
Пример 1. Создание соединения с MS SQL
Пример 2. Создание соединения с MySQL
Пример 3. Создание соединения с MS Excel версии 97, 2000
Пример 4. Создание соединения с MS Access
Пример 5. Создание соединения с текстовым файлом
Формат текстового файла данных


Пример 1. Создание соединения с MS SQL

  1. В окне «Свойства соединения с БД» введите имя соединения.
  2. Укажите время тайм-аут.
  3. Определите строку соединения, нажав кнопку [image].
    1. 3.1. Выберите «Microsoft OLE DB Provider for SQL Server». Нажмите [image].

    2. 3.2. Определите параметры подключения к базе данных MS SQL:
      1. 3.2.1. Укажите расположение (имя компьютера в сети) и имя сервера, например localhost\sqlexpress.
      2. 3.2.2. Укажите способ (через учетную запись Windows или MS SLQ сервера) и данные авторизации (логин и пароль).
      3. 3.2.3. Выберите базу данных, которую вы хотите использовать в SpRobot.
      4. 3.2.4. Проверьте подключение, нажав на кнопку «Проверить подключение».
      5. 3.2.5. После успешной проверки подключения нажмите «OK».

  4. Соединение готово. В окне «Свойства соединения с БД» нажмите кнопку «OK».
Пример SQL запроса

select * from table1 where ID=~Var1~

Этот запрос возвратит все строки таблицы table1, у которой столбец ID равен значению переменной Var1. Переменная создана в алгоритме Конструктора.

Смотрите также:

Соединения с БД пользователя
Пример 2. Создание соединения с MySQL
Пример 3. Создание соединения с MS Excel версии 97, 2000
Пример 4. Создание соединения с MS Access
Пример 5. Создание соединения с текстовым файлом
Формат текстового файла данных


Пример 2. Создание соединения с MySQL

Для получения доступа к MySQL через OLE DB необходимо установить компонент MySQL Connector/ODBC
  1. В окне «Свойства соединения с БД» введите имя соединения.
  2. Укажите время тайм-аут.
  3. В параметрах соединения укажите один из следующих вариантов подключения:
    • Локальная база данных:
      Driver={MySQL ODBC 5.2s Driver}; Server=localhost; Database=имя БД; User=логин;Password=пароль; Option=3;
      В выделенных местах строки подключения укажите реальные имя БД, логин и пароль пользователя.
    • Удаленная база данных:
      Driver={MySQL ODBC 5.2a Driver}; Server=Адрес сервера MySQL; Database=имя БД; User=логин;Password=пароль; Option=3;
      В выделенных местах строки подключения укажите реальные адрес сервера MySQL (имя компьютера или IP), имя БД, логин и пароль пользователя.
  4. Соединение готово. В окне «Свойства соединения с БД» нажмите кнопку «OK».
Пример SQL запроса

select * from table1 where ID=~Var1~ limit 1

Этот запрос возвратит одну строку таблицы table1, у которой столбец ID равен значению переменной Var1. Переменная создана в алгоритме Конструктора.

Смотрите также:

Соединения с БД пользователя
Пример 1. Создание соединения с MS SQL
Пример 3. Создание соединения с MS Excel версии 97, 2000
Пример 4. Создание соединения с MS Access
Пример 5. Создание соединения с текстовым файлом
Формат текстового файла данных


Пример 3. Создание соединения с MS Excel версии 97, 2000

  1. В окне «Свойства соединения с БД» введите имя соединения.
  2. Укажите время тайм-аут.
  3. Определите строку соединения, нажав кнопку [image].
    1. 3.1. Выберите «Microsoft Jet 4.0 OLE DB Provider». Нажмите

    2. 3.2. Определите параметры подключения, указав расположение XLS файла:

    3. 3.3. Перейдите на закладку «Все».

    4. 3.4. Выберите строку «Extended Properties», нажмите кнопку «Изменить значение». В открывшемся окне введите «Excel 8.0», нажмите «OK».

    5. 3.5. В закладке «Подключение» нажмите «Проверить подключение». После успешной проверки нажмите «OK».
  4. Соединение готово. В окне «Свойства соединения с БД» нажмите кнопку «OK».
Пример SQL запроса

В качестве имени таблицы в SQL запросе к Excel файлу используется имя листа в формате [имя листа + символ доллара]. Например:
select * from [Лист1$]
Первая строка листа должна содержать имена колонок, например:

Используя эти имена, можно выполнять запросы с предложением WHERE, например:
select * from [Лист1$] where ID=~Var1~
Этот запрос возвратит строки листа Лист1, у которого столбец ID равен значению переменной Var1. Переменная создана в алгоритме Конструктора.

Формат даты в запросах следующий: #m/d/yyyy#, например:
select * from [Лист1$] where Сol=#12/31/2012#
При выполнении запроса UPDATE необходимо указать псевдоним для листа, например:
update [Лист1$] A set A.Col1 = 123 where A.ID = 1

Смотрите также:

Соединения с БД пользователя
Пример 1. Создание соединения с MS SQL
Пример 2. Создание соединения с MySQL
Пример 4. Создание соединения с MS Access
Пример 5. Создание соединения с текстовым файлом
Формат текстового файла данных


Пример 4. Создание соединения с MS Access

  1. В окне «Свойства соединения с БД» введите имя соединения.
  2. Укажите время тайм-аут.
  3. Определите строку соединения, нажав кнопку [image].
    1. 3.1. Выберите «Microsoft Jet 4.0 OLE DB Provider». Нажмите

    2. 3.2. Определите параметры подключения к базе данных:
      1. 3.2.1. Укажите MDB файл базы данных MS Access.
      2. 3.2.2. Проверьте подключение, нажав на кнопку «Проверить подключение». После успешной проверки нажмите «OK».

  4. Соединение готово. В окне «Свойства соединения с БД» нажмите кнопку «OK».
Пример SQL запроса

select * from table1 where ID=~Var1~

Этот запрос возвратит все строки таблицы table1, у которой столбец ID равен значению переменной Var1. Переменная создана в алгоритме Конструктора.

Смотрите также:

Соединения с БД пользователя
Пример 1. Создание соединения с MS SQL
Пример 2. Создание соединения с MySQL
Пример 3. Создание соединения с MS Excel версии 97, 2000
Пример 5. Создание соединения с текстовым файлом
Формат текстового файла данных


Пример 5. Создание соединения с текстовым файлом

Провайдер «Microsoft Jet 4.0 OLE DB Provider» позволяет обращаться к данным, находящимся в текстовом файле. Формат текстового файла описан в разделе «Формат текстового файла данных». Работа с текстовыми файлами имеет некоторые особенности:
  • В папке, где расположен текстовый файл с данными, также должен находиться файл «schema.ini», в котором описывается формат данных.
  • Текстовый файл открывается в режиме только для чтения, т.е. к данным нельзя применять SQL запрос UPDATE. Однако приложение может выполнять вставку новых строк в текстовый файл (SQL запрос INSERT).
  1. В окне «Свойства соединения с БД» введите имя соединения.
  2. Укажите время тайм-аут.
  3. Определите строку соединения, нажав кнопку [image].
    1. 3.1. Выберите «Microsoft Jet 4.0 OLE DB Provider». Нажмите

    2. 3.2. Укажите папку, в которой располагается текстовый файл:

    3. 3.3. Перейдите на закладку «Все».

    4. 3.4. Выберите строку «Extended Properties», нажмите кнопку «Изменить значение». В открывшемся окне введите «Text», нажмите «OK».

    5. 3.5. В закладке «Подключение» нажмите «Проверить подключение». После успешной проверки нажмите «OK».
  4. Соединение готово. В окне «Свойства соединения с БД» нажмите кнопку «OK».
Пример SQL запроса

Если в текстовом файле и файле описания «schema.ini» имена колонок не указаны, то провайдер «Microsoft Jet 4.0 OLE DB Provider» автоматически присвоит им имена F1, F2,..., FN, где N - количество колонок.
select * from text.txt where F1="some text"
Этот запрос возвратит все строки текстового файла text.txt, у которого первая колонка F1 равна «some text».

Если в текстовом файле и файле описания «schema.ini» определены имена колонок, то можно составить такой запрос:
select * from text.txt where ID=~Var1~
Этот запрос возвратит все строки текстового файла text.txt, у которого колонка ID равна значению переменной Var1. Переменная создана в алгоритме Конструктора.

Смотрите также:

Соединения с БД пользователя
Пример 1. Создание соединения с MS SQL
Пример 2. Создание соединения с MySQL
Пример 3. Создание соединения с MS Excel версии 97, 2000
Пример 4. Создание соединения с MS Access
Формат текстового файла данных


Формат текстового файла данных

Для правильного доступа к текстовому файлу необходимо использовать файл «schema.ini», в котором описывается формат данных. Этот файл должен находиться в папке, в которой расположен текстовый файл. Более подробно использование «schema.ini» описывается здесь: Schema.ini File (Text File Driver).

В текстовом файле данные должны быть представлены в виде таблицы. Каждая строка файла — это одна строка таблицы. Значения отдельных колонок разделяются разделительным символом, например точка с запятой (;).

Параметры файла «schema.ini»

В первой строке файла «schema.ini» должен быть указан текстовый файл с данными, например:
[text.txt]
Символ-разделитель определяется через параметр Format:
  • символ табуляции:
    Format=TabDelimited
  • произвольный символ (нельзя использовать символ кавычки «"»):
    Format=Delimited(символ)
  • длина колонок фиксированная:
    Format=FixedLength
Определить заголовок таблицы можно двумя путями:
  • Первая строка в текстовом файле содержит имена колонок. В этом случает необходимо определить параметр ColNameHeader=True:
    ColNameHeader=True
  • Определить каждую колонку в отдельности и указать имя, тип колонки и длину (параметр ColNameHeader=False). Каждая колонка описывается так:
    ColN=ИмяКолонки ТипКолонки Width ДлинаКолонки
    Например, первая колонка имеет имя Наименование, текстовый тип Text, длина 30 символов:
    Col1=Наименование Text Width 30
    Имя колонки, состоящее из двух и более слов, необходимо заключать в кавычки, например:
    Col1="Наименование товара" Text Width 30

Примеры текстовых файлов и описания «schema.ini»

  • Текстовый файл с именем «text.txt»:
    1;2;3;4;5
    6;7;8;9;10
    В этом файле 2 строки и 5 колонок, «;» - символ-разделитель, имена колонок не определены.
    Файл «schema.ini»:
    [text.txt]
    Format=Delimited(;)
    ColNameHeader=false
  • Текстовый файл с именем «text.txt»:
    Наименование|Количество
    Телевизор|10
    Пылесос|20
    Магнитола|30
    В этом файле 3 строки (не считая заголовка) и 2 колонки, «|» - символ-разделитель, имена колонок определены.
    Файл «schema.ini»:
    [text.txt]
    Format=Delimited(|)
    ColNameHeader=True
  • Текстовый файл с именем «data.csv»:
    Телевизор;10
    Пылесос;20
    Магнитола;30
    В этом файле 3 строки и 2 колонки, «;» - символ-разделитель, имена колонок не указаны.
    Файл «schema.ini»:
    [data.csv]
    Format=Delimited(;)
    ColNameHeader=False
    Col1="Наименование товара" Text
    Col2=Количество Long
    В «schema.ini» для колонок указывается только имя и тип.
  • Текстовый файл с именем «data.csv»:
    Телевизор;10
    Пылесос;20
    Магнитола;30
    В этом файле 3 строки и 2 колонки, «;» - символ-разделитель, имена колонок не указаны.
    Файл «schema.ini»:
    [data.csv]
    Format=Delimited(;)
    ColNameHeader=False
    Col1="Наименование товара" Text Width 10
    Col2=Количество Long Width 5
    В «schema.ini» для колонок указывается имя, тип и длина.

Смотрите также:

Соединения с БД пользователя
Пример 1. Создание соединения с MS SQL
Пример 2. Создание соединения с MySQL
Пример 3. Создание соединения с MS Excel версии 97, 2000
Пример 4. Создание соединения с MS Access
Пример 5. Создание соединения с текстовым файлом


Дерево меню

Раздел «Дерево меню» - это гибкий инструмент, позволяющий легко создавать алгоритмы голосового меню. Этот раздел имеет дружественный и наглядный интерфейс, благодаря чему даже неподготовленный пользователь сможет разрабатывать голосовое меню.

Дерево меню имеет несколько рабочих областей. В первой области отображается иерархия голосового меню в древовидной форме. Во второй области содержится описание меню, выбранное в области дерева.

Создание голосового меню

Контекстное меню

Вставить какое-либо меню в дерево можно двумя способами: используя панель инструментов или контекстное меню. В первом случае необходимо левой кнопкой мыши указать в дереве то меню, в которое будет вставляться новое, и затем на панели инструментов нажать кнопку, соответствующую нужному типу меню: общее меню [image], меню «Голосовая почта – Запись» [image] или меню «Голосовая почта – Прослушать» [image].

Во втором случае необходимо правой кнопкой мыши указать в дереве то меню, в которое необходимо вставить новое, в появившемся контекстном меню выбрать пункт «Добавить меню», затем пункт, соответствующий нужному типу меню: «Общее меню», «Голосовая почта – Запись» или «Голосовая почта – Прослушать».

Удаление меню производится через панель инструментов, контекстное меню или меню Клиента. Сначала нужно в дереве указать удаляемое меню, а затем на панели инструментов нажать кнопку «Удалить меню» [image] или в меню выбрать пункт «Удалить».

Также в дереве меню можно копировать, удалить, вырезать и вставлять ветки, переименовывать отдельные элементы меню, раскрывать и сжимать все элементы дерева. Эти функции доступны в контекстном меню или в меню Клиента.

Во время составления голосового меню Автосекретарь запоминает сделанные изменения. Эти изменения можно отменить или вернуть, используя меню Клиента («Правка/Отменить изменение» и «Правка/Вернуть изменение») или панель инструментов (кнопки [image] и [image]).

Сохранение, загрузка и компиляция

Сохранение разрабатываемого голосового меню выполняется нажатием на панели инструментов кнопки «Сохранить дерево меню в базу данных» [image] или через меню Клиента «Дерево меню/Сохранить...». Причем в базе данных сохраняется только само дерево меню, без алгоритма. В окне сохранения необходимо выбрать существующую программу или ввести имя новой:

Чтобы загрузить из базы данных дерево меню, нужно нажать на панели инструментов кнопку «Загрузить дерево меню из базы данных» [image] или выбрать в меню Клиента пункт «Дерево меню/Открыть...». Алгоритм, даже если он сохранен в программе, не загружается. Программа, из которой будет загружаться дерево меню, указывается в окне загрузки:

При составлении голосового меню можно периодически проверять его на наличие ошибок, нажимая кнопку «Проверить дерево меню на ошибки» [image] или используя меню Клиента «Дерево меню/Проверить на ошибки».

Удаление существующего дерева голосового меню выполняется кнопкой «Создать новое дерево меню» [image] или через меню Клиента «Дерево меню/Создать». Данные, находящиеся в БД, не изменяются.

После того как голосовое меню полностью разработано, его необходимо преобразовать в алгоритм (выполнить компиляцию). Эта операция выполняется нажатием на панели инструментов кнопки «Скомпилировать и сохранить дерево меню» [image] или выбором пункта в меню Клиента «Дерево меню/Компиляция...». Перед компиляцией Автосекретарь запросит имя программы, в которую будет сохранены дерево меню и алгоритм.

При компиляции Автосекретарь выполняет следующие действия:

  • проверка дерева меню на ошибки;
  • сохранение дерева меню в базе данных;
  • непосредственно компиляция;
  • проверка полученного алгоритма на ошибки;
  • сохранение алгоритма в базу данных.

Ход компиляции разработанного голосового меню отображается в отдельном окне:

Если во время компиляции обнаружится ошибка, то программа прервет компиляцию и выдаст поясняющее сообщение об ошибке.

После успешной компиляции преобразованное в алгоритм голосовое меню также отображается в Конструкторе. В Конструкторе пользователь может внести желаемые корректировки в алгоритм, а потом сохранить его в базу дынных. Успешно сохраненный алгоритм Сервер может выполнять на телефонном канале.

Импорт и экспорт дерева меню

Созданное дерево меню можно сохранить в отдельный файл (экспортировать). Эта операция выполняется через меню Клиента («Дерево меню/Экспорт...») или через панель инструментов (кнопка [image]). В экспортируемом файле сохраняется иерархия дерева меню, данные каждого элемента меню и используемые аудиофайлы.

Загрузка дерева меню из файла (импорт) выполняется через меню Клиента («Дерево меню/Импорт...») или через панель инструментов (кнопка [image]). Автосекретарь извлекает из указанного файла дерево меню, данные и аудиофайлы. Последние сохраняются в папке «Import\<название файла без расширения>», которая находится в директории Клиента.

Смотрите также:


Типы голосового меню

В Дереве меню существует шесть типов меню:

  • Главное меню
  • Общее меню
  • Меню «Голосовая почта – Запись»
  • Меню «Голосовая почта – Прослушать» уровень 1
  • Меню «Голосовая почта – Прослушать» уровень 2
  • Меню «Голосовая почта – Прослушать» уровень 3


Главное меню

В иерархии дерева главное меню находится на самом верхнем уровне, а все остальные меню расположены на втором и более низком уровне. Только в главном меню есть настройка, в которой определяется число гудков срабатывания алгоритма голосового меню. Меню этого типа в алгоритме встречается один раз.

В упрощенном виде ход выполнения алгоритма главного меню выглядит следующим образом (если не выбран донабор номера):

  1. Ожидать входящий звонок. После N гудка Автосекретарь снимет трубку.
  2. Произнести в телефонную линию звуковые данные.
  3. Ожидать ввод абонента для выбора пункта меню.
  4. Выполнить действие (набрать номер, перейти в меню и др.) для выбранного пункта меню.

При использовании донабора номера ход выполнения алгоритма будет таким:

  1. Ожидать входящий звонок. После N гудка Автосекретарь снимет трубку.
  2. Произнести в телефонную линию звуковые данные.
  3. Ожидать ввод абонента:
    • выбор пункта меню (занести значение в переменную «Var1»);
    • донабор номера (занести значение в переменную «Var2»).
  4. Если "Var2" не пустое, то..
    • переадресовать на номер «Var1» + «Var2» (выполнить действие Набрать номер),
    • иначе выполнить действие (набрать номер, перейти в меню и др.) для выбранного пункта меню.

Главное меню состоит из четырех пунктов.

В пункте №1 пользователь указывает, после какого гудка при входящем звонке Автосекретарь должен поднять трубку. Если количество гудков будет равно одному или нолю, то Автосекретарь снимет трубку после первого гудка.

В пункте №2 пользователь указывает, какой аудиофайл нужно проиграть в телефонную линию. Аудиофайл можно указать, введя его имя (и путь к нему, если нужно) в поле ввода, либо нажав на кнопки «Выбрать» или «Звуковой редактор». Кнопка «Выбрать» откроет окно, в котором пользователю нужно будет указать звуковой файл, находящийся на диске компьютера (формат PCM, расширение WAV, моно, 8 бит, 11025 кГц). Нажатие кнопки «Звуковой редактор» откроет программу, в которой пользователь сможет создать голосовую фразу, используя микрофон, и отредактировать ее. При сохранении созданной фразы в Звуковом редакторе через меню «Файл\Сохранить как...» имя файла автоматически будет скопировано в поле ввода.

В пункте №3 пользователь указывает, какой тип ввода использовать. Тип ввода «количество символов» означает, что Автосекретарь будет ждать, когда абонент введет нужное количество символов на телефоне. Тип ввода «до завершающего символа» означает, что Автосекретарь будет ожидать, пока абонент не нажмет завершающий символ (выбирается из всплывающего списка). После того как абонент завершит ввод, Автосекретарь перейдет к следующему пункту. Введенные абонентом символы (исключая завершающий символ, если использован этот тип ввода), Автосекретарь запоминает в переменной, имя которой указывается в соответствующем поле. Если выбран донабор, то Автосекретарь ждет ввода дополнительных символов. Когда сумма кол-ва символов в «Var1» и «Var2» будет равной указанному кол-ву цифр в номере, Автосекретарь выполнит переадресацию на введенный номер. Параметры переадресации указываются по кнопке «Настройка донабора».

После того как абонент с помощью телефона введет символы, Автосекретарь сравнит их со значениями, указанными в колонке «Значения» таблицы, находящейся в пункте №4. В поле «Количество значений» пользователь, разрабатывающий голосовое меню, определяет, сколько действий могут быть выполнены Автосекретарем. В колонке «Действие» таблицы из всплывающего списка пользователь выбирает действие, которое будет выполнено Автосекретарем, если абонент введет символы, совпадающие со значением из соответствующей колонки. В колонке «Примечание» можно занести пояснения к указанному действию и значению. Эта информация является необязательной и используется только для повышения информативности разрабатываемого голосового меню.

Если абонент ввел символы, которых нет среди значений таблицы, то Автосекретарь выполнит действие, выбранное из всплывающего списка, находящегося сразу после таблицы (поле «если Абонент ввел значение, которого нет среди перечисленных выше»).

Действие, указанное в поле «если вышло время ожидания ввода (тайм-аут)», выполнится, если абонент за указанное в пункте №3 время не введет какой-либо символ1.

Смотрите также:

Типы голосового меню
Дерево меню
Действия

Прим. 1. Это время распространяется на каждый символ в отдельности. Т.е. Автосекретарь будет ждать ввода очередного символа в течение времени «тайм-аут».


Общее меню

Общее меню отличается от главного только тем, что не имеет настройки числа гудков. Поэтому меню данного типа не может быть первым в алгоритме, и всегда будет находится на втором или более низком уровне в иерархии дерева меню. Общее меню может неограниченное число раз вставляться в голосовое меню.

В упрощенном виде ход выполнения алгоритма общего меню выглядит следующим образом:

  1. При входе в меню произнести в телефонную линию звуковые данные.
  2. Ожидать ввод абонента.
  3. Выполнить действие (набрать номер, перейти в меню и др.) в зависимости от того, что ввел абонент.

Описание пунктов №1-3 общего меню совпадает с аналогичными пунктами в главном меню.

Отдельные пункты общего меню могут быть отключены. В этом случае они не будут добавлены в алгоритм при компиляции. Отключение пунктов меню может понадобиться, например, если необходимо на некоторое значение, введенное абонентом, проиграть аудиофайл и выполнить безусловное действие (в этом случае включенным останется только пункт №1).

Смотрите также:


Меню «Голосовая почта – Запись»

Этот тип меню используется для сохранения голосовых сообщений (ГС).

В упрощенном виде ход выполнения алгоритма меню записи ГС выглядит следующим образом:

  1. При входе в меню произнести в телефонную линию фразу типа «Сейчас мы не можем ответить, оставьте сообщение после звукового сигнала» и записать ГС для пользователя.
  2. После записи ГС произнести возможные действия над сообщением:
    • прослушать сообщение снова – нажмите «1»
    • переписать сообщение – нажмите «2»
    • удалить сообщение и вернуться в предыдущее меню – нажмите «3»
  3. Ожидать ввод абонента.
  4. Выполнить действие в зависимости от того, что ввел абонент:
    • прослушать ГС
    • перезаписать ГС
    • удалить ГС и вернуться в предыдущее меню

В пункте №1 этого типа меню кроме аудиофайла также необходимо указать имя пользователя, для которого будет оставлено сообщение. Голосовые сообщения могут быть сохранены только для тех, кто зарегистрирован в системе Автосекретаря как пользователь. Имя пользователя выбирается из всплывающего списка.

Если в алгоритме в любом из меню есть действие «Набрать номер», то в списке пользователей также появится переменная «%@VarLogin%». При выборе из всплывающего списка этой переменной сообщение будет сохранено для пользователя, логин которого содержится в этой переменной. Значение этой переменной определяется в одном из параметров действия «Набрать номер».

Пункт №2 уже содержит имя звукового файла. При желании пользователь может задать свой аудиофайл.

Описание пункта №3 кроме поля, определяющего имя переменной, совпадает с описанием аналогичного пункта главного меню.

В пункте №4 предопределено количество значений и перечень действий. Параметр «количество значений» может принимать значение «3» и более. Первые три действия в таблице изменять нельзя, можно лишь изменять значение и примечание.

Смотрите также:


Меню «Голосовая почта – Прослушать (уровень 1)»

Прослушивание сохраненных голосовых сообщений через телефон реализовано с помощью трехуровневого меню. Меню первого уровня описывается в данном разделе. Оно предназначено для ввода номера ящика голосовой почты.

В упрощенном виде ход выполнения алгоритма этого меню выглядит следующим образом:

  1. При входе в меню произнести в телефонную линию фразу типа «Введите номер ящика голосовой почты».
  2. Ожидать ввода номера ящика. Если ящик с введенным номером не найден, то произнести в телефонную линию фразу типа «Ящик голосовой почты с таким номером не найден» и вернуться к шагу 1.
  3. Перейти в меню «Голосовая почта – Прослушать (уровень 2)».

В пункте №1 указаны аудиофайлы с заранее подготовленными фразами. При желании пользователь может использовать свои собственные аудиофайлы.

Пункт №2 содержит предопределенный тип ввода. Пользователь может изменять только завершающий символ и время «тайм-аут».

Таблица из пункта №3 в данном типе меню не используется. Пользователь может изменять только действие в случае истечения времени «тайм-аут».

После ввода и успешной проверки номера ящика голосовой почты Автосекретарь автоматически переходит в меню «Голосовая почта – Прослушать (уровень 2)».

Смотрите также:


Меню «Голосовая почта – Прослушать (уровень 2)»

Это меню предназначено для ввода пароля и управления ящиком голосовой почты. Находясь в этом меню, после успешного ввода пароля абонент может удалить ГС (все или только прослушанные) или войти в меню прослушивания (уровень 3).

В упрощенном виде ход выполнения алгоритма этого меню выглядит следующим образом:

  1. При входе в меню произнести в телефонную линию фразу типа «Введите пароль».
  2. Ожидать ввода пароля. Если введен неправильный пароль, то произнести в телефонную линию фразу типа «Набран неверный пароль» и вернуться к шагу 1.
  3. После успешного ввода пароля произнести возможные действия над ящиком голосовой почты
    • прослушать сообщения – нажмите «1»
    • удалить все сообщения – нажмите «2»
    • удалить прослушанные сообщения – нажмите «3»
    • вернуться в предыдущее меню – нажмите #
  4. Ожидать ввод абонента.
  5. Выполнить действие в зависимости от того, что ввел абонент:
    • перейти в меню «Голосовая почта – Прослушать (уровень 3)»
    • удалить все сообщения
    • удалить прослушанные сообщения
    • вернуться в предыдущее меню

В пункте №1 указаны аудиофайлы с заранее подготовленными фразами. При желании пользователь может использовать свои собственные аудиофайлы.

Пункт №2 содержит предопределенный тип ввода. Пользователь может изменять только завершающий символ и время «тайм-аут».

В пункте №3 указан заранее подготовленный аудиофайл. Если нужно, пользователь может использовать собственную фразу.

Описание пункта №4 кроме поля, определяющего имя переменной, совпадает с описанием аналогичного пункта главного меню.

В пункте №5 предопределено количество значений и перечень действий. Параметр «количество значений» может принимать значение «4» и более. Первые четыре действия в таблице изменять нельзя, можно лишь изменять значение и примечание.

Смотрите также:


Меню «Голосовая почта – Прослушать (уровень 3)»

Это меню используется для прослушивания отдельных голосовых сообщений, содержащихся в ящике, определенном в меню «Голосовая почта – Прослушать» уровня 1 и 2.

В упрощенном виде ход выполнения алгоритма этого меню выглядит следующим образом:

  1. При входе в меню выполнить:
    1. Произнести возможные действия во время прослушивания ГС:
      1. на 5 сек. назад –нажмите «7»
      2. на 5 сек. вперед – нажмите «9»
      3. приостановить/продолжить прослушивание – нажмите *
      4. завершить прослушивание – нажмите #
    2. проиграть в телефонную линию ГС
    3. произнести дату и время записи ГС1
    4. произнести возможные действия по перемещению между ГС:
      1. прослушать сообщение снова – нажмите «1»
      2. прослушать предыдущее сообщение – нажмите «4»
      3. прослушать следующее сообщение – нажмите «6»
      4. удалить сообщение – нажмите «5»
      5. вернуться в предыдущее меню – нажмите #
  2. Ожидать ввод абонента.
  3. Выполнить действие в зависимости от того, что ввел абонент:
    1. повторить ГС (перейти к шагу 1.2)
    2. прослушать предыдущее ГС
    3. прослушать следующее ГС. Если абонент прослушал все сообщения, то произнести фразу типа «Достигнут конец списка сообщений» и перейти к шагу 1.4
    4. удалить прослушанное ГС. Если после удаления ящик окажется пустым, то произнести фразу типа «Ящик голосовой почты пуст» и вернуться в предыдущее меню
    5. вернуться в предыдущее меню

В пункте №1 указаны аудиофайлы с заранее подготовленными фразами. При желании пользователь может использовать свои собственные аудиофайлы. Также в этом пункте имеется настройка, определяющая, когда произносить дату и время записи ГС: перед прослушиванием, после него или вообще не произносить. Также эта настройка определяет формат произносимой даты. Она вызывается нажатием на кнопку «Установить», находящейся напротив текста «Произнести дату и время записи сообщения в формате».

Описание пункта №2 кроме поля, определяющего имя переменной, совпадает с описанием аналогичного пункта главного меню.

В пункте №3 предопределено количество значений и перечень действий. Параметр «количество значений» может принимать значение «5» и более. Первые пять действий в таблице изменять нельзя, можно лишь изменять значение и примечание.

Смотрите также:

Типы голосового меню
Дерево меню
Действия
Голосовая почта

Прим. 1. В этом меню имеется настройка, которая указывает, когда произносить дату и время записи ГС: перед прослушиванием ГС, после него или вообще не произносить.


Действия

Автосекретарь в ответ на введенные абонентом символы выполняет различные действия. Их перечень зависит от типа меню, в котором они устанавливаются.

Действия «Перейти в меню», «Набрать номер», «Вызвать подпрограмму» имеют параметры, которые определяются в отдельном окне. Это окно появляется сразу после указания во всплывающем списке одного из этих действий.

Список и описание действий

  • действие «Перейти в меню...»
    • Параметр: имя меню.
    • Описание: выполняет переход в меню, имя которого указано в параметре. Меню выбирается из всплывающего списка, содержащего имена только «дочерних» меню.
    • Используется в типах меню: главное меню, общее меню, меню прослушивания ГС уровня 2.

  • действие «На уровень вверх»
    • Описание: выполняет переход в предыдущее меню (в «родительское» меню).
    • Используется в типах меню: общее меню, меню записи ГС, меню прослушивания ГС уровней 1, 2 и 3.

  • действие «На первый уровень»
    • Описание: выполняет переход в главное меню.
    • Используется в типах меню: общее меню, меню записи ГС, меню прослушивания ГС уровней 1, 2 и 3.

  • действие «Прослушать снова»
    • Описание: Автосекретарь переходит к тому месту алгоритма в текущем меню, в котором проигрывается аудиофайл.
    • Используется в типах меню: все.

  • действие «Набрать номер...»
    • Параметры: номер телефона, логин пользователя, контроль, имя меню 1, имя меню 2, тайм-аут.
    • Описание: выполняет набор телефонного номера. Использование в номере символа «F» аналогично нажатию на телефонном аппарате кнопки «Flash». Если параметр «Контроль» определен как «НЕТ», то после набора номера Автосекретарь положит трубку и перейдет в начало алгоритма. Если «Контроль» равен «ЕСТЬ», то Автосекретарь будет ожидать ответ вызываемого абонента в течение времени «тайм-аут». В этом случае возможны три варианта: абонент занят - выполнится переход в меню 1, абонент не отвечает (вышло время «тайм-аут») - выполнится переход в меню 2, абонент ответил - Автосекретарь положит трубку и перейдет в начало алгоритма. Меню выбираются из всплывающего списка, в котором содержатся только «дочерние» меню. В меню 1 и 2 можно вставить меню для записи ГС. В этом случае в меню записи ГС укажите в качестве логина переменную «%@VarLogin%», тогда сообщение будет сохранено для пользователя, логин которого указан в параметре данного действия.
    • Используется в типах меню: главное меню, общее меню.

  • действие «Завершить разговор»
    • Описание: Автосекретарь «кладет» трубку и переходит в начало алгоритма
    • Используется в типах меню: все.

  • действие «Вызвать подпрограмму...»
    • Параметр: имя подпрограммы.
    • Описание: выполняет алгоритм указанной в параметре подпрограммы. Подпрограмма выбирается из всплывающего списка параметра. Создание подпрограмм осуществляется с помощью Конструктора.
    • Используется в типах меню: все.

  • действие «Повторить ввод»
    • Описание: выполняет переход на то место в алгоритме текущего меню, в котором ожидается ввод абонента.
    • Используется в типах меню: все.

  • действие «Прослушать ГС»
    • Описание: выполняет прослушивание голосового сообщения, после того как абонент сохранил его для пользователя.
    • Используется в типах меню: меню записи ГС.

  • действие «Перезаписать ГС»
    • Описание: выполняет перезапись только что сохраненного голосового сообщения.
    • Используется в типах меню: меню записи ГС.

  • действие «Удалить ГС»
    • Описание: удаляет голосовое сообщение.
    • Используется в типах меню: меню записи ГС, меню прослушивания ГС уровня 3.

  • действие «Удалить все сообщения»
    • Описание: удаляет все сообщения, находящиеся в ящике голосовой почты.
    • Используется в типах меню: меню прослушивания ГС уровня 2.

  • действие «Удалить прослушанные сообщения»
    • Описание: удаляет только прослушанные сообщения ящика голосовой почты.
    • Используется в типах меню: меню прослушивания ГС уровня 2.

  • действие «Повторить сообщение»
    • Описание: выполняет повторное прослушивание голосового сообщения.
    • Используется в типах меню: меню прослушивания ГС уровня 3.

  • действие «Предыдущее сообщение»
    • Описание: выполняет прослушивание предыдущего сообщения.
    • Используется в типах меню: меню прослушивания ГС уровня 3.

  • действие «Следующее сообщение»
    • Описание: выполняет прослушивание следующего сообщения
    • Используется в типах меню: меню прослушивания ГС уровня 3.

Смотрите также:


Конструктор

Конструктор предназначен для составления алгоритма голосового меню. Он создает графическое представление алгоритма, наглядно показывающее, как будут выполняться команды программы. Инструментарий Конструктора очень гибок, что дает пользователю возможность создавать практически любой алгоритм в рамках имеющихся команд.

С помощью Конструктора можно не только разрабатывать алгоритм Автосекретаря, но также составлять подпрограммы, которые могут быть использованы в дереве меню как часть общего алгоритма.

В Конструкторе можно выделить несколько рабочих областей: 1 – панель команд, 2 – поле алгоритма, 3 – свойства команды, 4 – описание команды и ее параметров.

Создание алгоритма

Алгоритм создается следующим образом: сначала необходимо выбрать команду на панели команд, потом в поле алгоритма указать на связь (голубая линия между командами), куда необходимо вставить новую команду, и, если нужно, настроить параметры команды в области свойства команды (установка команды «Перейти к метке» имеет некоторые отличия, подробности см. в описании команды в разделе «Список и описание команд алгоритма»).

Отмена текущего действия осуществляется нажатием на панели команд кнопки «Отменить действие» [image], удаление команды производится после нажатия кнопки «Удалить команду» [image].

Многие команды алгоритма имеют различные параметры. Они настраиваются в области свойства команды двумя способами: с использованием всплывающего списка и редактируемого поля.

Во время составления алгоритма Автосекретарь запоминает сделанные изменения. Эти изменения можно отменить или вернуть, используя меню Клиента («Правка/Отменить изменение» и «Правка/Вернуть изменение») или панель инструментов (кнопки [image] и [image]).

В Конструкторе пользователь может выделять команды, используя прямоугольник выделения (удерживается левая кнопка мыши и выбираются команды) или клавиши CTRL и SHIFT.

Контекстное меню

В Конструкторе можно копировать, удалять, вырезать и вставлять выделенные команды. Эти операции доступны в контекстном меню или в меню Клиента.

Сохранение и загрузка

После того как алгоритм был разработан, его необходимо сохранить в базу данных. На панели инструментов необходимо нажать кнопку «Сохранить алгоритм в базе данных» [image] (или в меню Клиента выбрать пункт «Конструктор/Сохранить...»), указать тип алгоритма (программа или подпрограмма) и его имя. Перед сохранением всегда осуществляется проверка алгоритма на ошибки.

Если алгоритм сожержит команды «Выполнить SQL запрос» и «Выполнить скрипт Visual Basic» и если длина текста в них больше 100 символов, то такой алгоритм нельзя сохранить как подпрограмму.

Конструктор позволяет изменять алгоритм, который уже был сохранен в базе данных. Для этого необходимо загрузить его в Конструктор. Выберите в меню Клиента пункт «Конструктор/Открыть...» или на панели инструментов нажмите на кнопку «Загрузить алгоритм из базы данных» [image], выберите имя из списка программ или подпрограмм.

При конструировании алгоритма можно периодически проверять его на наличие ошибок, нажав на панели инструментов кнопку «Проверить алгоритм на ошибки» [image] или выбрав в меню Клиента пункт «Конструктор/Проверить на ошибки».

Удаление существующего алгоритма выполняется кнопкой «Создать новый алгоритм» [image], при этом алгоритм, находящийся в БД, не изменяется.

Импорт и экспорт алгоритма

Созданный алгоритм можно сохранить в отдельный файл (экспортировать). Эта операция выполняется через меню Клиента («Конструктор/Экспорт...») или через панель инструментов (кнопка [image]). В экспортируемом файле сохраняются все команды, их параметры, а также используемые аудиофайлы.

Загрузка алгоритма из файла (импорт) выполняется через меню Клиента («Конструктор/Импорт...») или через панель инструментов (кнопка [image]). Автосекретарь извлекает из указанного файла команды и аудиофайлы. Последние сохраняются в папке «Import\<название файла без расширения>», которая находится в директории Клиента.

Смотрите также:


Список и описание команд алгоритма

Вкладка «События»
Команды этой вкладки ожидают некоторое событие и при его наступлении передают управление следующей команде.

Ожидать дозвон
Параметры: количество дозвонов N.
Описание: команда ожидает входящие звонки и после N дозвонов (гудков) снимает трубку и передает управление следующей команде. Число N не должно быть отрицательным. Если с помощью команды Зафиксировать событие установлено «HandsetTakeOff», то трубка не будет поднята.

Ждать действия абонента
Параметры: имя переменной Var, время ожидания N.
Описание: команда ожидает действие вызываемого абонента. Возможны следующие варианты: вызываемый абонент взял трубку – переменная Var примет значение «0», абонент занят – Var будет равна «1», вышло время ожидания – Var будет содержать «2». Имя переменной Var может содержать английские и русские буквы, цифры и знак подчеркивания «_», но оно не должно начинаться с цифры. Время ожидания N измеряется в секундах, и оно не должно быть отрицательным. Эта команда используется только после выполнения команды Набрать номер.

Ввод символа(ов) до завершающего символа
Параметры: имя переменной Var, символ завершения, время ожидания N, значение по умолчанию Val.
Описание: команда ожидает ввода символов (DTMF сигналов) абонентом. Ввод прекращается нажатием символа завершения, который выбирается из всплывающего списка. Результат ввода (исключая символ завершения) заносится в переменную Var. В качестве символа завершения можно использовать цифры от «0» до «9», буквы «A», «B», «C», «D» и символы «*», «#». Если за время N абонент не введет ни одного символа, то команда завершится, и переменная Var примет значение по умолчанию Val. Отсчет времени ожидания начинается после каждого нажатия символа. Параметр N измеряется в секундах, и он не должен быть отрицательным.

Ввод заданного числа символов
Параметры: имя переменной Var, количество символов N1, время ожидания N2, значение по умолчанию Val.
Описание: команда ожидает ввода символов (DTMF сигналов) абонентом. Ввод завершится после того, как абонент введет определенное количество символов. Результат ввода содержится в переменной Var. Количество символов N1 должно быть больше ноля. Если за время N2 абонент не введет ни одного символа, то команда завершится, и переменная Var примет значение по умолчанию Val. Отсчет времени ожидания начинается после каждого нажатия символа. Параметр N2 измеряется в секундах, и он не должен быть отрицательным.

Вкладка «Действия»
Команды этой вкладки выполняют конкретные действия, вызывая внутренние команды устройства SpRecord.

Набрать номер
Параметры: номер телефона Num.
Описание: команда набирает номер телефона Num. Номер может содержать следующие символы: «0»..«9», «A», «B», «C», «D», «*», «#», «F» (кнопка Flash), «P» (в начале номера, импульсный набор), «T» (в начале номера, тоновый набор), «,» (пауза 1 сек.). Длительность Flash-паузы задается в разделе «Сервер/Настройка». Также внутри номера можно включать переменные, выделенные символом «%» («процент»). Например, пусть параметр Num содержит «123 %Var1% 1321». При наборе номер будет преобразован следующим образом: «123» плюс значение переменной Var1 (например «102») плюс «1321», т.е. в результате номер будет содержать «1231021321». Пробелы игнорируются. С помощью контекстного меню параметра можно вставить существующие переменные в набираемый номер.

Взять трубку
Параметры: нет.
Описание: команда замыкает шлейф телефонной линии (поднимает телефонную трубку).

Положить трубку
Параметры: нет.
Описание: команда размыкает шлейф телефонной линии (кладет телефонную трубку).

Проиграть аудиофайл
Параметры: имя файла File.
Описание: проиграть аудиофайл в телефонную линию. Имя файла (вместе с путем) должно быть меньше 100 символов. Аудиофайл должен иметь следующий формат: несжатый PCM (как правило, с расширением «WAV»), частота 11,025 кГц, 8 бит, моно. Звуковые данные можно передавать в телефонную линию только при поднятой трубке телефона (см. команду Взять трубку). Если во время проигрывания абонент нажал кнопку телефона, то проигрывание немедленно прекращается, а введенный символ запоминается. Этот символ будет автоматически передан следующей команде ожидания ввода. В параметре File можно указать следующее:
  • конкретное имя файла. Файл должен находиться на компьютере, на котором создается алгоритм голосового меню. При сохранении алгоритма указанный аудиофайл копируется на компьютер Сервера SpRobot. Используя контекстное меню параметра, можно открыть Звуковой редактор. Если параметр содержит имя файла, то редактор откроет этот файл. При сохранении аудиофайла в редакторе (пункт меню «Файл/Сохранить как») его имя будет автоматически прописано в параметре.
  • имя файла по шаблону (маске) с использованием переменных. В этом случае звуковые файлы должны находиться на компьютере, где установлен Сервер SpRobot. Имя файла должно содержать переменные, выделенные символом «%» («процент»). Например, пусть параметр File содержит «c:\audio\file%Var1%.wav». При выполнении команды имя будет преобразовано следующим образом: «c:\audio\file» плюс значение переменной Var1 (например «1») плюс «.wav», т.е. в результате имя файла будет «c:\audio\file1.wav».

Получить определившийся номер
Параметры: имя переменной Var.
Описание: команда возвращает в переменной Var номер звонящего абонента, если он определился АОНом. Если номер не был определен к моменту вызова команды, то переменная будет содержать «0».

Вкладка «Служебные»
В эту группу входят команды, реализация которых не связана с вызовом внутренних команд устройства SpRecord.

Условие «Если равно»
Параметры: имя переменной, значение Val.
Описание: команда сравнивает переменную со значением Val. Если они равны, то будут выполнятся команды в ветке «Да», иначе – в ветке «Нет» (см. рис. ниже). Переменная выбирается из всплывающего списка. Также внутри значения Val можно включать переменные, выделенные символом «%».

Выход из программы
Параметры: нет.
Описание: команда завершает работу алгоритма.

Метка
Параметры: имя метки Lab.
Описание: метка устанавливается в то место алгоритма, в которое планируется осуществить переход (см. команду Перейти к метке). Имя метки Lab может содержать английские и русские буквы, цифры и знак подчеркивания «_», но оно не должно начинаться с цифры.

Перейти к метке
Параметры: имя метки.
Описание: команда осуществляет переход в алгоритме на указанную метку. Метка выбирается из всплывающего списка. При выборе этой команды в панели команд вначале необходимо указать в алгоритме метку, на которую планируется осуществить переход, а после этого установить команду перехода в алгоритме. Таким образом перед использованием этой команды алгоритм уже должен содержать необходимую метку.

Пауза
Параметры: задержка N.
Описание: команда выполняет задержку на N миллисекунд. Напомню, что в 1 секунде содержится 1000 миллисекунд (мсек.). Задержка N не должна быть меньше ноля. Если во время этой команды появится тоновый сигнал "Занято", то SpRobot либо прервет ее выполнение и перейдет в начало алгоритма, либо будет ожидать все указанное время без прерывания. Это поведение регулируется в команде Зафиксировать событие (по умолчанию команда "Пауза" не реагирует на сигнал "Занято").

Перейти в начало алгоритма
Параметры: нет.
Описание: команда переходит в начало алгоритма и выполняет первую команду.

Зафиксировать событие
Параметры: тип события, текст Val.
Описание: команда записывает сообщение с текстом Val в журнал событий (см. раздел «Журнал событий»). Тип события выбирается пользователем из всплывающего списка. Текст может содержать любые символы и переменные, выделенные символом «%» («процент»). Эта команда используется при формировании отчетов для фиксации различных событий (см. раздел «Отчеты»). Также с помощью этой команды можно изменять различные настройки Автосекретаря. Для этого необходимо:
  1. выбрать тип «Событие пользователя»;
  2. в параметре Val написать одно из следующих значений:
    • SetSensDTMF - реагировать на DTMF при проигрывании аудиофайла;
    • ResetSensDTMF - не реагировать на DTMF при проигрывании аудиофайла;
    • DefaultSensDTMF - установить значение, указанное в настройках дозвона;
    • HandsetTakeOn - команда Ожидать дозвон после прихода N-ого гудка поднимет трубку;
    • HandsetTakeOff - команда Ожидать дозвон после прихода N-ого гудка не будет поднимать трубку.
    • Dial "<имя_канала>" <режим> - указать режим набора номера: тоновый или импульсный. Имя канала - это имя, прописанное в устройстве SpRecord, например "T4002061 - 1" (не путать с именем канала пользователя). При указании канала кавычки обязательны, регистр букв в имени учитывается. Режим - может принимать значения: tone или pulse.

      Пример. Чтобы на канале "T4002030 - 1" набор номера производился в тоновом режиме, в параметре Val необходимо написать следующее:

      Dial "T4002030 - 1" Tone

    • PauseReactBusy - в команде Пауза реагировать на тоновый сигнал "Занято";
    • PauseNoReactBusy - в команде Пауза не реагировать на тоновый сигнал "Занято" (по умолчанию не реагировать).

Создать переменную
Параметры: имя переменной Var.
Описание: команда создает переменную с именем Var и делает ее доступной другим командам алгоритма. Если переменная с именем Var уже существует, то команда сразу завершается и передает управление следующей команде.

Установить значение переменной
Параметры: имя переменной, значение Val.
Описание: команда присваивает переменной значение Val. Значение также может содержать переменные, выделенные символом «%» («процент»). Переменная выбирается из всплывающего списка.

Увеличить значение переменной на 1
Параметры: имя переменной.
Описание: команда увеличивает значение переменной на 1. Переменная выбирается из всплывающего списка.

Выполнить SQL запрос
Параметры: имя соединения с БД, текст запроса, имя переменной Var1, имя переменной Var2.
Описание: команда выполняет SQL запрос к базе данных пользователя. Настройка соединения выполняется в разделе «Программы/Список/Соединения с БД пользователя». Имя соединения выбирается из списка. В тексте запроса можно указать переменные, созданные в алгоритме Конструктора. В запросе имена переменных необходимо заключить между символами «~» (тильда), например:
SELECT * FROM table1 WHERE column1=~UserVar~
Также в запросе можно указать предопределенные переменные:
  • ~VcMailFileName~ имя файла последнего записанного голосового сообщения;
  • ~RecordFileName~ имя файла записанного телефонного разговора;
  • ~GetChannelName~ имя канала SpRecord, на котором выполняется алгоритм Автосекретаря;
  • ~GetPrgID~ идентификатор алгоритма Автосекретаря (поле «Code» таб. «Programs»);
  • ~ANI~ определившийся номер АОН.
Например:
INSERT INTO Table (Col1, Col2, Col3) VALUES ('~ANI~', '~RecordFileName~', '~VcMailFileName~')
После выполнения команды переменная Var1 содержит результат: 0 - ошибка, 1 - успешное выполнение. Если запрос возвращает набор данных (например, используется запрос SELECT), то переменная Var2 будет содержать количество записей в этом наборе. Если запрос выполнился с ошибкой или не вернул набор данных, то Var2 будет равна 0. Var1 и Var2 выбираются из всплывающего списка.

Также вместо текста запроса можно указать файл, в котором он содержится. Этот файл должен находиться на компьютере, где установлен Сервер SpRobot. Для указания файла напишите в фигурных скобках следующее: слово «FILE», двоеточие и имя файла, например:
{FILE:C:\SomeFolder\SomeQuery.sql}

Получить значение из SQL выборки
Параметры: имя столбца, имя переменной.
Описание: команда извлекает из SQL выборки значение, содержащееся в указанном столбце, и сохраняет его в переменной. Набор данных SQL выборки формируется командой «Выполнить SQL запрос». Если набор дынных содержит более одной записи, то значение будет взято из первой записи. Если указанный столбец отсутствует в выборке или выборка не определена, то переменная будет содержать пустую строку.

Выполнить скрипт Visual Basic
Параметры: текст скрипта, имя переменной.
Описание: команда выполняет скрипт Visual Basic. В переменную заносится результат выполнения: 0 - ошибка, 1 - успех. В скрипте можно оперировать данными, содержащимися в алгоритме автосекретаря:
  • SpRobot.Vars("имя_переменной") - получить/установить значение переменной, созданной в Конструкторе;
  • SpRobot.ANI - получить определившийся номер АОН;
  • SpRobot.GetChannelName - получить имя канала SpRecord, на котором выполняется алгоритм Автосекретаря;
  • SpRobot.GetPrgID - получить идентификатор алгоритма Автосекретаря (поле «Code» таб. «Programs»);
  • SpRobot.RecordFileName - получить имя файла записанного телефонного разговора;
  • SpRobot.VcMailFileName - получить имя файла последнего записанного голосового сообщения;
  • SpRobot.PrgIsRun("имя_канала_в_устройстве") - узнать, запущен ли алгоритм SpRobot на указанном канале: 0 - не запущен, 1 - запущен;
  • SpRobot.GetChannelState("имя_канала_в_устройстве") - получить состояние канала:
    • -1 - канал не найден;
    • 0 - линия отключена;
    • 1 - трубка положена;
    • 2 - трубка поднята;
    • 3 - ошибка определения состояния, повторите попытку позже.
Например, следующий скрипт записывает некоторые данные Автосекретаря в файл «output.log»:
Dim oFso, oMyFile, TempVar
Set oFso = CreateObject("Scripting.FileSystemObject")
Set oMyFile = oFso.OpenTextFile("C:\output.log", 8 , True)

' сохранить имя файла записанного телефонного разговора
oMyFile.WriteLine("Запись разговора: " & SpRobot.RecordFileName)

' сохранить имя файла последнего записанного голосового сообщения
oMyFile.WriteLine("Запись голосового сообщения: " & SpRobot.VcMailFileName)

' получить состояние канала
oMyFile.WriteLine("Состояние канала: " & SpRobot.GetChannelState("T4001234 - 1"))

' получить значение переменной Var1, созданной в Конструкторе Автосекретаря
TempVar = SpRobot.Vars("Var1")

' изменить значение переменной Var1, созданной в Конструкторе Автосекретаря
SpRobot.Vars("Var1") = "9" & TempVar

oMyFile.Close
Set oMyFile = Nothing
Set oFso = Nothing
Также вместо текста скрипта можно указать файл, в котором он содержится. Этот файл должен находиться на компьютере, где установлен Сервер SpRobot. Для указания файла напишите в фигурных скобках следующее: слово «FILE», двоеточие и имя файла, например:
{FILE:C:\SomeFolder\SomeScript.vbs}

Показать сообщение
Параметры: пользователь(и) Val1, текст сообщения Val2.
Описание: команда отображает сообщение с текстом Val2 для указанных пользователей (Val1). Сообщение будет показано только в открытой программе Автосекретарь SpRobot. Вид сообщения (обычное или всплывающее окно) и другие параметры указываются в меню «Система/Параметры». Пользователи должны быть зарегистрированы в системе Автосекретарь SpRobot. В параметре Val1 можно указать одного пользователя, несколько пользователей (через запятую) или пустое значение. В последнем случае сообщение будет показано всем авторизованным пользователям. Параметр Val2 содержит текст сообщения. Val1 и Val2 могут содержать переменные, заключенные в символ процента «%».

Также вместо текста сообщения можно указать файл, в котором он содержится. Этот файл должен находиться на компьютере, где установлен Сервер SpRobot. Для указания файла напишите в фигурных скобках следующее: слово «FILE», двоеточие и имя файла, например:
{FILE:C:\SomeFolder\SomeMessage.txt}

Запустить внешнее приложение
Параметры: пользователь(и) Val1, имя файла File, параметры запуска Val2.
Описание: команда запускает внешнее приложение File для указанных пользователей (Val1). Внешнее приложение будет запущено, если открыта программа Автосекретарь SpRobot. Пользователи должны быть зарегистрированы в системе Автосекретарь SpRobot. В параметре Val1 можно указать одного пользователя, несколько пользователей (через запятую) или пустое значение. В последнем случае сообщение будет показано всем авторизованным пользователям. Val2 содержит строку параметров, которая будет передана внешнему приложению при запуске. Параметры Val1, File и Val2 могут содержать переменные, заключенные в символ процента «%».

Показать HTML страницу
Параметры: пользователь(и) Val1, текст HTML страницы Val2.
Описание: команда отображает HTML страницу с текстом Val2 для указанных пользователей (Val1). Сообщение будет показано только в открытой программе Автосекретарь SpRobot. Вид сообщения (обычное или всплывающее окно) и другие параметры указываются в меню «Система/Параметры». Пользователи должны быть зарегистрированы в системе Автосекретарь SpRobot. В параметре Val1 можно указать одного пользователя, несколько пользователей (через запятую) или пустое значение. В последнем случае сообщение будет показано всем авторизованным пользователям. Val1 может содержать переменные, заключенные в символ процента «%». Параметр Val2 содержит текст HTML страницы. Val2 может содержать переменные, заключенные в символ тильда «~».

Также вместо текста HTML страницы можно указать файл, в котором он содержится. Этот файл должен находиться на компьютере, где установлен Сервер SpRobot. Для указания файла напишите в фигурных скобках следующее: слово «FILE», двоеточие и имя файла, например:
{FILE:C:\SomeFolder\SomePage.html}

Произнести данные
Параметры: имя переменной Var1, имя переменной Var2.
Описание: команда произносит в телефонную линию содержимое переменной Var2. Тип произносимых данных указывается в Var1: 1 - номер телефона, 2 - целое положительное число, 3 - дата/время, 4 - сумма руб. Перед вызовом описываемой команды необходимо определить значения переменных Var1 и Var2.

Вкладка «Голосовая почта»
В эту группу входят команды, выполняющие операции над сообщениями и ящиками голосовой почты.

Записать голосовое сообщение
Параметры: логин пользователя, имя файла File, символ остановки записи.
Описание: команда проигрывает аудиофайл в телефонную линию, выдает короткий гудок и затем записывает голосовое сообщение для указанного пользователя. Сообщение можно оставить только для зарегистрированного в системе пользователя, который выбирается из всплывающего списка (см. раздел «Администрирование пользователей»). В качестве пользователя можно указать переменную, выделенную символом «%» («процент»). Описание параметра «имя файла» дано в команде Проиграть аудиофайл. Максимальная длина одного голосового сообщения определяется настройками пользователя (см. раздел «Администрирование пользователей»). При нажатии абонентом символа остановки прекращается запись голосового сообщения. В качестве символа остановки можно использовать цифры от «0» до «9», буквы «A», «B», «C», «D» и символы «*», «#».

Получить ID последнего голосового сообщения
Параметры: имя переменной Var.
Описание: команда заносит в переменную Var идентификатор голосового сообщения, который был записан с помощью команды Записать голосовое сообщение. Если в алгоритме до команды «Получить ID последнего голосового сообщения» уже несколько раз записывалось голосовое сообщение, то возвращается идентификатор последнего записанного сообщения. Если Var содержит «0», то идентификатор не определен. После вызова этой команды при прослушивании сообщения с помощью команды Прослушать голосовое сообщение признак «Сообщение прослушано» изменяться не будет. Изменение этого признака при прослушивании сообщения будет происходить после вызова команды Проверить пароль ящика голосовой почты.

Удалить голосовое сообщение
Параметры: имя переменной.
Описание: команда удаляет из системы голосовое сообщение, идентификатор которого находится в переменной. Переменная выбирается из всплывающего списка.

Прослушать голосовое сообщение
Параметры: имя переменной, формат даты N.
Описание: команда воспроизводит в телефонную линию записанное в системе голосовое сообщение, идентификатор которого находится в переменной. Переменная выбирается из всплывающего списка. При выполнении этой команды голосовое сообщения отмечается как прослушанное (исключения см. в команде Получить ID последнего голосового сообщения). При воспроизведении Автосекретарь в зависимости от формата даты N произносит дату и время записи сообщения. Формат даты определяется комбинацией следующих значений: 1 - день недели, 2 - число, 4 - месяц, 8 - часы, 16 - минуты, 32 - год, 64 - произнести дату в конце сообщения. Например, если N будет равно 102 (т.е. 2 + 4 + 32 + 64), то Автосекретарь произнесет число, месяц и год записи сообщения после воспроизведения голосового сообщения. А если N будет равно 25 (т.е. 1 + 8 + 16), то Автосекретарь произнесет день недели, час и минуту записи сообщения перед воспроизведением голосового сообщения. Во время прослушивания сообщения можно управлять воспроизведением: кнопка «7» - перемотка назад на 5 сек., «9» - перемотка вперед на 5 сек., «*» - приостановить/продолжить, «#» - завершить прослушивание, выйти из команды.

Проверить, существует ли ящик голосовой почты
Параметры: имя переменной Var1, имя переменной Var2.
Описание: команда проверяет, существует ли ящик голосовой почты с номером, содержащимся в переменной Var1. Если ящик с таким номером существует, то переменная Var2 будет содержать «1», иначе - «0». Переменная Var1 выбирается из всплывающего списка.

Проверить пароль ящика голосовой почты
Параметры: имя переменной Var1, имя переменной Var2, имя переменной Var3.
Описание: команда проверяет пароль (переменная Var2) ящика с номером Var1 и возвращает результат в переменной Var3. Если пароль для указанного ящика верный, то Var3 будет содержать «1», если нет, то Var3 примет значение «0». Переменные Var1 и Var2 выбираются из всплывающего списка. Эта команда влияет на признак «Сообщение прослушано» (подробнее см. команды Получить ID последнего голосового сообщения и Прослушать голосовое сообщение).

Удалить все сообщения из ящика
Параметры: имя переменной.
Описание: команда удаляет все голосовые сообщения из ящика с номером, определяемым содержимым переменной. Переменная выбирается из всплывающего списка.

Удалить прослушанные сообщения из ящика
Параметры: имя переменной.
Описание: команда удаляет все прослушанные голосовые сообщения из ящика с номером, определяемым содержимым переменной. Переменная выбирается из всплывающего списка.

Проверить, пустой ли ящик голосовой почты
Параметры: имя переменной Var1, имя переменной Var2
Описание: команда проверяет, есть ли сообщения в ящике с номером Var1. Если сообщения отсутствуют, то переменная Var2 будет равна «0», иначе - «1». Переменная Var1 выбирается из всплывающего списка.

Получить список сообщений ящика голосовой почты
Параметры: имя переменной.
Описание: команда формирует внутренний список идентификаторов всех голосовых сообщений, находящихся в ящике, номер которого определяется переменной. Сообщения в списке расположены по убыванию их даты записи, т.е. в начале списка находятся сообщения, записанные последними. Эта команда необходима для перемещения между сообщениями и должна вызываться всегда перед использованием команд Список пуст или достигнут конец списка, Перейти к предыдущему сообщению в списке, Перейти к следующему сообщению в списке, и Получить ID текущего сообщения в списке. Имя переменной выбирается из всплывающего списка.

Список пуст или достигнут конец списка
Параметры: имя переменной Var.
Описание: команда проверяет состояние списка сообщений, сформированного командой Получить список сообщений ящика голосовой почты. Результат проверки находится в переменной Var: «0» - список пуст, «1» - достигнут конец списка, во всех остальных случаях «2». Она проверяет внутренний флаг, сигнализирующий о достижении конца списка, записывает результат в переменной Var и сбрасывает этот флаг в состояние «Конец списка не достигнут» (см. команду Перейти к следующему сообщению в списке). Эта команда всегда должна вызываться после выполнения команды Получить список сообщений ящика голосовой почты.

Перейти к предыдущему сообщению в списке
Параметры: нет.
Описание: команда перемещает текущий указатель в списке сообщений на предыдущую позицию. Если перед выполнением команды указатель уже был на первой позиции в списке, то команда не выполнит никаких действий. Эта команда всегда должна вызываться после выполнения команды Получить список сообщений ящика голосовой почты.

Перейти к следующему сообщению в списке
Параметры: нет.
Описание: команда перемещает текущий указатель в списке сообщений на следующую позицию. Если перед выполнением команды указатель уже был на последней позиции в списке, то команда установит внутренний флаг в состояние «Достигнут конец списка» и не выполнит никаких действий (см. команду Список пуст или достигнут конец списка). Эта команда всегда должна вызываться после выполнения команды Получить список сообщений ящика голосовой почты.

Получить ID текущего сообщения в списке
Параметры: имя переменной Var.
Описание: команда заносит в переменную Var идентификатор сообщения, на который указывает текущий указатель в списке сообщений. Если Var равен «0», то идентификатор не определен. Эта команда всегда должна вызываться после выполнения команды Получить список сообщений ящика голосовой почты.

Произнести количество сообщений
Параметры: имя переменной.
Описание: команда произносит в телефонную линию количество всех сообщений, находящихся в ящике голосовой почты, а затем – количество прослушанных сообщений. Номер ящика определяется переменной, которая выбирается из всплывающего списка.

Смотрите также:


Отчеты

Раздел «Отчеты» дает возможность пользователю получать информацию о том, какие события произошли во время сеанса «разговора» звонящего абонента с Автосекретарем.

Параметры фильтра

Для формирования отчета пользователь должен указать в запросе:
  1. период, в течение которого фиксировались события
  2. отрезок времени (шаг), на который делится период
  3. события, которые нужно вывести в отчете
  4. канал телефонной линии

Пользователь может выбрать следующие события:

  • входящие звонки;
  • не отвеченные вызовы;
  • оператор взял трубку;
  • Автосекретарь взял трубку;
  • вызванные отделы (т. е. набранные Автосекретарем внутренние номера);
  • вызванные уровни меню (фиксируется вход звонящего абонента в какое-либо меню Автосекретаря);
  • соединение с программой записи прервано;
  • событие пользователя (в алгоритме Автосекретаря фиксируется команда «Зафиксировать событие»).

При выборе события, канала или нажатии на кнопку «Изменить» программа формирует отчет и отображает его в виде графика или таблицы.

Настройка отображения отчета

Отчет может быть представлен в трех формах:

  • в табличной форме

  • в виде графика из прямоугольников

  • в виде графика из линий

Для некоторых видов событий (например, «Вызванные уровни меню», «Вызванные отделы» и др.) формируется не один отчет, а несколько, в зависимости от количества значений, найденных для этих событий. Например, событие «Вызванные уровни меню» может иметь несколько значений: «Главное меню», «Меню записи голосового сообщения», «Меню вызова оператора» и т.п. В этом случае, чтобы просмотреть отчет, необходимо кроме события еще указать значение из всплывающего списка «Значение».

Обновление данных отчета вызывается нажатием на панели инструментов кнопки «Обновить отчет» [image] или выбором соответствующего пункта в меню.

Сформированный отчет можно сохранить в файле формата CSV1, поддерживаемом MS Excel и OpenOffice Calc. Для сохранения отчета необходимо на панели инструментов нажать кнопку «Сохранить отчет» [image] или в меню выбрать соответствующий пункт.

Особенности отображения графика

Чтобы отобразить отчет в графическом виде, необходимо выбрать переключатель «Прямоугольник» или «Линия». График может отображаться в плоской или объемной форме (галочка «3D»). Настройка «Показать значения» включает/отключает надписи значений. Также можно изменять количество выборок (шагов), которые одновременно отображаются в графике (поле «Обзор длиной..»). Настройка «Показать график с выборки №» позволяет начало графика перенести на установленную позицию.

Также график можно распечатать на принтере, нажав на панели инструментов кнопку «Печать отчета» [image] или выбрав в меню пункт «Распечатать отчет».

Смотрите также:

Команда «Зафиксировать событие»

Прим. 1. CSV файл — это текстовый файл, предназначенный для представления табличных данных. Каждая строка файла — это одна строка таблицы. Значения отдельных колонок разделяются разделительным символом - точка с запятой (;). Импорт и экспорт файлов такого типа возможен во многих программах, например: Microsoft Excel, OpenOffice.org Calc, SQL Server Management Studio и другие.


Журнал событий

Раздел «Журнал событий» отображает события и сообщения, зафиксированные Сервером. Благодаря этому разделу пользователь может в реальном времени следить за состоянием Сервера и алгоритмов, выполняющихся на каналах. Также журнал событий позволяет обнаруживать причины неполадок и сбоев в работе различных программных модулей Сервера.

Журнал событий в основном содержит служебную и специфическую информацию, которая не понадобится рядовым пользователям Автосекретаря. Поэтому разумно открывать доступ к этому разделу только для пользователей с правами администратора.

Фильтр

Журнал событий имеет фильтр отображения данных. Он вызывается нажатием на панели инструментов кнопки «Задать фильтр» [image] или в меню выбором одноименного пункта.

В фильтре можно указать период, в течение которого фиксировались события Сервером, тип (типы) зафиксированных сообщений и канал (каналы), на котором фиксировались сообщения.

Обновление и сохранение в CSV файл

Обновление отображаемых данных в соответствии с выбранными настойками фильтра выполняется нажатием на панели инструментов кнопки «Обновить» [image] или через контекстное меню.

Содержимое журнала можно сохранить в файле формата CSV1, поддерживаемом MS Excel и OpenOffice Calc. Для этого необходимо на панели инструментов нажать кнопку «Сохранить в файл CSV» [image] или выбрать в меню соответствующий пункт.

Прим. 1. CSV файл — это текстовый файл, предназначенный для представления табличных данных. Каждая строка файла — это одна строка таблицы. Значения отдельных колонок разделяются разделительным символом - точка с запятой (;). Импорт и экспорт файлов такого типа возможен во многих программах, например: Microsoft Excel, OpenOffice.org Calc, SQL Server Management Studio и другие.


Голосовая почта

Автосекретарь имеет возможность сохранять голосовые сообщения для зарегистрированных пользователей. Доступ к этим сообщениям возможен как через телефон, так и через раздел «Голосовая почта» Клиента Автосекретаря.

В зависимости от назначенных прав пользователь может иметь доступ к голосовым сообщениям всех пользователей или только к личным сообщениям (см. раздел «Администрирование пользователей»).

Функции проигрывания

Во время прослушивания сообщений пользователю доступны следующие функции:

  • проиграть сообщение (на панели инструментов кнопка [image], в контекстном меню или в меню Клиента);
  • пауза при прослушивании (на панели инструментов кнопка [image], в контекстном меню или в меню Клиента);
  • остановить прослушивание (на панели инструментов кнопка [image], в контекстном меню или в меню Клиента);
  • изменить громкость;
  • изменить позицию прослушивания в сообщении;
  • использовать автоматическую регулировку уровня звука (АРУЗ).

В этом разделе сообщения можно прослушивать подряд. Для этого необходимо на панели инструментов нажать на кнопку [image] или в меню установить режим «Проигрывать сообщения подряд».

При прослушивании пользователем голосовых сообщений через телефон или Клиент Автосекретаря проигранное сообщение автоматически помечается как прослушанное.

Выделение сообщений

Выделение сообщений в списке выполняется следующими комбинациями клавиш:

«CTRL + A», «Num +» | выделить все сообщения
«Num - » | убрать все выделения
«Num * » | инвертировать выделение
«INSERT» | отметить выделение/снять выделение текущего сообщения

Также сообщения можно выделить, нажав левой кнопкой мыши на левом столбце таблицы, в которой отображается список голосовых сообщений. Чтобы выделить группу сообщений, укажите первое и последнее сообщение в группе, удерживая клавишу «SHIFT». Нажимая левую кнопку мыши и удерживая клавишу «CTRL», можно выделить несколько сообщений отдельно друг от друга.

Фильтр

Фильтр голосовой почты позволяет выбрать записи, отвечающие указанным в фильтре критериям. Чтобы задать критерии фильтрации, нажмите на панели инструментов кнопку «Задать фильтр» [image] или выберите в меню одноименный пункт.

В поле «Телефонный номер» можно указать как непосредственный номер, так и шаблон. Для указания шаблона используются символы «%» (любые символы в любом количестве или пусто) и «_» (любой одиночный символ).

Удаление и обновление

Удалить сообщение (или выделенные сообщения) можно несколькими способами: нажать на панели инструментов кнопку «Удалить голосовое сообщение» [image], нажать на клавиатуре «DELETE» или выбрать в меню пункт «Удалить».

Обновление списка сообщений выполняется нажатием на панели инструментов кнопки «Обновить» [image] или через меню.

Смотрите также:

Администрирование пользователей


Администрирование пользователей

Автосекретарь является многопользовательской системой с разграничением прав доступа к различным функциям. Такая организация программы позволяет свести к минимуму ошибки, возникающие по вине пользователей, и увеличивает стабильность ее работы.

Автосекретарь и Автообзвон имеют отдельный набор пользователей, ролей и прав. Таким образом, из Автосекретаря нельзя управлять пользователями и ролями Автообзвона, и наоборот.

Автосекретарь предоставляет доступ только зарегистрированным активным пользователям. Как правило, ведение пользователей осуществляется администратором системы.

Каждый пользователь в системе имеет определенную роль, которая, в свою очередь, ассоциирована с некоторым набором прав, определяющих, что может, а что не может выполнять в системе пользователь с данной ролью. Принцип разграничения прав доступа пользователей с использованием ролей графически представлен на рисунке:

Пользователи «П1» и «П2» имеют общую роль «1» (а значит и одинаковые права), которая связана с некоторым набором прав «А». Аналогично для пользователей «П3» и «П4». Роль «3» присвоена только одному пользователю «П5».

Практически в Автосекретаре можно завести две роли: «Администратор» и «Пользователи». Первая роль имеет максимальные права и предназначена для настройки и администрирования всей системы, а вторая – минимальные, ее можно присвоить рядовым пользователям, которые смогут просматривать и изменять собственные настройки и прослушивать только личную голосовую почту.

Смотрите также:


Список пользователей

В этом разделе администратор системы может создавать и удалять пользователей, а также изменять их настройки (свойства). По умолчанию после установки в Автосекретаре заведено два пользователя: «ADMIN» (максимальные права) и «USER» (минимальные права).

Добавление и изменение свойств пользователей выполняется через панель инструментов или контекстное меню: кнопка «Добавить пользователя» [image] и кнопка «Свойства пользователя» [image] соответственно.

При добавлении пользователя в свойствах необходимо указать следующее: логин и пароль для входа в систему, максимальную длину одного голосового сообщения, номер и пароль ящика голосовой почты, роль и активность. Остальные поля не обязательны для заполнения. Логин пользователя и номер ящика голосовой почты должны быть уникальны в рамках Автосекретаря. Проверка на уникальность номера ящика выполняется нажатием на кнопку

При изменении свойств администратор не может изменять только логин пользователя.

Пользователь, имеющий доступ только к личным настройкам, может изменять из обязательных полей только пароль для входа в систему и пароль к личному ящику голосовой почты.

Операция удаления выполняется через панель инструментов или контекстное меню «Удалить пользователя» [image]. Удаление пользователей возможно только в случае, если они отмечены как неактивные и не имеют сообщений голосовой почты.

Обновление списка пользователей выполняется на панели инструментов нажатием на кнопку «Обновить» [image] или через контекстное меню.

Удалять или изменять роль и активность пользователя «ADMIN» запрещено.

Смотрите также:


Роли

В этом разделе администратор может создавать, удалять роли и назначать права. Чтобы добавить роль, нужно на панели инструментов нажать на кнопку «Добавить роль» [image] или выбрать соответствующий пункт в контекстном меню. При добавлении программа запросит имя новой роли.

Чтобы удалить роль, на панели инструментов нужно нажать на кнопку «Удалить роль» [image] или выбрать соответствующий пункт в контекстном меню.

Удалить роль можно, только если она не связана с пользователями и не имеет назначенных прав.

Назначить права можно через панель инструментов (кнопка «Назначить права на роль» [image]) или контекстное меню.

В верхнем списке окна «Права роли» отображаются права, которые будут присвоены редактируемой роли, в нижнем – доступные права.

Перед перемещением прав из одного списка в другой необходимо сначала их выделить. Выделить можно один элемент или группу. Чтобы выделить в списке группу прав, необходимо, удерживая на клавиатуре кнопку «SHIFT», указать мышкой первый и последний элемент группы. Если необходимо выделить несколько прав, то, удерживая на клавиатуре кнопку «CTRL», выделите нужные элементы списка.

Чтобы переместить права из нижнего списка в верхний, необходимо нажать на кнопку «Добавить». Нажатие на кнопку «Добавить все» переместит все доступные права в верхний список. Удаление прав из верхнего списка осуществляется нажатием на кнопку «Убрать». Нажатие на кнопку «Убрать все» удалит все выбранные права.

После того как в верхнем списке будет сформирован желаемый набор прав, необходимо нажать на кнопку «ОК». Если нажать на кнопку «Отмена», то сделанные изменения не будут приняты.

В системе запрещено удалять или изменять роль «Все права».

Смотрите также:


Права

Список прав и их описание приведены в таблице:

Право | Описание
Список каналов: просмотр | Пользователь может просматривать список каналов
Список каналов: редактирование | Пользователь может назначать программу (алгоритм) на канал, планировать запуск программы (алгоритма)
Пользователи, список пользователей: просмотр | Пользователь может просматривать список пользователей, зарегистрированных в системе
Пользователи, список пользователей: редактирование | Пользователь может изменять свойства всех пользователей, добавлять новых и удалять существующих пользователей
Пользователи, список пользователей: редактирование собственной учетной записи | Пользователь может просматривать и изменять только личные настройки
Пользователи, роли: просмотр | Пользователь может просматривать список ролей
Пользователи, роли: редактирование | Пользователь может добавлять и удалять роли, но не может назначать права (см. право «Роли и права: редактирование»)
Роли и права: просмотр | Пользователь может получать от сервера список всех прав и список прав, установленных на определенную роль (необходима для раздела «Роли», функция «Назначить права»)
Программы: просмотр | Пользователь может просматривать список программ и подпрограмм, а также содержимое дерева меню и алгоритма в Конструкторе
Программы: редактирование | Пользователь может изменять, добавлять и удалять программы и подпрограммы, а также сохранять содержимое дерева меню и алгоритм Конструктора в базе данных
Сервер: настройка | Пользователь может изменять настройки Сервера (Автосекретарь и Автообзвон имеют общие настройки Сервера)
Журнал событий: просмотр событий | Пользователь может просматривать журнал событий
Список каналов: запуск, остановка, завершение автосекретаря | Пользователь может запускать и останавливать алгоритм на телефонном канале
Голосовая почта: доступ к почте всех пользователей | Пользователь может удалять, прослушивать и просматривать список голосовых сообщений всех пользователей
Голосовая почта: доступ к почте только для своей учетной записи | Пользователь может удалять, прослушивать и просматривать список только личных голосовых сообщений
Роли и права: редактирование | Пользователь может назначать права на роль
Отчеты: формирование | Пользователь имеет полный доступ к разделу «Отчеты»

При назначении прав важно учитывать, что право на редактирование также дает право на просмотр.

Смотрите также:


Настройка Сервера

Раздел «Настройка Сервера» позволяет через Клиент Автосекретаря настраивать различные параметры Сервера.

Автообзвон и Автосекретарь обращаются к одним и тем же настройкам Сервера.

После того как пользователь изменил настройки, необходимо нажать на кнопку «Сохранить», чтобы сделанные изменения были сохранены на Сервере.

Сохраненные настройки вступают в силу только после перезапуска Сервера.

Параметры базы данных

Тип источника данных

В этой настройке пользователь выбирает из всплывающего списка, где будут храниться данные: в MS SQL Server или в локальных таблицах формата Parodox 7. Поскольку изменения настроек начинают действовать не сразу, то под всплывающим списком в поле «сейчас» отображается текущий тип источника данных.

Имя SQL сервера

Имя SQL сервера можно ввести с клавиатуры или выбрать из списка.

Имя БД

В данном параметре указывается имя новой или уже существующей БД на SQL сервере. В этом случае возможны следующие варианты подключения к данным:
  • указанная БД не существует. В этом случае при запуске Сервера SpRobot база данных будет создана автоматически.
  • указанная БД существует. При запуске Сервер SpRobot проверит целостность БД:
    • если БД целостна, т.е. содержит все необходимые таблицы, то Сервер SpRobot будет использовать ее как источник данных.
    • если она не целостна, то Сервер SpRobot будет использовать локальные таблицы.
Идентификация

Здесь указывается способ идентификации (тип проверки подлинности) при подключении к MS SQL серверу: Windows или SQL Server.

Логин и пароль

Если была выбрана идентификация «SQL Server», то в параметрах «Логин» и «Пароль» необходимо указать соответственно имя пользователя и его пароль. Эти данные Сервер SpRobot будет использовать для подключения к MS SQL. Указанный пользователь должен иметь права на создание БД, таблиц внутри БД и модификацию содержимого таблиц.

Тайм-аут подключения

Этот параметр определяет время, в течение которого Сервер SpRobot пытается подключиться к SQL серверу. Если за указанное время Сервер SpRobot не сможет подключиться, то в качестве источника данных будут выбраны локальные таблицы.

Параметры сервера

TCP/IP порт

В этой настройке пользователь устанавливает, какой порт будет использоваться при обмене данными между Сервером SpRobot и Клиентами по TCP/IP протоколу. Это может понадобиться, например, если порт, устанавливаемый по умолчанию в SpRobot, уже используется другой программой. Номер порта должен быть в диапазоне 1001 – 65535.

Реагировать на поднятие трубки оператором

Устройство SpRecord может распознавать поднятие трубки на параллельном телефоне. Если этот параметр установлен, то при поднятии трубки оператором во время работы алгоритма Автосекретаря или Автообзвона Сервер остановит выполнение текущей команды (например, прекратит выводить в линию звуковые данные) и будет ждать, пока оператор не завершит разговор и не положит трубку телефона. Данная настройка позволяет оператору «перехватывать» входящий/исходящий звонок. После завершения разговора Сервер продолжит выполнение с начала алгоритма. Если оператор поднял трубку во время обзвона абонентов, то такой номер будет отмечен как «успешно обработан».

Flash-пауза

В режиме тонового набора перед выдачей номера можно кратковременно разомкнуть шлейф телефонной линии. Это позволяет эмитировать нажатие кнопки «Flash» на телефоне при переводе звонка на другого абонента мини-АТС. Длительность разрыва линии определяется параметром «Flash-пауза».

Удалять записи из журналов

В этом параметре указывается количество дней, по истечении которых записи в журналах событий и обзвона будут удаляться.

Тоновый режим набора номера

Этот параметр определяет, в каком режиме Автосекретарь и Автообзвон будут набирать телефонные номера. Выключенный параметр устанавливает импульсный режим.

Смотрите также:

Вход в систему (авторизация)


Клиент Автообзвона

Клиент Автообзвона - это программа, с помощью которой выполняются различные задачи оповещения, например: составление списка абонентов, создание алгоритма оповещения, запуск оповещения на телефонных каналах, администрирование пользователей и др.

Окно состоит из нескольких рабочих областей.

1. Главное меню

Главное меню состоит из следующих пунктов:
  • «Система»
    • «Параметры»:
      • установить время ожидания ответа Сервера на запрос Клиента (сек.).
      • проверять обновления автоматически (спустя 3 минуты после запуска Клиента).
      • Окно сообщения. Эта группа параметров устанавливает внешний вид сообщений, выводимых командами «Показать сообщение» и «Показать HTML страницу»:
        • Закрыть окно сообщения спустя (сек.).
        • Вид окна: обычное или всплывающее. В последнем случае можно указать позицию на экране, направление появления окна, ширину, высоту и смещение по Х.

    • «Авторизация» - повторно войти в систему.
    • «Выход» - завершить работу Клиента.
  • «Список программ» - название и содержимое этого пункта меню зависит от выбранного раздела. Как правило, его содержимое совпадает с контекстным меню и панелью инструментов. В данном случае отображается раздел «Список программ».
  • «Инструменты»
    • «Звуковой редактор» - открыть Звуковой редактор.
  • «Справка»
    • «Справка» - открыть справку SpRobot.
    • «Быстрый старт» - начать обучение по использованию Автообзвона.
    • «Ввести ключ активации» - снять ограничения демо-режима Автообзвона (см. «Установка SpRobot»).

    • «Проверить обновление» - проверить, появилась ли новая версия SpRobot.
    • «О программе» - узнать текущую версию программы.
2. Панель инструментов

Панель инструментов содержит функциональные кнопки. Набор этих кнопок и выполняемые ими функции зависят от выбранного раздела.

3. Панель разделов

В этой панели отображаются разделы, которые позволяют пользователю выполнять различные задачи. Перечень доступных разделов зависит от имеющихся у пользователя прав (см. «Администрирование пользователей/Роли»). В контекстном меню этой области пользователь может обновлять ее содержимое.

4. Рабочая область выбранного раздела

В этой области отображается содержимое выбранного раздела, например: список, алгоритм голосового меню и др.

Контекстное меню

Каждая рабочая область имеет собственное контекстное меню. Оно вызывается нажатием правой кнопки мыши в рабочей области. Содержимое контекстного меню зависит от выбранного раздела.

Смотрите также:

Установка SpRobot
Список программ
Состояние номеров
Журнал обзвона
Справочник абонентов
Программа автообзвона
Журнал событий
Администрирование пользователей
Настройка Сервера


Вход в систему (авторизация)

Для того чтобы начать работу с Автообзвоном, необходимо войти в систему (выполнить авторизацию). После запуска Клиента появляется окно входа в систему. Если запуск был первым после установки SpRobot, то окно входа будет иметь расширенный вид:

При последующих запусках окно входа отображается в сжатом виде:

В полях логина и пароля необходимо ввести логин пользователя, зарегистрированного в системе, и его пароль. После установки Автообзвона в системе заведены два пользователя: «ADMIN» (пароль «ADMIN») и «USER» (пароль «USER»).

Если Клиент Автообзвона находится на том же компьютере, на котором установлен Сервер SpRobot, то необходимо в настройках соединения отметить пункт «Сервер на этом компьютере». Для того чтобы установить связь с Сервером, находящимся на другом компьютере, необходимо выбрать пункт «Сервер находится в сети» и нажать кнопку «Обзор». Далее в открывшемся окне нужно выбрать компьютер, на котором расположен Сервер SpRobot.

Номер порта1, через который Сервер и Клиент будут обмениваться информацией, указывается в поле «Порт».

Чтобы проверить соединение с Сервером, необходимо нажать на кнопку «Тест».

Кнопка «Соединение» расширяет или сжимает окно входа в систему.

После успешной авторизации программа запоминает логин, пароль (если была выбрана соответствующая опция), адрес Сервера и номер порта.

Смотрите также:

Администрирование пользователей
Настройка Сервера

Прим. 1. Если на компьютере Сервера или Клиента работает брандмауэр (фаервол), то его необходимо настроить так, чтобы Сервер и Клиент могли беспрепятственно обмениваться информацией по TCP/IP протоколу. В случае установки Сервера программа инсталляции автоматически выполняет необходимые настройки брандмауэра Windows.


Быстрый старт

Обучение «Быстрый старт» поможет освоить основные правила создания и запуска обзвона. Процесс обучения займет 10-15 минут.

Задача: оповестить клиентов о задолженности.

Входные данные:

  • cписок номеров клиентов в CSV файле:

    1;01.12.2009;123.01
    2;01.12.2009;123.01
    3;01.12.2009;123.01
    4;01.12.2009;123.01
    5;01.12.2009;123.01

    Столбцы разделяются точкой с запятой («;»), первый столбец - номер телефона, второй - дата, третий - сумма задолженности;
  • 3 аудиофайла: «Здравствуйте. Ваша задолженность на...», «...составляет...», «После того как вы прослушаете это сообщение, нажмите любую кнопку телефона. Если вы этого не сделаете, то вам позвонят снова».

Файл со списком номеров и звуковые файлы можно найти в папке установки «..\SpRobot\Client\Samples\Автообзвон\Быстрый старт».

Алгоритм: После того как клиент возьмет трубку, необходимо
  • произнести приветствие,
  • произнести дату,
  • произнести «...составляет...»,
  • произнести сумму задолженности,
  • ожидать нажатия клиентом любой кнопки на телефоне, чтобы гарантировать доставку сообщения.

Условия запуска:
  • звонок из мини АТС;
  • оповещение на двух телефонных линиях.

Шаг 1. Создать список номеров обзвона
Шаг 2. Указать настройки дозвона
Шаг 3. Определить алгоритм автообзвона
Шаг 4. Установить расписание
Шаг 5. Сохранить программу в базу данных
Шаг 6. Запустить программу обзвона
Шаг 7. Просмотреть результат обзвона


Быстрый старт

Шаг 1. Создать список номеров обзвона

1. Откройте раздел «Список номеров»:

2. Импортируйте список номеров из CSV файла:

3. Укажите в предварительном просмотре символ-разделитель, нажмите «ОК».

4. Проверьте правильность импорта данных:

Шаг 2. Указать настройки дозвона >>

Смотрите также:

Список номеров


Быстрый старт

Шаг 2. Указать настройки дозвона

1. Откройте раздел «Настройка дозвона»:

2. Для каждого случая («абонент занят», «абонент не отвечает», «другое или неверный код») установите необходимые параметры:

3. Укажите время дозвона (сек.):

4. Введите номер выхода в город (префикс), например «9»:

Шаг 3. Определить алгоритм автообзвона >>

Смотрите также:

Настройка дозвона


Быстрый старт

Шаг 3. Определить алгоритм автообзвона

1. Откройте раздел «Алгоритм»:

2. Добавьте команду «Проиграть аудиофайл»:

3. В параметрах укажите аудиофайл приветствия «Здравствуйте. Ваша задолженность на...»:

4. Добавьте команду «Произнести данные»:

5. В параметрах укажите столбец из списка номеров, содержащий дату (столбец «N1»):

6. Добавьте команду «Проиграть аудиофайл».
7. В параметрах укажите аудиофайл фразы «...составляет...».
8. Добавьте команду «Произнести данные».
9. В параметрах укажите столбец из списка номеров, содержащий сумму задолженности (столбец «N2»).
10. Добавьте команду «Проиграть аудиофайл».
11. В параметрах укажите аудиофайл фразы «После того как вы прослушаете это сообщение, нажмите любую кнопку телефона. Если вы этого не сделаете, то вам позвонят снова».
12. Добавьте команду «Запросить код».
13. В параметрах установите «Любое значение»:

Шаг 4. Установить расписание >>

Смотрите также:

Алгоритм автообзвона


Быстрый старт

Шаг 4. Установить расписание

1. Откройте раздел «Расписание»:

2. Установите «Ручной запуск»:

3. Укажите каналы, на которых будет выполняться программа обзвона:

Шаг 5. Сохранить программу в базу данных >>

Смотрите также:

Расписание


Быстрый старт

Шаг 5. Сохранить программу в базу данных

1. На панели инструментов нажмите «Сохранить все настройки»:

2. Введите имя новой программы обзвона или укажите уже существующее имя, затем нажмите «Сохранить»:

3. После того как Автообзвон сохранит все настройки программы, нажмите «Закрыть»:

Шаг 6. Запустить программу обзвона >>

Смотрите также:

Программа автообзвона


Быстрый старт

Шаг 6. Запустить программу обзвона

1. Откройте раздел «Список программ»:

2. Укажите в списке сохраненную Вами программу обзвона:

3. На панели инструментов нажмите «Запустить программу автообзвона»:

Шаг 7. Просмотреть результат обзвона >>

Смотрите также:

Список программ


Быстрый старт

Шаг 7. Просмотреть результат обзвона

1. Откройте раздел «Состояние номеров»:

2. На панели инструментов нажмите «Задать фильтр» и выберите программу обзвона:

3. По умолчанию данные в таблице отсортированы по первому столбцу (номерам телефонов):

Вернуться в начало обучения

Смотрите также:

Состояние номеров


Быстрый старт.
Ручное формирование списка номеров.

Обучение «Быстрый старт» поможет освоить основные правила создания и запуска обзвона. Процесс обучения займет 10-15 минут.

Задача: оповестить клиентов о задолженности.

Входные данные:

  • cписок номеров клиентов, их задолженность и дата (эти данные будут занесены вручную):
    Номер | Дата | Сумма
    1 | 01.12.2009 | 123.01
    2 | 01.12.2009 | 123.01
    3 | 01.12.2009 | 123.01
    4 | 01.12.2009 | 123.01
    5 | 01.12.2009 | 123.01
  • 3 аудиофайла: «Здравствуйте. Ваша задолженность на...», «...составляет...», «После того как вы прослушаете это сообщение, нажмите любую кнопку телефона. Если вы этого не сделаете, то вам позвонят снова».

Звуковые файлы можно найти в папке установки «..\SpRobot\Client\Samples\Автообзвон\Быстрый старт».

Алгоритм: После того как клиент возьмет трубку, необходимо
  • произнести приветствие,
  • произнести дату,
  • произнести «...составляет...»,
  • произнести сумму задолженности,
  • ожидать нажатия клиентом любой кнопки на телефоне, чтобы гарантировать доставку сообщения.

Условия запуска:
  • звонок из мини АТС;
  • оповещение на двух телефонных линиях.

Шаг 1. Создать список номеров обзвона
Шаг 2. Указать настройки дозвона
Шаг 3. Определить алгоритм автообзвона
Шаг 4. Установить расписание
Шаг 5. Сохранить программу в базу данных
Шаг 6. Запустить программу обзвона
Шаг 7. Просмотреть результат обзвона


Быстрый старт.
Ручное формирование списка номеров.

Шаг 1. Создать список номеров обзвона

1. Откройте раздел «Список номеров»:

2. Укажите количество строк и столбцов, достаточных для ввода данных. В нашем случае 5 строк и 3 столбца:

3. Для столбца «N1» укажите тип «Дата/время»:

4. Для столбца «N2» укажите тип «Сумма руб.»:

5. Заполните столбцы «№ Телефона», «N1» и «N2» согласно исходным данным. После этого проверьте правильность введенных данных:

Шаг 2. Указать настройки дозвона >>

Смотрите также:

Список номеров


Быстрый старт.
Ручное формирование списка номеров.

Шаг 2. Указать настройки дозвона

1. Откройте раздел «Настройка дозвона»:

2. Для каждого случая («абонент занят», «абонент не отвечает», «другое или неверный код») установите необходимые параметры:

3. Укажите время дозвона (сек.):

4. Введите номер выхода в город (префикс), например «9»:

Шаг 3. Определить алгоритм автообзвона >>

Смотрите также:

Настройка дозвона


Быстрый старт.
Ручное формирование списка номеров.

Шаг 3. Определить алгоритм автообзвона

1. Откройте раздел «Алгоритм»:

2. Добавьте команду «Проиграть аудиофайл»:

3. В параметрах укажите аудиофайл приветствия «Здравствуйте. Ваша задолженность на...»:

4. Добавьте команду «Произнести данные»:

5. В параметрах укажите столбец из списка номеров, содержащий дату (столбец «N1»):

6. Добавьте команду «Проиграть аудиофайл».
7. В параметрах укажите аудиофайл фразы «...составляет...».
8. Добавьте команду «Произнести данные».
9. В параметрах укажите столбец из списка номеров, содержащий сумму задолженности (столбец «N2»).
10. Добавьте команду «Проиграть аудиофайл».
11. В параметрах укажите аудиофайл фразы «После того как вы прослушаете это сообщение, нажмите любую кнопку телефона. Если вы этого не сделаете, то вам позвонят снова».
12. Добавьте команду «Запросить код».
13. В параметрах установите «Любое значение»:

Шаг 4. Установить расписание >>

Смотрите также:

Алгоритм автообзвона


Быстрый старт.
Ручное формирование списка номеров.

Шаг 4. Установить расписание

1. Откройте раздел «Расписание»:

2. Установите «Ручной запуск»:

3. Укажите каналы, на которых будет выполняться программа обзвона:

Шаг 5. Сохранить программу в базу данных >>

Смотрите также:

Расписание


Быстрый старт.
Ручное формирование списка номеров.

Шаг 5. Сохранить программу в базу данных

1. На панели инструментов нажмите «Сохранить все настройки»:

2. Введите имя новой программы обзвона или укажите уже существующее имя, затем нажмите «Сохранить»:

3. После того как Автообзвон сохранит все настройки программы, нажмите «Закрыть»:

Шаг 6. Запустить программу обзвона >>

Смотрите также:

Программа автообзвона


Быстрый старт.
Ручное формирование списка номеров.

Шаг 6. Запустить программу обзвона

1. Откройте раздел «Список программ»:

2. Укажите в списке сохраненную Вами программу обзвона:

3. На панели инструментов нажмите «Запустить программу автообзвона»:

Шаг 7. Просмотреть результат обзвона >>

Смотрите также:

Список программ


Быстрый старт.
Ручное формирование списка номеров.

Шаг 7. Просмотреть результат обзвона

1. Откройте раздел «Состояние номеров»:

2. На панели инструментов нажмите «Задать фильтр» и выберите программу обзвона:

3. По умолчанию данные в таблице отсортированы по первому столбцу (номерам телефонов):

Вернуться в начало обучения

Смотрите также:

Состояние номеров


Список программ

Управление списком

В этом разделе пользователь может изменить свойства программы автообзвона или удалить ее. Используя главное меню, контекстное меню или панель инструментов (кнопка «Свойства программы» [image]), можно изменить имя и примечание программы. Удаление программы выполняется нажатием на панели инструментов кнопки «Удалить программу» [image]. Также удалить программу можно в соответствующем пункте главного или контекстного меню. Обновление информации в списке вызывается кнопкой «Обновить» [image].

Выполнение программ оповещения

Чтобы начать выполнение программы оповещения, необходимо нажать на панели инструментов кнопку «Запустить программу автообзвона» [image]. Если в расписании программы указан ручной запуск, то выполнение начнется немедленно. А если программа оповещения имеет тип расписания «Период» или «Запуск по датчику», то нажатие кнопки [image] активирует программу, но не запустит ее. Запуск произойдет только тогда, когда выполнится условие запуска, указанное в расписании: наступит определенное время или сработает датчик. Неактивированная программа даже при наступлении условия, указанного в расписании, запускаться не будет.

Чтобы прекратить выполнение программы оповещения, необходимо нажать кнопку «Остановить выполнение программы» [image]. В главном меню это пункт «Выключить», в контекстном - «Остановить выполнение».

Если программа была остановлена, а список номеров не был обработан полностью, то при следующем запуске Автообзвон спросит, продолжить обработку списка или начать заново.

Статистика

В списке программ также отображается текущее состояние списка номеров программ оповещения (статистика). К статистике относятся следующие столбцы в списке программ:
  • «Всего номеров». В этом столбце указывается общее количество номеров обзвона.
  • «Обработано». Здесь указывается количество обработанных номеров обзвона1.
  • «Успешных». Столбец содержит количество успешно обработанных номеров2.
Также в списке «Обрабатываются номера» при выполнении программ оповещения отображаются обрабатываемые на данный момент номера. Состояние всех номеров выполняющейся программы обзвона можно посмотреть в разделе «Состояние номеров». Подробные данные о результатах обзвона каждого номера можно просмотреть в разделе «Журнал обзвона».

Если включена хотя бы одна из программ обзвона, то статистика будет обновляться автоматически. Интервал обновления указывается в параметре «Автоматически обновлять каждые...».

Каналы

В списке каналов отображаются все каналы устройств SpRecord, подключенных к компьютеру, на котором находится Сервер. По умолчанию в списке каналов отображаются только те устройства, которые подключены к Серверу. Отображение каналов отключенных устройств включается/выключается нажатием кнопки [image] или через пункт меню «Показывать отключенные устройства».

Каналы устройства могут иметь следующие статусы:

1. При определении статуса произошла ошибка. Такое состояние могут иметь каналы, к которым запрещено подключение через библиотеку SpRecord.

2. К каналу устройства не подключена телефонная линия.

3. Телефонная линия подключена, трубка находится на аппарате.

4. Телефонная линия подключена, трубка поднята.

Обновление списка устройств и каналов происходит автоматически при изменении состояния или их подключении/отключении к компьютеру. Для принудительного обновления списка используется кнопка «Обновить» [image], находящаяся слева от списка каналов, или соответствующий пункт в контекстном меню.

Смотрите также:

Состояние номеров
Журнал обзвона
Настройка дозвона
Расписание

Прим. 1. Звонок считается обработанным в двух случаях: 1) звонок успешно обработан или 2) абонент был занят, не отвечал или другое и выполнено указанное количество повторных звонков (см. раздел «Настройки дозвона» параметр «Повторять попытку»).

Прим. 2. Звонок считается успешно обработанным, если соблюдены два условия: абонент поднял трубку и прослушал сообщение до конца. Если параметр «Абонент положил трубку, не дослушав до конца» в разделе «Настройки дозвона» установлен в «Успешно обработан», то звонок будет считаться успешным, даже если сообщение не было прослушано до конца (абонент положил трубку во время прослушивания).


Состояние номеров

Раздел «Состояние номеров» отображает информацию о результатах оповещения программ автообзвона. В отличие от «Журнал обзвона», который содержит историю оповещения, в этом разделе отображается последний результат обзвона. Раздел содержит следующие данные:
  • «ID» - идентификатор номера в базе данных
  • «Номер» - номер абонента
  • «Имя» - имя абонента (берется из справочника абонентов)
  • «Состояние» - последний результат оповещения; может принимать значения:
    • не обработано (фон строки серого цвета)
    • успешно завершен (фон строки голубого цвета)
    • абонент занят (фон строки красного цвета)
    • абонент не ответил (фон строки красного цвета)
    • другое: разрыв линии, ошибка программы, неверно введенный код и т.д. (фон строки красного цвета)
    • исключен: номер исключен из списка обзвона (фон строки серого цвета, текст темно-серого цвета)
  • «Статус» - может принимать значения:
    • обрабатывается, т.е. в данный момент программа обзванивает этот номер (обрабатываемые номера показаны жирным шрифтом синего цвета)
    • не обрабатывается, т.е в данный момент программа не обзванивает этот номер
  • «Начало обзвона» и «Длительность» - время начала обзвона и его длительность
  • «DTMF ответ» содержит набор символов (DTMF сигналов), которые ввел абонент во время обзвона
  • «Попыток» - означает, сколько было попыток дозвона на данный номер
В контекстном меню есть пункт «Исключить номер». С его помощью можно временно убрать из обзвона исключаемый номер. Для того чтобы вернуть исключенный номер в процесс обзвона, используется пункт «Включить номер».

Фильтр

Раздел «Состояние номеров» имеет фильтр отображения данных. Он вызывается нажатием на панели инструментов кнопки «Задать фильтр» [image] или выбором в меню одноименного пункта.

В фильтре необходимо указать программу оповещения, состояния номеров и их статус.

Сортировка

Информацию в списке состояний можно сортировать по любому столбцу. Столбец, по которому отсортированы данные, обозначен стрелкой. Эта стрелка также показывает направление сортировки: сверху вниз (от меньшего к большему) или снизу вверх (от большего к меньшему). Для того чтобы выполнить сортировку, необходимо нажать на заголовке выбранного столбца.

Обновление и сохранение в CSV файл

Обновление отображаемых данных в соответствии с выбранными настойками фильтра выполняется нажатием на панели инструментов кнопки «Обновить» [image] или через контекстное меню.

Состояние номеров можно сохранить в файле формата CSV1, поддерживаемом MS Excel и OpenOffice Calc. Для этого необходимо на панели инструментов нажать кнопку «Сохранить в CSV файл» [image] или выбрать в меню соответствующий пункт.

Смотрите также:

Журнал обзвона

Прим. 1. CSV файл — это текстовый файл, предназначенный для представления табличных данных. Каждая строка файла — это одна строка таблицы. Значения отдельных колонок разделяются разделительным символом - точка с запятой (;). Импорт и экспорт файлов такого типа возможен во многих программах, например: Microsoft Excel, OpenOffice.org Calc, SQL Server Management Studio и другие.


Журнал обзвона

Раздел «Журнал обзвона» отображает подробную информацию о результатах оповещения каждого номера. В отличие от раздела «Состояние номеров» журнал обзвона отображает историю оповещения. Журнал содержит следующие данные:
  • «Начало» и «Длительность» - время начала обзвона и его длительность
  • «Номер» - номер абонента
  • «Имя» - имя абонента (берется из справочника абонентов)
  • «Результат обзвона» - результат оповещения; может принимать значения:
    • успешно завершен
    • занято
    • абонент не ответил
    • другое (разрыв линии, ошибка программы, неверно введенный код и т.д.)
  • «Ответ абонента» содержит набор символов (DTMF сигналов), которые ввел абонент

Фильтр

Журнал обзвона имеет фильтр отображения данных. Он вызывается нажатием на панели инструментов кнопки «Задать фильтр» [image] или выбором в меню одноименного пункта.

В фильтре необходимо указать программу оповещения и время ее запуска.

Сортировка

Информацию в журнале обзвона можно сортировать по любому столбцу. Столбец, по которому отсортированы данные, обозначен стрелкой. Эта стрелка также показывает направление сортировки: сверху вниз (от меньшего к большему) или снизу вверх (от большего к меньшему). Для того чтобы выполнить сортировку, необходимо нажать на заголовке выбранного столбца.

Обновление и сохранение в CSV файл

Обновление отображаемых данных в соответствии с выбранными настойками фильтра выполняется нажатием на панели инструментов кнопки «Обновить» [image] или через контекстное меню.

Содержимое журнала можно сохранить в файле формата CSV1, поддерживаемом MS Excel и OpenOffice Calc. Для этого необходимо на панели инструментов нажать кнопку «Сохранить в CSV файл» [image] или выбрать в меню соответствующий пункт.

Смотрите также:

Состояние номеров

Прим. 1. CSV файл — это текстовый файл, предназначенный для представления табличных данных. Каждая строка файла — это одна строка таблицы. Значения отдельных колонок разделяются разделительным символом - точка с запятой (;). Импорт и экспорт файлов такого типа возможен во многих программах, например: Microsoft Excel, OpenOffice.org Calc, SQL Server Management Studio и другие.


Справочник абонентов

Справочник абонентов содержит имена абонентов (клиентов, сотрудников и т. д.), их телефонные номера, а также имя программы обзвона, в которой участвует номер. Он может использоваться для формирования списка номеров оповещения.

Импорт и экспорт

Функция импорта позволяет добавить к справочнику абонентов данные из CSV файла1. Для этого на панели инструментов или в меню выберите «Импорт справочника абонентов» [image]. После импорта данных из файла программа покажет результат:

Требования к CSV файлу. Импортируемый CSV файл должен содержать три колонки, разделенные точкой с запятой «;»: имя абонента, номер телефона, примечание (может быть пустым). Пример содержимого CSV файла:

Павел П.;89015678945;сотовый
Павел П.;679845;домашний
Сергей С.;456789;
Сергей С.;123456;
Сергей С.;120934;

Во время импорта данных программа осуществляет проверку на наличие дубликатов номеров: если номер уже существует в справочнике, то он не будет снова добавлен из CSV файла.

Справочник абонентов можно сохранить на диск. Для этого на панели инструментов или в меню необходимо выбрать «Экспорт справочника абонентов» [image]. Программа сформирует CSV файл, используя в качестве разделителя символ «;».

Ручное редактирование

Ручное редактирование справочника позволяет добавлять абонента, изменять егo данные (имя и номера телефонов), удалять абонента или его отдельные номера.

Добавить абонента [image].

В появившемся окне «Добавить абонента» необходимо указать имя абонента и хотя бы один номер.

Изменить данные абонента [image].

В появившемся окне «Изменить данные абонента» можно изменить имя, номера телефонов и примечания.

Удалить абонента [image]. Эта функция удаляет абонента и все его номера из справочника.

Функция «Удалить номер» [image] убирает из справочника номер абонента. Если абонент имел один номер, то удалиться также абонент. Также эта функция удаляет выделенные номера. Чтобы выделить группу номеров, необходимо, удерживая «Shift», отметить первый и последний номер группы. Для выделения различных номеров, выберите строки, удерживая «Ctrl».

Копирование и выделение в списке номеров

При формировании списка оповещения для программы автообзвона номера можно выбрать из справочника. Для этого необходимо выделить номера и выполнить функцию «Добавить в список номеров» [image].

Иногда бывает необходимо выделить номера, находящиеся в программе оповещения (раздел «Список номеров») и принадлежащие тому или иному абоненту (абонентам). Для этого необходимо выполнить функцию «Выделить в списке номеров» [image].

Чтобы выделить группу номеров, необходимо, удерживая «Shift», отметить первый и последний номер группы. Для выделения различных номеров, выберите строки, удерживая «Ctrl».

Смотрите также:

Список номеров

Прим. 1. CSV файл — это текстовый файл, предназначенный для представления табличных данных. Каждая строка файла — это одна строка таблицы. Значения отдельных колонок разделяются разделительным символом - точка с запятой (;). Импорт и экспорт файлов такого типа возможен во многих программах, например: Microsoft Excel, OpenOffice.org Calc, SQL Server Management Studio и другие.


Программа автообзвона

Для оповещения абонентов Автообзвон использует программы обзвона. Их список отображается в разделе «Автообзвон/Список программ». Каждая программа обзвона (оповещения) включает в себя 4 раздела:
  • Список номеров. В этом разделе формируется список номеров и дополнительные данные (например, о задолженности), которые могут быть использованы в алгоритме.
  • Настройка дозвона. Здесь определяются различные настройки дозвона: через какое время повторно позвонить на номер и сколько раз это сделать в случае неудачной попытки, время ожидания вызова абонента и т.д.
  • Алгоритм. В этом разделе пользователь создает алгоритм, который будет выполнен, когда абонент возьмет трубку.
  • Расписание. Данный раздел содержит информацию о запуске программы оповещения: тип запуска (вручную, по времени или по датчику) и каналы, на которых будет выполняться программа.
Таким образом перед тем как выполнять оповещение абонентов, сначала необходимо настроить все 4 раздела программы.

Общие функции

Каждый раздел программы имеет общие функции, выполняющие различные действия над программой в целом. К ним относятся:
  • Новая программа. Вызов этой функции удаляет из памяти программу и сбрасывает все настройки на значения по умолчанию.
  • Загрузить. Функция загружает из базы данных программу оповещения в память Клиента Автообзвона. Имя программы отображается на панели разделов и в разделах программы.
  • Сохранить.... Эта функция сохраняет текущий раздел программы в базу данных. Другие разделы не сохраняются.
  • Сохранить все настройки. В отличие от предыдущей эта функция сохраняет все разделы программы в базу данных.
  • Обновить программу автообзвона. Если программа уже была загружена из базы данных в память Клиента, то выполнится функция«Загрузить». Если же программа не была загружена, то выполнится функция «Новая программа».
Каждая из перечисленных выше функций доступна в любом разделе программы на панели инструментов или в главном меню.

Создание новой программы

Новая программа обзвона создается следующим образом:
  1. Выбрать на панели разделов любой раздел программы (список номеров, настройка дозвона, алгоритм, расписание).
  2. На панели инструментов или в главном меню вызвать функцию «Новая программа» 1.
  3. Настроить все 4 раздела программы: список номеров, настройка дозвона, алгоритм и расписание.
  4. На панели инструментов или в главном меню вызвать функцию «Сохранить все настройки».
  5. В появившемся окне сохранения введите имя новой программы и нажмите «Сохранить».
После сохранения новую программу оповещения можно запустить, используя раздел «Список программ».

Изменения существующей программы

Для изменения существующей программы необходимо выполнить следующие шаги:
  1. Выбрать на панели разделов любой раздел программы (список номеров, настройка дозвона, алгоритм, расписание).
  2. Загрузить программу обзвона из базы данных: через панель инструментов или главное меню вызовите функцию «Загрузить».
  3. Внести изменения в разделы программы (список номеров, настройка дозвона, алгоритм или расписание).
  4. На панели инструментов или в главном меню вызвать функцию «Сохранить все настройки» и в появившемся окне сохранения нажать «Сохранить».
После сохранения изменений программу оповещения можно запустить, используя раздел «Список программ».

Смотрите также:

Список программ
Список номеров
Настройка дозвона
Алгоритм
Расписание

Прим. 1. Если в память Клиента Автообзвона не была загружена ни одна программа, то выполнять функцию «Новая программа» не обязательно.


Список номеров

Раздел «Список номеров» содержит телефонные номера абонентов и дополнительные данные, которые могут быть использованы в алгоритме оповещения. Список можно создать тремя путями: копировать номера из Справочника абонентов, импортировать номера из CSV файла или добавить вручную.

Импорт и экспорт

Список номеров можно загрузить из CSV файла1. Для этого на панели инструментов или в главном меню необходимо выбрать «Импорт списка номеров» [image]. После выбора импортируемого файла появится окно «Импорт данных»:

Это окно предназначено для предварительного просмотра импортируемых данных. Разделительный символ, используемый в загружаемом CSV файле, выбирается в области «Разделитель».

Каждая колонка (столбец) в CSV файле должна иметь один из следующих типов: номер телефона, число, дата/время, сумма в рублях. CSV файл всегда должен содержать по крайней мере одну колонку - номер телефона. Если данные в CSV файле сформированы правильно, т.е. соответствуют формату, используемым Автообзвоном (см. ниже), то при импорте тип колонок будет определен автоматически. Также тип колонки можно указать в главном или контекстном меню - пункт «Тип столбца».

Контекстное меню списка номеров

Во время импорта списка номеров программа не всегда верно определяет тип данных. Поэтому рекомендуется после импорта проверить тип каждого столбца. Для того чтобы проверить соответствие загруженных данных типу колонок, необходимо нажать на кнопку «Проверить» [image].

Список номеров, содержащийся в памяти Автообзвона, можно сохранить на диск. Для этого на панели инструментов или в главном меню необходимо выбрать «Экспорт списка номеров» [image]. Автообзвон сформирует CSV файл, используя в качестве разделителя символ «;».

Ручное редактирование

При ручном редактировании необходимо установить размер таблицы, т.е. указать количество строк и столбцов. Количество строк и столбцов определяется на панели инструментов.

После определения размера таблицы необходимо заполнить все ячейки: указать номера телефонов и дополнительные данные (столбцы «N1», «N2» и т.д.).

Удаление одного столбца из таблицы выполняется функцией «Удалить столбец» [image] (находится на панели инструментов, в главном и контекстном меню). Чтобы удалить строку, на которой находится курсор, необходимо выполнить функцию «Удалить строку» [image].

Также в списке можно выделить группу номеров: удерживая «Shift», отмечать номера строк (это самый первой столбец в таблице). Чтобы выделить различные номера, необходимо, удерживая «Ctrl», отмечать выбранные строки. Выделенные номера можно удалить, выбрав в главном или контекстном меню пункт «Удалить выбранные строки» [image].

В списке номеров не отображаются имена из справочника абонентов. Чтобы выделить номера того или иного абонента, необходимо в разделе «Справочник абонентов» выполнить функцию «Выделить в списке номеров» [image].

Для того чтобы очистить список номеров, необходимо на панели инструментов или в меню выбрать «Очистить список номеров» [image].

Если вы хотите задать порядок обзвона, то необходимо выполнить сортировку списка. Для этого нажмите на заголовок столбца, по которому вы хотите отсортировать список. Отсортированный столбец в заголовке будет отображать стрелку, указывающую направление сортировки: от меньшего к большему или наоборот.

Поиск

В списке номеров можно найти абонента по следующим данным: номер, имя и примечание (последние два берутся из Справочника абонентов). Для вызова поиска нажмите кнопку [image] или «Ctrl + F». Чтобы продолжить поиск абонента, нажмите «F3». Поиск будет продолжаться, пока не достигнет конца списка.

Типы данных

В таблице списка номеров, кроме непосредственно номера, можно указать дополнительные данные. Эти данные содержатся в столбцах «N1», «N2» и т.д. Каждый дополнительный столбец может иметь один из следующих типов:
  • Номер телефона
    • допустимые символы: «0»..«9», «A»..«D», «F», «P», «T», «*», «#», «,» (подробности смотрите в команде Набрать номер)
    • формат: любая последовательность разрешенных символов
    • пример: «4560912», «89127563411»
  • Число
    • допустимые символы: цифры от «0» до «9»
    • формат: число должно быть целым и неотрицательным
    • пример: «1234»
  • Дата (время)
    • допустимые символы: цифры от «0» до «9», пробел, точка, двоеточие
    • формат: ДД.ММ.ГГГГ, чч:мм, ДД.ММ.ГГГГ чч:мм, где «ДД» - число месяца (2 цифры), «ММ» - месяц (2 цифры), «ГГГГ» - год (4 цифры), «чч» - часы (1 или 2 цифры), «мм» - минуты (2 цифры)
    • пример: «01.12.2009», «18:45», «15.05.2009 9:15»
  • Сумма (руб.)
    • допустимые символы: цифры от «0» до «9», точка, запятая
    • формат: целое или дробное число
    • пример: «12.49», «0,01», «1234», «467,5»

Смотрите также:

Справочник абонентов
Программа автообзвона
Алгоритм
Стандартный и альтернативный механизм автообзвона

Прим. 1. CSV файл — это текстовый файл, предназначенный для представления табличных данных. Каждая строка файла — это одна строка таблицы. Значения отдельных колонок разделяются разделительным символом: запятая (,), точка с запятой (;), верт. линия (|) или другие символы. Импорт и экспорт файлов такого типа возможен во многих программах, например: Microsoft Excel, OpenOffice.org Calc, SQL Server Management Studio и другие.


Настройка дозвона

Абонент занят, абонент не отвечает, другое

Результат обзвона каждого номера может быть успешным или неудачным. Неудачный результат может иметь три причины:
  • абонент занят
  • абонент не ответил (не взял трубку)
  • другое или неверный код (разрыв линии, ошибка в программе, сбой аппаратуры, абонент набрал неверный код и др.)
Автообзвон обрабатывает каждый неудачный случай в отдельности. Пользователь должен указать в настройках для каждого случая следующее: через какое время повторить попытку (поле «Повторный звонок через») и количество попыток (поле «Повторять попытку»).

Абонент положил трубку, не дослушав сообщение

В этом параметре необходимо указать, как расценивать ситуацию, в которой абонент положил трубку не дослушав сообщение. Если установлено значение «Абонент занят», то такой случай будет считаться неудачным. Если же указано «Успешно обработан», то звонок будет считаться успешным.

Время ожидания вызова абонента

Этот параметр определяет время, в течение которого Автообзвон ожидает, когда абонент возьмет трубку. Если за это время абонент не возьмет трубку, то данный звонок будет иметь результат «абонент не ответил».

Префикс телефона

Параметр используется для формирования номера, на который будет осуществлен дозвон. Например, в префиксе можно записать код выхода в город (если звонки исходят из офисной АТС). Во время обзвона значение этого параметра присоединяется к номеру из списка номеров.

Реагировать на DTMF при прослушивании сообщения

Если этот параметр установлен, то во время прослушивания сообщения нажатие абонентом любой кнопки на телефоне немедленно завершит текущее сообщение и Автообзвон перейдет к выполнению следующей команды алгоритма.

Смотрите также:


Алгоритм

Алгоритм оповещения можно создать двумя путями:

  • Алгоритм автообзвона, использующий упрощенный интерфейс, который позволяет легко составлять алгоритм оповещения;
  • Конструктор, представляющий собой инструмент для составления алгоритма в наглядном графическом виде (наподобие блок-схемы).


Алгоритм автообзвона

С помощью этого раздела можно быстро и легко составить алгоритм оповещения.

Редактирование алгоритма автообзвона

Алгоритм состоит из последовательности команд. Добавление новой команды к алгоритму выполняется кнопкой «Добавить команду» [image]. После того как команда была добавлена, необходимо указать параметры команды (см. ниже).

Чтобы удалить команду из алгоритма, необходимо нажать кнопку «Удалить команду» [image].

Кнопка «Проверить программу автообзвона на ошибки» [image] выполняет проверку алгоритма. При сохранении программы Автообзвон автоматически выполняет проверку.

Настройки

Перезаписывать алгоритм Конструктора при сохранении. Если эта опция включена, то алгоритм Конструктора будет перезаписан при сохранении алгоритма автообзвона.

Добавить запрос для определения поднятия трубки абонентом при отсутствии гудков в телефонной линии. Иногда при дозвоне на мобильные номера отвечает робот сотового оператора (например сообщая, что абонент не доступен), или вместо гудков звучит мелодия. Если эта опция включена, то при преобразовании алгоритма автообзвона в алгоритм Конструктора будет включен запрос на подтверждение поднятия трубки абонентом. Этот запрос содержит цикл, в котором выполняются следующие команды:
Цикл:
  1. Проиграть аудиофайл с фразой типа «Нажмите любую кнопку».
  2. Ждать нажатия любой кнопки в течение 3 сек.
  3. Проверить, была ли нажата кнопка:
    • Если кнопка была нажата, то перейти к выполнению основного алгоритма автообзвона.
    • Если кнопка не была нажата, то перейти к п. 1.
Этот цикл будет выполняться в течение времени ожидания (указывается в разделе «Настройка дозвона»). Если за это время кнопка не будет нажата, то программа Автообзвона завершит дозвон и отметит данный номер как «Абонент не ответил».

Описание команд и их параметров

Алгоритм оповещения может состоять из следующих команд:
  • Проиграть аудиофайл
    • Параметры: имя звукового файла.
    • Описание: команда воспроизводит в телефонную линию аудиофайл, указанный в ее параметре. Имя (вместе с путем, если он есть) файла должно быть менее 100 символов. Аудиофайл должен иметь следующий формат: несжатый PCM (как правило, с расширением «WAV»), частота 11,025 кГц, 8 бит, моно. В параметре можно вызвать Звуковой редактор (кнопка [image]). Если имя файла уже указано, то редактор откроет этот файл. При сохранении аудиофайла в редакторе (пункт меню «Сохранить как») его имя будет автоматически присвоено параметру, из которого был вызван редактор.
  • Произнести данные
    • Параметры:
      • «Телефон, число, дата/время, сумма (руб.)»: наименование столбца;
      • «Проиграть аудиофайл по шаблону»: шаблон (маска) имени файла;
    • Описание: команда извлекает данные об абоненте, находящиеся в указанном столбце списка номеров (см. раздел «Список номеров»), и выполняет одно из следующих действий:
      • «Телефон, число, дата/время, сумма (руб.)»: воспроизводит в телефонную линию полученные данные;
      • «Проиграть аудиофайл по шаблону»: воспроизводит в телефонную линию аудиофайл. В имени файла можно указать наименование столбца, выделенное символом «%» («процент»). Например, пусть указан следующий шаблон имени файла: «c:\audio\file%N1%ver%N2%.wav». При выполнении команды имя будет преобразовано следующим образом: «c:\audio\file» плюс значение столбца N1 (например «1») плюс «ver» плюс значение столбца N2 (например «15») плюс «.wav», т.е. в результате имя файла будет «c:\audio\file1ver15.wav». Звуковые файлы должны находиться на компьютере, где установлен Сервер SpRobot.
  • Ожидать ввод N символов
    • Параметры: количество символов, время ожидания ввода (тайм-аут).
    • Описание: команда ожидает ввода символов (DTMF сигналов) абонентом. Ввод завершится после того, как абонент введет определенное количество символов. Если за время тайм-аут абонент не введет ни одного символа, то команда завершится, и алгоритм перейдет к выполнению следующей команды. Отсчет времени ожидания начинается после каждого нажатия символа. Символы, введенные абонентом, запоминаются в базе данных (см. раздел «Журнал обзвона»).
  • Ожидать ввод до завершающего символа
    • Параметры: завершающий символ, время ожидания ввода (тайм-аут).
    • Описание: команда ожидает ввода символов (DTMF сигналов) абонентом. Ввод прекращается после нажатия символа завершения, который выбирается из всплывающего списка. Если за время тайм-аут абонент не введет ни одного символа, то команда завершится, и алгоритм перейдет к выполнению следующей команды. Отсчет времени ожидания начинается после каждого нажатия символа. Символы, введенные абонентом, запоминаются в базе данных (см. раздел «Журнал обзвона»).
  • Запросить код
    • Параметры:
      • «Любое значение»: без параметров;
      • «Статический код»: значение кода;
      • «Код из столбца»: наименование столбца, завершающий символ.
    • Описание: команда ожидает ввод кода абонентом. Использование этой команды гарантирует доставку голосового сообщения. Если абонент введет неверный код, то эта ситуация будет расцениваться как «Другое или неверный код» (см. раздел «Настройка дозвона»). Символы, введенные абонентом, запоминаются в базе данных (см. раздел «Журнал обзвона»).
      • «Любое значение» - абонент должен нажать любую кнопку телефона.
      • «Статический код» - от всех оповещаемых абонентов ожидается ввод одного и того же кода, указанного в этой команде.
      • «Код из столбца» - абонент должен ввести код, содержащийся в указанном столбце списка номеров (см. раздел «Список номеров»). В этом случае код может быть индивидуальным для каждого абонента. После ввода кода абонент должен нажать завершающий символ (по умолчанию «решетка»).

Смотрите также:


Соединения с БД пользователя

Программа SpRobot имеет функции, которые позволяют обращаться к любым базам данных (MS SQL, MySQl, MS Access, MS Excel и др.). С помощью команд алгоритма «Выполнить SQL запрос» и «Получить значение из SQL выборки» можно извлекать и изменять данные. Для того чтобы соединиться с БД, необходимо установить параметры связи в разделе «Алгоритм/Соединения с БД пользователя».

Добавление, изменение и удаление

С помощью главного и контекстного меню и панели инструментов можно выполнить следующие действия:
  • Добавить соединение с БД.
  • Изменить свойства соединения с БД.
  • Удалить соединение с БД.
  • Обновить список соединений.
Свойства соединения с БД

  • Имя соединения. Каждое соединение должно иметь имя (псевдоним), которое используется в команде алгоритма «Выполнить SQL запрос».
  • Тайм-аут (сек.). Определяет максимальное время выполнения SQL запроса.
  • Параметры соединения. Содержит строку подключения к БД пользователя. Строку можно заполнить вручную или с помощь интерфейса Windows «Свойства связи с данными», вызываемого кнопкой

Смотрите также:

Список и описание команд алгоритма
Пример 1. Создание соединения с MS SQL
Пример 2. Создание соединения с MySQL
Пример 3. Создание соединения с MS Excel версии 97, 2000
Пример 4. Создание соединения с MS Access
Пример 5. Создание соединения с текстовым файлом
Формат текстового файла данных


Пример 2. Создание соединения с MySQL

Для получения доступа к MySQL через OLE DB необходимо установить компонент MySQL Connector/ODBC
  1. В окне «Свойства соединения с БД» введите имя соединения.
  2. Укажите время тайм-аут.
  3. В параметрах соединения укажите один из следующих вариантов подключения:

    • Локальная база данных:

      Driver={MySQL ODBC 5.2a Driver}; Server=localhost; Database=имя БД; User=логин;Password=пароль; Option=3;
      В выделенных местах строки подключения укажите реальные имя БД, логин и пароль пользователя.

    • Удаленная база данных:

      Driver={MySQL ODBC 5.2a Driver}; Server=Адрес сервера MySQL; Database=имя БД; User=логин;Password=пароль; Option=3;
      В выделенных местах строки подключения укажите реальные адрес сервера MySQL (имя компьютера или IP), имя БД, логин и пароль пользователя.

  4. Соединение готово. В окне «Свойства соединения с БД» нажмите кнопку «OK».

Пример SQL запроса

select * from table1 where ID=~Var1~ limit 1

Этот запрос возвратит одну строку таблицы table1, у которой столбец ID равен значению переменной Var1. Переменная создана в алгоритме Конструктора.

Смотрите также:

Соединения с БД пользователя
Пример 1. Создание соединения с MS SQL
Пример 3. Создание соединения с MS Excel версии 97, 2000
Пример 4. Создание соединения с MS Access
Пример 5. Создание соединения с текстовым файлом
Формат текстового файла данных


Конструктор

Конструктор предназначен для составления алгоритма оповещения. Он создает графическое представление алгоритма, наглядно показывающее, как будут выполняться команды программы. Инструментарий Конструктора очень гибок, что дает пользователю возможность создавать практически любой алгоритм в рамках имеющихся команд.

В Конструкторе можно выделить несколько рабочих областей: 1 – панель команд, 2 – поле алгоритма, 3 – свойства команды, 4 – описание команды и ее параметров.

Создание алгоритма

Алгоритм создается следующим образом: сначала необходимо выбрать команду на панели команд, потом в поле алгоритма указать на связь (голубая линия между командами), куда необходимо вставить новую команду, и, если нужно, настроить параметры команды в области свойства команды (установка команды «Перейти к метке» имеет некоторые отличия, подробности см. в описании команды в разделе «Список и описание команд алгоритма»).

Отмена текущего действия осуществляется нажатием на панели команд кнопки «Отменить действие» [image], удаление команды производится после нажатия кнопки «Удалить команду» [image].

Многие команды алгоритма имеют различные параметры. Они настраиваются в области свойства команды двумя способами: с использованием всплывающего списка и редактируемого поля.

Во время составления алгоритма Автообзвон запоминает сделанные изменения. Эти изменения можно отменить или вернуть, используя меню Клиента («Правка/Отменить изменение» и «Правка/Вернуть изменение») или панель инструментов (кнопки [image] и [image]).

В Конструкторе пользователь может выделять команды, используя прямоугольник выделения (удерживается левая кнопка мыши и выбираются команды) или клавиши CTRL и SHIFT.

Контекстное меню

В Конструкторе можно копировать, удалять, вырезать и вставлять выделенные команды. Эти операции доступны в контекстном меню или в меню Клиента.

Сохранение и загрузка

После того как алгоритм был разработан, его необходимо сохранить в базу данных. На панели инструментов необходимо нажать кнопку «Сохранить алгоритм в базу данных» [image] (или в меню Клиента выбрать пункт «Конструктор/Сохранить...») и указать имя алгоритма. Перед сохранением всегда осуществляется проверка алгоритма на ошибки.

Конструктор позволяет изменять алгоритм, который уже был сохранен в базе данных. Для этого необходимо загрузить его в Конструктор. Выберите в меню Клиента пункт «Конструктор/Открыть...» или на панели инструментов нажмите на кнопку «Загрузить алгоритм из базы данных» [image], выберите имя из списка.

При конструировании алгоритма можно периодически проверять его на наличие ошибок, нажав на панели инструментов кнопку «Проверить алгоритм на ошибки» [image] или выбрав в меню Клиента пункт «Конструктор/Проверить на ошибки».

Удаление существующего алгоритма выполняется кнопкой «Создать новый алгоритм» [image], при этом алгоритм, находящийся в БД, не изменяется.

Импорт и экспорт алгоритма

Созданный алгоритм можно сохранить в отдельный файл (экспортировать). Эта операция выполняется через меню Клиента («Конструктор/Экспорт...») или через панель инструментов (кнопка [image]). В экспортируемом файле сохраняются все команды, их параметры, а также используемые аудиофайлы.

Загрузка алгоритма из файла (импорт) выполняется через меню Клиента («Конструктор/Импорт...») или через панель инструментов (кнопка [image]). Автообзвон извлекает из указанного файла команды и аудиофайлы. Последние сохраняются в папке «Import\<название файла без расширения>», которая находится в директории Клиента.

Смотрите также:


Список и описание команд алгоритма

Вкладка «События»
Команды этой вкладки ожидают некоторое событие и при его наступлении передают управление следующей команде.

Ждать действия абонента
Параметры: имя переменной Var, время ожидания N.
Описание: команда ожидает действие вызываемого абонента. Возможны следующие варианты: вызываемый абонент взял трубку – переменная Var примет значение «0», абонент занят – Var будет равна «1», вышло время ожидания – Var будет содержать «2». Имя переменной Var может содержать английские и русские буквы, цифры и знак подчеркивания «_», но оно не должно начинаться с цифры. Время ожидания N измеряется в секундах, и оно не должно быть отрицательным. Эта команда используется только после выполнения команды Набрать номер.

Ввод символа(ов) до завершающего символа
Параметры: имя переменной Var, символ завершения, время ожидания N, значение по умолчанию Val.
Описание: команда ожидает ввода символов (DTMF сигналов) абонентом. Ввод прекращается нажатием символа завершения, который выбирается из всплывающего списка. Результат ввода (исключая символ завершения) заносится в переменную Var. В качестве символа завершения можно использовать цифры от «0» до «9», буквы «A», «B», «C», «D» и символы «*», «#». Если за время N абонент не введет ни одного символа, то команда завершится, и переменная Var примет значение по умолчанию Val. Отсчет времени ожидания начинается после каждого нажатия символа. Параметр N измеряется в секундах, и он не должен быть отрицательным.

Ввод заданного числа символов
Параметры: имя переменной Var, количество символов N1, время ожидания N2, значение по умолчанию Val.
Описание: команда ожидает ввода символов (DTMF сигналов) абонентом. Ввод завершится после того, как абонент введет определенное количество символов. Результат ввода содержится в переменной Var. Количество символов N1 должно быть больше ноля. Если за время N2 абонент не введет ни одного символа, то команда завершится, и переменная Var примет значение по умолчанию Val. Отсчет времени ожидания начинается после каждого нажатия символа. Параметр N2 измеряется в секундах, и он не должен быть отрицательным.

Вкладка «Действия»
Команды этой вкладки выполняют конкретные действия, вызывая внутренние команды устройства SpRecord.

Набрать номер
Параметры: номер телефона Num.
Описание: команда набирает номер телефона Num. Номер может содержать следующие символы: «0»..«9», «A», «B», «C», «D», «*», «#», «F» (кнопка Flash), «P» (в начале номера, импульсный набор), «T» (в начале номера, тоновый набор), «,» (пауза 1 сек.). Длительность Flash-паузы задается в разделе «Сервер/Настройка». Также внутри номера можно включать переменные, выделенные символом «%» («процент»). Например, пусть параметр Num содержит «123 %Var1% 1321». При наборе номер будет преобразован следующим образом: «123» плюс значение переменной Var1 (например «102») плюс «1321», т.е. в результате номер будет содержать «1231021321». Пробелы игнорируются. С помощью контекстного меню параметра можно вставить существующие переменные в набираемый номер.

Взять трубку
Параметры: нет.
Описание: команда замыкает шлейф телефонной линии (поднимает телефонную трубку).

Положить трубку
Параметры: нет.
Описание: команда размыкает шлейф телефонной линии (кладет телефонную трубку).

Проиграть аудиофайл
Параметры: имя файла File.
Описание: проиграть аудиофайл в телефонную линию. Имя файла (вместе с путем) должно быть меньше 100 символов. Аудиофайл должен иметь следующий формат: несжатый PCM (как правило, с расширением «WAV»), частота 11,025 кГц, 8 бит, моно. Звуковые данные можно передавать в телефонную линию только при поднятой трубке телефона (см. команду Взять трубку). Если во время проигрывания абонент нажал кнопку телефона, то проигрывание немедленно прекращается, а введенный символ запоминается (это возможно, если в разделе «Настройка дозвона» установлен параметр «Реагировать на DTMF при прослушивании сообщения»). Этот символ будет автоматически передан следующей команде ожидания ввода. В параметре File можно указать следующее:
  • конкретное имя файла. Файл должен находиться на компьютере, на котором создается алгоритм голосового меню. При сохранении алгоритма указанный аудиофайл копируется на компьютер Сервера SpRobot. Используя контекстное меню параметра, можно открыть Звуковой редактор. Если параметр содержит имя файла, то редактор откроет этот файл. При сохранении аудиофайла в редакторе (пункт меню «Файл/Сохранить как») его имя будет автоматически прописано в параметре.
  • имя файла по шаблону (маске) с использованием переменных. В этом случае звуковые файлы должны находиться на компьютере, где установлен Сервер SpRobot. Имя файла должно содержать переменные, выделенные символом «%» («процент»). Например, пусть параметр File содержит «c:\audio\file%Var1%.wav». При выполнении команды имя будет преобразовано следующим образом: «c:\audio\file» плюс значение переменной Var1 (например «1») плюс «.wav», т.е. в результате имя файла будет «c:\audio\file1.wav».

Вкладка «Служебные»
В эту группу входят команды, реализация которых не связана с вызовом внутренних команд устройства SpRecord.

Условие «Если равно»
Параметры: имя переменной, значение Val.
Описание: команда сравнивает переменную со значением Val. Если они равны, то будут выполнятся команды в ветке «Да», иначе – в ветке «Нет» (см. рис. ниже). Переменная выбирается из всплывающего списка. Также внутри значения Val можно включать переменные, выделенные символом «%».

Выход из программы
Параметры: нет.
Описание: команда завершает работу алгоритма.

Метка
Параметры: имя метки Lab.
Описание: метка устанавливается в то место алгоритма, в которое планируется осуществить переход (см. команду Перейти к метке). Имя метки Lab может содержать английские и русские буквы, цифры и знак подчеркивания «_», но оно не должно начинаться с цифры.

Перейти к метке
Параметры: имя метки.
Описание: команда осуществляет переход в алгоритме на указанную метку. Метка выбирается из всплывающего списка. При выборе этой команды в панели команд вначале необходимо указать в алгоритме метку, на которую планируется осуществить переход, а после этого установить команду перехода в алгоритме. Таким образом перед использованием этой команды алгоритм уже должен содержать необходимую метку.

Пауза
Параметры: задержка N.
Описание: команда выполняет задержку на N миллисекунд. Напомню, что в 1 секунде содержится 1000 миллисекунд (мсек.). Задержка N не должна быть меньше ноля. Если во время этой команды появится тоновый сигнал "Занято", то SpRobot либо прервет ее выполнение и перейдет в начало алгоритма, либо будет ожидать все указанное время без прерывания. Это поведение регулируется в команде Зафиксировать событие (по умолчанию команда "Пауза" не реагирует на сигнал "Занято").

Перейти в начало алгоритма
Параметры: нет.
Описание: команда переходит в начало алгоритма и выполняет первую команду.

Зафиксировать событие
Параметры: тип события, текст Val.
Описание: команда записывает сообщение с текстом Val в журнал событий (см. раздел «Журнал событий»). Тип события выбирается пользователем из всплывающего списка. Текст может содержать любые символы и переменные, выделенные символом «%» («процент»). Также с помощью этой команды можно изменять различные настройки Автообзвона. Для этого необходимо:
  1. выбрать тип «Событие пользователя»;
  2. в параметре Val написать одно из следующих значений:
    • SetSensDTMF - реагировать на DTMF при проигрывании аудиофайла;
    • ResetSensDTMF - не реагировать на DTMF при проигрывании аудиофайла;
    • DefaultSensDTMF - установить значение, указанное в настройках дозвона;
    • SetIfBusySuccess - установить параметр «Абонент положил трубку, не дослушав сообщение» как «Успешно обработан»;
    • ResetIfBusySuccess - установить параметр «Абонент положил трубку, не дослушав сообщение» как «Абонент занят»;
    • DefaultIfBusySuccess - установить параметр «Абонент положил трубку, не дослушав сообщение» так, как указано в «Настройке дозвона».
    • Dial "<имя_канала>" <режим> - указать режим набора номера: тоновый или импульсный. Имя канала - это имя, прописанное в устройстве SpRecord, например "T4002061 - 1" (не путать с именем канала пользователя). При указании канала кавычки обязательны, регистр букв в имени учитывается. Режим - может принимать значения: tone или pulse.

      Пример. Чтобы на канале "T4002030 - 1" набор номера производился в тоновом режиме, в параметре Val необходимо написать следующее:

      Dial "T4002030 - 1" Tone

    • PauseReactBusy - в команде Пауза реагировать на тоновый сигнал "Занято";
    • PauseNoReactBusy - в команде Пауза не реагировать на тоновый сигнал "Занято" (по умолчанию не реагировать).

Создать переменную
Параметры: имя переменной Var.
Описание: команда создает переменную с именем Var и делает ее доступной другим командам алгоритма. Если переменная с именем Var уже существует, то команда сразу завершается и передает управление следующей команде.

Установить значение переменной
Параметры: имя переменной, значение Val.
Описание: команда присваивает переменной значение Val. Значение также может содержать переменные, выделенные символом «%» («процент»). Переменная выбирается из всплывающего списка.

Увеличить значение переменной на 1
Параметры: имя переменной.
Описание: команда увеличивает значение переменной на 1. Переменная выбирается из всплывающего списка.

Выполнить SQL запрос
Параметры: имя соединения с БД, текст запроса, имя переменной Var1, имя переменной Var2.
Описание: команда выполняет SQL запрос к базе данных пользователя. Настройка соединения выполняется в разделе «Алгоритм/Соединения с БД пользователя». Имя соединения выбирается из списка. В тексте запроса можно указать переменные, созданные в алгоритме Конструктора. В запросе имена переменных необходимо заключить между символами «~» (тильда), например:
SELECT * FROM table1 WHERE column1=~UserVar~
Также в запросе можно указать предопределенные переменные:
  • ~VcMailFileName~ имя файла последнего записанного голосового сообщения;
  • ~RecordFileName~ имя файла записанного телефонного разговора;
  • ~GetChannelName~ имя канала SpRecord, на котором выполняется алгоритм Автообзвона;
  • ~GetPrgID~ идентификатор алгоритма Автообзвона (поле «ID» таб. «AutoDialing»);
  • ~NumID~ идентификатор текущего номера обзвона.
Например:
INSERT INTO Table (Col1, Col2) VALUES ('~RecordFileName~', '~VcMailFileName~')
После выполнения команды переменная Var1 содержит результат: 0 - ошибка, 1 - успешное выполнение. Если запрос возвращает набор данных (например, используется запрос SELECT), то переменная Var2 будет содержать количество записей в этом наборе. Если запрос выполнился с ошибкой или не вернул набор данных, то Var2 будет равна 0. Var1 и Var2 выбираются из всплывающего списка.

Также вместо текста запроса можно указать файл, в котором он содержится. Этот файл должен находиться на компьютере, где установлен Сервер SpRobot. Для указания файла напишите в фигурных скобках следующее: слово «FILE», двоеточие и имя файла, например:
{FILE:C:\SomeFolder\SomeQuery.sql}

Получить значение из SQL выборки
Параметры: имя столбца, имя переменной.
Описание: команда извлекает из SQL выборки значение, содержащееся в указанном столбце, и сохраняет его в переменной. Набор данных SQL выборки формируется командой «Выполнить SQL запрос». Если набор дынных содержит более одной записи, то значение будет взято из первой записи. Если указанный столбец отсутствует в выборке или выборка не определена, то переменная будет содержать пустую строку.

Выполнить скрипт Visual Basic
Параметры: текст скрипта, имя переменной.
Описание: команда выполняет скрипт Visual Basic. В переменную заносится результат выполнения: 0 - ошибка, 1 - успех. В скрипте можно оперировать данными, содержащимися в алгоритме автообзвона:
  • SpRobot.Vars("имя_переменной") - получить/установить значение переменной, созданной в Конструкторе;
  • SpRobot.ANI - получить определившийся номер АОН;
  • SpRobot.GetChannelName - получить имя канала SpRecord, на котором выполняется алгоритм Автообзвона;
  • SpRobot.GetPrgID - получить идентификатор алгоритма Автообзвона (поле «ID» таб. «AutoDialing»);
  • SpRobot.RecordFileName - получить имя файла записанного телефонного разговора;
  • SpRobot.VcMailFileName - получить имя файла последнего записанного голосового сообщения;
  • SpRobot.PrgIsRun("имя_канала_в_устройстве") - узнать, запущен ли алгоритм SpRobot на указанном канале: 0 - не запущен, 1 - запущен;
  • SpRobot.GetChannelState("имя_канала_в_устройстве") - получить состояние канала:
    • -1 - канал не найден;
    • 0 - линия отключена;
    • 1 - трубка положена;
    • 2 - трубка поднята;
    • 3 - ошибка определения состояния, повторите попытку позже;
  • SpRobot.GetNumID - получить идентификатор текущего номера обзвона.
Например, следующий скрипт записывает некоторые данные Автообзвона в файл «output.log»:
Dim oFso, oMyFile, TempVar
Set oFso = CreateObject("Scripting.FileSystemObject")
Set oMyFile = oFso.OpenTextFile("C:\output.log", 8 , True)

' сохранить имя файла записанного телефонного разговора
oMyFile.WriteLine("Запись разговора: " & SpRobot.RecordFileName)

' сохранить имя файла последнего записанного голосового сообщения
oMyFile.WriteLine("Запись голосового сообщения: " & SpRobot.VcMailFileName)

' получить состояние канала
oMyFile.WriteLine("Состояние канала: " & SpRobot.GetChannelState("T4001234 - 1"))

' получить значение переменной Var1, созданной в Конструкторе Автообзвона
TempVar = SpRobot.Vars("Var1")

' изменить значение переменной Var1, созданной в Конструкторе Автообзвона
SpRobot.Vars("Var1") = "9" & TempVar

oMyFile.Close
Set oMyFile = Nothing
Set oFso = Nothing
Также вместо текста скрипта можно указать файл, в котором он содержится. Этот файл должен находиться на компьютере, где установлен Сервер SpRobot. Для указания файла напишите в фигурных скобках следующее: слово «FILE», двоеточие и имя файла, например:
{FILE:C:\SomeFolder\SomeScript.vbs}

Показать сообщение
Параметры: пользователь(и) Val1, текст сообщения Val2.
Описание: команда отображает сообщение с текстом Val2 для указанных пользователей (Val1). Сообщение будет показано только в открытой программе Автообзвон SpRobot. Вид сообщения (обычное или всплывающее окно) и другие параметры указываются в меню «Система/Параметры». Пользователи должны быть зарегистрированы в системе Автообзвон SpRobot. В параметре Val1 можно указать одного пользователя, несколько пользователей (через запятую) или пустое значение. В последнем случае сообщение будет показано всем авторизованным пользователям. Параметр Val2 содержит текст сообщения. Val1 и Val2 могут содержать переменные, заключенные в символ процента «%».

Также вместо текста сообщения можно указать файл, в котором он содержится. Этот файл должен находиться на компьютере, где установлен Сервер SpRobot. Для указания файла напишите в фигурных скобках следующее: слово «FILE», двоеточие и имя файла, например:
{FILE:C:\SomeFolder\SomeMessage.txt}

Запустить внешнее приложение
Параметры: пользователь(и) Val1, имя файла File, параметры запуска Val2.
Описание: команда запускает внешнее приложение File для указанных пользователей (Val1). Внешнее приложение будет запущено, если открыта программа Автообзвон SpRobot. Пользователи должны быть зарегистрированы в системе Автообзвон SpRobot. В параметре Val1 можно указать одного пользователя, несколько пользователей (через запятую) или пустое значение. В последнем случае сообщение будет показано всем авторизованным пользователям. Val2 содержит строку параметров, которая будет передана внешнему приложению при запуске. Параметры Val1, File и Val2 могут содержать переменные, заключенные в символ процента «%».

Показать HTML страницу
Параметры: пользователь(и) Val1, текст HTML страницы Val2.
Описание: команда отображает HTML страницу с текстом Val2 для указанных пользователей (Val1). Сообщение будет показано только в открытой программе Автообзвон SpRobot. Вид сообщения (обычное или всплывающее окно) и другие параметры указываются в меню «Система/Параметры». Пользователи должны быть зарегистрированы в системе Автообзвон SpRobot. В параметре Val1 можно указать одного пользователя, несколько пользователей (через запятую) или пустое значение. В последнем случае сообщение будет показано всем авторизованным пользователям. Val1 может содержать переменные, заключенные в символ процента «%». Параметр Val2 содержит текст HTML страницы. Val2 может содержать переменные, заключенные в символ тильда «~».

Также вместо текста HTML страницы можно указать файл, в котором он содержится. Этот файл должен находиться на компьютере, где установлен Сервер SpRobot. Для указания файла напишите в фигурных скобках следующее: слово «FILE», двоеточие и имя файла, например:
{FILE:C:\SomeFolder\SomePage.html}

Вкладка «Голосовая почта»
В эту группу входят команды, выполняющие операции над сообщениями и ящиками голосовой почты. Записанные сообщения сохраняются для пользователей, зарегистрированных в система Автосекретарь SpRobot. Таким образом, чтобы прослушать голосовую почту, нужно авторизоваться в Клиенте Автосекретаря.

Записать голосовое сообщение
Параметры: логин пользователя Автосекретаря, имя файла File, символ остановки записи.
Описание: команда проигрывает аудиофайл в телефонную линию, выдает короткий гудок и затем записывает голосовое сообщение для указанного пользователя. Сообщение можно оставить только для зарегистрированного в системе Автосекретаря пользователя, который выбирается из всплывающего списка (см. раздел Администрирование пользователей в Автосекретаре). В качестве пользователя можно указать переменную, выделенную символом «%» («процент»). Описание параметра «имя файла» дано в команде Проиграть аудиофайл. Максимальная длина одного голосового сообщения определяется настройками пользователя (см. раздел Администрирование пользователей в Автосекретаре). При нажатии абонентом символа остановки прекращается запись голосового сообщения. В качестве символа остановки можно использовать цифры от «0» до «9», буквы «A», «B», «C», «D» и символы «*», «#».

Получить ID последнего голосового сообщения
Параметры: имя переменной Var.
Описание: команда заносит в переменную Var идентификатор голосового сообщения, который был записан с помощью команды Записать голосовое сообщение. Если в алгоритме до команды «Получить ID последнего голосового сообщения» уже несколько раз записывалось голосовое сообщение, то возвращается идентификатор последнего записанного сообщения. Если Var содержит «0», то идентификатор не определен. После вызова этой команды при прослушивании сообщения с помощью команды Прослушать голосовое сообщение признак «Сообщение прослушано» изменяться не будет. Изменение этого признака при прослушивании сообщения будет происходить после вызова команды Проверить пароль ящика голосовой почты.

Удалить голосовое сообщение
Параметры: имя переменной.
Описание: команда удаляет из системы голосовое сообщение, идентификатор которого находится в переменной. Переменная выбирается из всплывающего списка.

Прослушать голосовое сообщение
Параметры: имя переменной, формат даты N.
Описание: команда воспроизводит в телефонную линию записанное в системе голосовое сообщение, идентификатор которого находится в переменной. Переменная выбирается из всплывающего списка. При выполнении этой команды голосовое сообщения отмечается как прослушанное (исключения см. в команде Получить ID последнего голосового сообщения. При воспроизведении программа в зависимости от формата даты N произносит дату и время записи сообщения. Формат даты определяется комбинацией следующих значений: 1 - день недели, 2 - число, 4 - месяц, 8 - часы, 16 - минуты, 32 - год, 64 - произнести дату в конце сообщения. Например, если N будет равно 102 (т.е. 2 + 4 + 32 + 64), то программа произнесет число, месяц и год записи сообщения после воспроизведения голосового сообщения. А если N будет равно 25 (т.е. 1 + 8 + 16), то программа произнесет день недели, час и минуту записи сообщения перед воспроизведением голосового сообщения. Во время прослушивания сообщения можно управлять воспроизведением: кнопка «7» - перемотка назад на 5 сек., «9» - перемотка вперед на 5 сек., «*» - приостановить/продолжить, «#» - завершить прослушивание, выйти из команды.

Проверить, существует ли ящик голосовой почты
Параметры: имя переменной Var1, имя переменной Var2.
Описание: команда проверяет, существует ли ящик голосовой почты с номером, содержащимся в переменной Var1. Если ящик с таким номером существует, то переменная Var2 будет содержать «1», иначе - «0». Переменная Var1 выбирается из всплывающего списка.

Проверить пароль ящика голосовой почты
Параметры: имя переменной Var1, имя переменной Var2, имя переменной Var3.
Описание: команда проверяет пароль (переменная Var2) ящика с номером Var1 и возвращает результат в переменной Var3. Если пароль для указанного ящика верный, то Var3 будет содержать «1», если нет, то Var3 примет значение «0». Переменные Var1 и Var2 выбираются из всплывающего списка. Эта команда влияет на признак «Сообщение прослушано» (подробнее см. команды Получить ID последнего голосового сообщения и Прослушать голосовое сообщение).

Удалить все сообщения из ящика
Параметры: имя переменной.
Описание: команда удаляет все голосовые сообщения из ящика с номером, определяемым содержимым переменной. Переменная выбирается из всплывающего списка.

Удалить прослушанные сообщения из ящика
Параметры: имя переменной.
Описание: команда удаляет все прослушанные голосовые сообщения из ящика с номером, определяемым содержимым переменной. Переменная выбирается из всплывающего списка.

Проверить, пустой ли ящик голосовой почты
Параметры: имя переменной Var1, имя переменной Var2
Описание: команда проверяет, есть ли сообщения в ящике с номером Var1. Если сообщения отсутствуют, то переменная Var2 будет равна «0», иначе - «1». Переменная Var1 выбирается из всплывающего списка.

Получить список сообщений ящика голосовой почты
Параметры: имя переменной.
Описание: команда формирует внутренний список идентификаторов всех голосовых сообщений, находящихся в ящике, номер которого определяется переменной. Сообщения в списке расположены по убыванию их даты записи, т.е. в начале списка находятся сообщения, записанные последними. Эта команда необходима для перемещения между сообщениями и должна вызываться всегда перед использованием команд Список пуст или достигнут конец списка, Перейти к предыдущему сообщению в списке, Перейти к следующему сообщению в списке, и Получить ID текущего сообщения в списке. Имя переменной выбирается из всплывающего списка.

Список пуст или достигнут конец списка
Параметры: имя переменной Var.
Описание: команда проверяет состояние списка сообщений, сформированного командой Получить список сообщений ящика голосовой почты. Результат проверки находится в переменной Var: «0» - список пуст, «1» - достигнут конец списка, во всех остальных случаях «2». Она проверяет внутренний флаг, сигнализирующий о достижении конца списка, записывает результат в переменной Var и сбрасывает этот флаг в состояние «Конец списка не достигнут» (см. команду Перейти к следующему сообщению в списке). Эта команда всегда должна вызываться после выполнения команды Получить список сообщений ящика голосовой почты.

Перейти к предыдущему сообщению в списке
Параметры: нет.
Описание: команда перемещает текущий указатель в списке сообщений на предыдущую позицию. Если перед выполнением команды указатель уже был на первой позиции в списке, то команда не выполнит никаких действий. Эта команда всегда должна вызываться после выполнения команды Получить список сообщений ящика голосовой почты.

Перейти к следующему сообщению в списке
Параметры: нет.
Описание: команда перемещает текущий указатель в списке сообщений на следующую позицию. Если перед выполнением команды указатель уже был на последней позиции в списке, то команда установит внутренний флаг в состояние «Достигнут конец списка» и не выполнит никаких действий (см. команду Список пуст или достигнут конец списка). Эта команда всегда должна вызываться после выполнения команды Получить список сообщений ящика голосовой почты.

Получить ID текущего сообщения в списке
Параметры: имя переменной Var.
Описание: команда заносит в переменную Var идентификатор сообщения, на который указывает текущий указатель в списке сообщений. Если Var равен «0», то идентификатор не определен. Эта команда всегда должна вызываться после выполнения команды Получить список сообщений ящика голосовой почты.

Произнести количество сообщений
Параметры: имя переменной.
Описание: команда произносит в телефонную линию количество всех сообщений, находящихся в ящике голосовой почты, а затем – количество прослушанных сообщений. Номер ящика определяется переменной, которая выбирается из всплывающего списка.

Вкладка «Автообзвон»
В эту группу входят команды оповещения абонентов.

Начать автообзвон
Параметры: имя переменной Var.
Описание: команда запрашивает у Сервера очередной номер для обзвона. После его получения команда берет трубку и возвращает в переменной Var номер абонента. Любой алгоритм оповещения всегда должен начинаться с этой команды и заканчиваться командой Закончить автообзвон. Эта команда сбрасывает значения всех переменных кроме Var.

Закончить автообзвон
Параметры: имя переменной, значение Val.
Описание: команда кладет трубку телефона, сохраняет в БД значение Val и результат обзвона, который содержится в переменной. Переменная должна содержать одно из следующих значений: 0 - успешный обзвон, 1 - абонент занят, 2 - абонент не отвечает, 3 - другое или неверный код. Значение Val содержит введенные абонентом символы (можно указать переменные, выделенные символом «%»). Val будет отображаться в Состоянии номеров (колонка «DTMF ответ») и в Журнале обзвона (колонка «Ответ абонента»). Любой алгоритм оповещения всегда должен начинаться с команды Начать автообзвон и заканчиваться описываемой командой.

Получить данные об абоненте
Параметры: имя столбца, имя переменной Var1, имя переменной Var2.
Описание: команда возвращает содержимое столбца для текущего абонента (он определяется командой Начать автообзвон). В переменной Var1 возвращается тип данных: 0 - неопределенный тип (в случае ошибки), 1 - номер телефона, 2 - целое положительное число, 3 - дата/время, 4 - сумма руб. Var2 содержит значение указанного столбца. При формировании списка номеров в Автообзвоне пользователь может указать дополнительные данные каждого абонента в столбцах N1, N2 и т.д. Значения именно этих столбцов извлекает описываемая команда. Содержимое переменных Var1 и Var2 используется в команде Произнести данные об абоненте

Произнести данные
Параметры: имя переменной Var1, имя переменной Var2.
Описание: команда произносит в телефонную линию содержимое переменной Var2. Тип произносимых данных указывается в Var1. Перед вызовом описываемой команды необходимо определить значения переменных Var1 и Var2, например с помощью команды Получить данные об абоненте.

Обработать событие
Параметры: событие, текст скрипта, имя переменной.
Описание: команда выполняет скрипт Visual Basic при появлении события, указанного в первом параметре. В переменную заносится результат выполнения: 0 - ошибка, 1 - успех. Более подробное описание выполнения скриптов Visual Basic смотрите в команде Выполнить скрипт Visual Basic. Событие выбирается пользователем из всплывающего списка. Возможны следующие значения:
  • «Первый запуск обзвона» - выполняется 1 раз при первом запуске обзвона.
  • «Последняя остановка обзвона» - выполняется 1 раз при окончательном завершении обзвона (например, по расписанию или когда пользователь нажал кнопку "Остановить выполнение программы автообзвона на каналах" или когда закончились номера).
  • «Промежуточный запуск обзвона» - выполняется при первом и каждом промежуточном запуске обзвона (например, если обзвон происходит в несколько этапов по расписанию или каждый раз при срабатывании датчика).
  • «Промежуточная остановка обзвона» - выполняется при каждом промежуточном и последнем завершении обзвона.
  • «Запуск на канале» - выполняется при каждом запуске обзвона на каждом канале.
  • «Остановка на канале» - выполняется при каждой остановке обзвона на каждом канале.
События запуска выполняются в соответствии с их порядком расположения в алгоритме Конструктора. Порядок выполнения событий остановки не зависит от расположения команды. События остановки выполняются в такой последовательности: остановка на канале, промежуточная остановка обзвона, последняя остановка обзвона.

Смотрите также:


Расписание

В разделе «Расписание» выполняется настройка запуска программ оповещения. Чтобы настроить запуск, необходимо указать:
  • условие запуска (по времени, по датчику или вручную);
  • каналы, на которых будет выполняться оповещение;
  • количество запусков обзвона.
Условие запуска

Существует 3 типа запуска программы оповещения:
  • Период 1. Этот тип запуска позволяет указать период выполнения программы оповещения.
    • Если параметр «Звонить в промежутке» не отмечен, то программа запустится во время, указанное в поле «Начало», а завершится во время, указанное в поле «Конец».
    • Если параметр «Звонить в промежутке» установлен, то программа запустится в указанные дни недели и во время, определенное в поле «Старт». Программа будет выполняться в течение времени, указанного в поле «Длительность».
    Период запуска должен быть больше 2-х минут.
  • Запуск по датчику. В этом случае программа запустится, когда сработает датчик, подключенный к компьютеру Сервера.
    • Список датчиков отображает все датчики, подключенные к Серверу SpRobot. Также в списке показывается текущее состояние датчиков: замкнуто ( [image]) или разомкнуто ( [image]).
    • Параметр «Реагировать на замыкание» указывает, в каком случае должна запуститься программа оповещения: при замыкании или размыкании датчика.
    • Параметр «Макс. время работы алгоритма» определяет, сколько времени может работать программа оповещения после ее запуска.
  • Ручной запуск. Этот тип запуска означает, что пользователь сам следит за запуском и остановкой программы (см. раздел «Список программ»).

Каналы

Чтобы указать, на каких каналах запускать программу, необходимо отметить галочкой выбранные каналы.

Количество запусков обзвона

Оповещение полностью обработанного списка номеров можно запустить заново. Количество запусков и время, через которое следует заново начать обзвон, определяются в этих настройках. Программа автообзвона запустится повторно при следующих условиях:

  • список номеров был полностью обработан во время последнего запуска;
  • программа автообзвона выключена;
  • тип запуска «Период» или «Ручной запуск»;
  • количество запусков программы больше 0 и меньше числа, указанного в настройках;
  • после выключения программы прошло указанное в настройках время.

Приоритеты условий запуска

Приоритет программ оповещения в зависимости от условий запуска представлен в таблице:

Тип запуска | Приоритет
Датчик | Высший
Период | Средний
Ручной | Низший

Таким образом, если время и каналы запуска некоторых программ совпадают, то программа, имеющая меньший приоритет, будет остановлена программой с более высоким приоритетом.

Правила запуска программ с одинаковым типом запуска:

Тип запуска | Правило запуска
Датчик | Более высокий приоритет имеет программа, запущенная позже
Период | Более высокий приоритет имеет программа, запущенная ранее
Ручной | Более высокий приоритет имеет программа, запущенная ранее

Смотрите также:

Список программ

Прим. 1. Если вы укажите период обзвона, который охватывает ночное время (с 22:00 до 7:00), то появится предупреждающее сообщение.


Стандартный и альтернативный механизм автообзвона

В SpRobot механизм автообзвона сосредоточен в 2 командах алгоритма Конструктора: Начать автообзвон и Закончить автообзвон. Пользователь может выбрать, какой механизм автообзвона использовать: стандартный или альтернативный.

Стандартный механизм автообзвона

Команда «Начать автообзвон» будет содержать следующие действия:
  1. выбрать номер из БД SpRobot
    • выбрать номер со статусом1 «Не обработан»
      если номер есть, то перейти к шагу 2
    • выбрать номер со статусом «Занят»
      если номер есть и с момента, когда завершился обзвон этого номера в предыдущий раз, прошло указанное в настройках время, то перейти к шагу 2
    • выбрать номер со статусом «Не отвечает»
      если номер есть и с момента, когда завершился обзвон этого номера в предыдущий раз, прошло указанное в настройках время, то перейти к шагу 2
    • выбрать номер со статусом «Другое или неверный код»
      если номер есть и с момента, когда завершился обзвон этого номера в предыдущий раз, прошло указанное в настройках время, то перейти к шагу 2
    • если номер есть
      если время для очередного обзвона не наступило, то выйти из этой команды и подождать 5 сек.
    • иначе завершить весь автообзвон
  2. получить данные об абоненте (числа, суммы, дата/время)
  3. указать в БД для выбранного номера, что он обрабатывается (поле Processing='True'), записать время начала обзвона и увеличить счетчик количества звонков на этот номер на 1
Команда «Закончить автообзвон» будет содержать следующие действие:
указать в БД для выбранного номера, что обработка закончилась (поле Processing='False'), и сохранить результат обзвона (занят/не отвечает/другое, DTMF-ответ абонента и время окончания обзвона)

В каждом действии SpRobot выполняет различные SQL-запросы.

Альтернативный механизм автообзвона

С помощью альтернативного механизма автообзвона SpRobot может брать номера для обзвона непосредственно из БД пользователя (xls-файлы2, MS Access, MySQL, MS SQL, Oracle и др.) без копирования списка номеров в БД SpRobot. Таким образом достигается более глубокая интеграция с различными программными системами.

Также альтернативный механизм расширяет функциональность автообзвона: можно, например, производить бесконечный обзвон по кругу, обзванивать абонентов с несколькими номерами, интегрировать Автообзвон в корпоративный портал/сайт и др.

Суть альтернативного механизма автообзвона заключается в том, что пользователь заменяет SQL-запросы SpRobot на свои собственные. Включение/выключение и настройка альтернативного механизма осуществляется в разделе «Список номеров», параметр «Использовать БД пользователя».

Описание настроек альтернативного механизма автообзвона:
  • секция General - общие настройки (обязательная секция).
    • параметр SrcName - имя соединения с БД пользователя (раздел «Алгоритм», вкладка «Соединения с БД пользователя»). Если пользователь желает работать с БД SpRobot (MS SQL или локальные таблицы), то в этом параметре необходимо указать слово «SpRobot».
    • параметр Version - версия (всегда 1).
    • параметр DateTimeFormat - формат даты-времени. Значение этого параметра используется, когда дата-время указывается в текстовом виде в предложении WHERE SQL-запроса.

      Для определения формата можно использовать следующие символы:
      d | показать день как число без ведущего нуля (1-31)
      dd | показать день как число с ведущим нулем (01-31)
      m | показать месяц как число без ведущего нуля (1-12). Если «m» идет сразу после «h» или «hh», то будут показаны минуты, а не месяц
      mm | показать месяц как число с ведущим нулем (01-12). Если «mm» идет сразу после «h» или «hh», то будут показаны минуты, а не месяц
      yy | показать год как двузначное число (00-99)
      yyyy | показать год как четырехзначное число (0000-9999)
      h | показать часы как число без ведущего нуля (0-23)
      hh | показать часы как число с ведущим нулем (00-23)
      n | показать минуты как число без ведущего нуля (0-59)
      nn | показать минуты как число с ведущим нулем (00-59)
      s | показать секунды как число без ведущего нуля (0-59)
      ss | показать секунды как число с ведущим нулем (00-59)
      z | показать миллисекунды как число без ведущего нуля (0-999)
      zzz | показать миллисекунды как число с ведущим нулем (000-999)
      'xx'/"xx" | символы, заключенные в одинарные или двойные кавычки, показывать как есть, без форматирования

      Примеры:
      dd.mm.yyyy h:mm:ss | 25.10.2012 9:12:45
      mm/dd/yyyy hh:mm:ss.zzz | 10/25/2012 09:30:23.567
  • секция Unprocessed - выбрать необработанные номера (обязательная секция).
    • параметр Priority - приоритет выполнения SQL-запроса среди других запросов.
    • параметр Query - SQL-запрос, который выбирает номер из БД. Запрос должен вернуть как минимум 2 поля: идентификатор номера и сам номер. Если выборка содержит несколько строк, то будет выбрана первая строка.
    • параметр ID - имя поля идентификатора, которое будет возвращено в запросе.
    • параметр Number - имя поля номера, которое будет возвращено в запросе.
  • секция Busy - выбрать номера со статусом «Занято» (необязательная секция).
    • параметр Priority - приоритет выполнения SQL-запроса среди других запросов.
    • параметр Query - SQL-запрос, который выбирает номер из БД. Запрос должен вернуть как минимум 3 поля: идентификатор номера, сам номер и время окончания обзвона в предыдущий раз. Если выборка содержит несколько строк, то будет выбрана первая строка.
    • параметр ID - имя поля идентификатора, которое будет возвращено в запросе.
    • параметр Number - имя поля номера, которое будет возвращено в запросе.
    • параметр EndTime - имя поля, содержащее время завершения обзвона в предыдущий раз.
  • секция NotAnswered - выбрать номера со статусом «Не отвечает» (необязательная секция).
    • параметр Priority - приоритет выполнения SQL-запроса среди других запросов.
    • параметр Query - SQL-запрос, который выбирает номер из БД. Запрос должен вернуть как минимум 3 поля: идентификатор номера, сам номер и время окончания обзвона в предыдущий раз. Если выборка содержит несколько строк, то будет выбрана первая строка.
    • параметр ID - имя поля идентификатора, которое будет возвращено в запросе.
    • параметр Number - имя поля номера, которое будет возвращено в запросе.
    • параметр EndTime - имя поля, содержащее время завершения обзвона в предыдущий раз.
  • секция Other - выбрать номера со статусом «Другое или неверный код» (необязательная секция).
    • параметр Priority - приоритет выполнения SQL-запроса среди других запросов.
    • параметр Query - SQL-запрос, который выбирает номер из БД. Запрос должен вернуть как минимум 3 поля: идентификатор номера, сам номер и время окончания обзвона в предыдущий раз. Если выборка содержит несколько строк, то будет выбрана первая строка.
    • параметр ID - имя поля идентификатора, которое будет возвращено в запросе.
    • параметр Number - имя поля номера, которое будет возвращено в запросе.
    • параметр EndTime - имя поля, содержащее время завершения обзвона в предыдущий раз.
  • секция UserValues - выбрать данные об абоненте (необязательная секция).
    • параметр Query - SQL-запрос, который формирует данные об абоненте.
    • параметр Form - тип выборки: строка (AsRow) или таблица (AsTable).
      AsRow
      В этом случае SQL-запрос, содержащийся в параметре «Query», должен вернуть данные об абоненте в одной строке вида: Тип1, Значение1, Тип2, Значение2 и т.д. Тип - это целое число, которое указывает тип следующего за ним значения: 1 - номер телефона, 2 - число, 3 - дата/время, 4 - сумма руб. Значение - это поле таблицы, содержащей данные абонентов, или конкретное значение. Например, чтобы выбрать сумму и дату задолженности, нужно указать такой запрос:
      select 4, SummaDebt, 3, DateDebt from UserTable where ID=~NumID~
      AsTable
      В этом случае SQL-запрос, содержащийся в параметре «Query», должен вернуть данные об абоненте в нескольких строках вида:
      Тип1, Значение1
      Тип2, Значение2
      ...
      Тип - это целое число, которое указывает тип следующего за ним значения: 1 - номер телефона, 2 - число, 3 - дата/время, 4 - сумма руб. Значение - это поле таблицы, содержащей данные абонентов, или конкретное значение. Данные об абоненте должны располагаться в нескольких строках таблицы с привязкой к идентификатору номера. Например, пусть таблица номеров содержит следующие данные:
      ID | Number
      1 | 12345
      2 | 54321
      Пусть данные абонента (сумма и дата задолженности) находятся в другой таблице, которая содержит следующие данные:
      NumID | TypeValue | Value
      1 | 4 | 123,56
      1 | 3 | 1.12.2012
      2 | 4 | 5678,12
      2 | 3 | 1.12.2012
      Чтобы выбрать сумму и дату задолженности, нужно указать такой запрос:
      select TypeValue, Value from UserValues where NumID=~NumID~
      В алгоритме Конструктора для получения этих данных нужно использовать команду Получить данные об абоненте. Например, чтобы получить сумму задолженности, в этой команде в параметре «Имя столбца» нужно указать «N1». Тогда первая переменная будет содержать тип данных «4», а вторая - сумму задолженности.
    • параметр Type - имя поля, которое содержит код типа данных (только для Form=AsTable).
    • параметр Value - имя поля, которое содержит данные об абоненте (только для Form=AsTable).
  • секция BeforeDialNumber - выполнить запрос перед обзвоном очередного номера (необязательная секция).
    • параметр Query - SQL-запрос. В этом запросе можно указать, что номер обрабатывается (чтобы эта же программа автообзвона на других каналах не взяла этот номер на обработку), записать время начала обзвона и увеличить счетчик звонков.
  • секция AfterDialNumber - выполнить запрос после обзвона очередного номера (необязательная секция).
    • параметр Query - SQL-запрос. В этом запросе можно указать, что обработка закончилась, и сохранить результат обзвона (успех/занят/не отвечает/другое, DTMF-ответ абонента и время окончания обзвона).
  • секция DialBreak - выполнить запрос, если обзвон был прерван (необязательная секция). Прерывание обзвона может быть, например, из-за критической ошибки, или из-за того, что пользователь остановил программу автообзвона или вышло время, указанное в расписании, и др.
    • параметр Query - SQL-запрос. В этом запросе можно указать, что обработка закончилась, и сохранить время окончания обзвона.
  • секция ResetNumbers - сброс номеров в начальное состояние при запуске программы автообзвона (необязательная секция). Сброс выполняется 1 раз при первом запуске перед началом выполнения команд алгоритма.
    • параметр Query - SQL-запрос, который приводит список номеров в начальное состояние.

В SQL-запросе можно указать предопределенные переменные:
~DialID~ | идентификатор программы автообзвона (это значение берется из таблицы Autodialing БД SpRobot)
~RepeatBusy~ | значение параметра «Повторять попытку» из настройки «Абонент занят»
~RepeatNoAnswer~ | значение параметра «Повторять попытку» из настройки «Абонент не отвечает»
~RepeatOther~ | значение параметра «Повторять попытку» из настройки «Другое или неверный код»
~NumID~ | идентификатор номера, берется из запроса секций «Unprocessed», «Busy», «NotAnswered», «Other»
~Now~ | текущее время в текстовом виде согласно формату, определенному в секции «General»
~Status~ | результат обзвона номера: 1 - успех, 2 - занято, 3 - не отвечает, 4 - другое
~AnswerDTMF~ | DTMF-ответ абонента

Команда «Начать автообзвон» будет содержать следующие действия:

  1. выбрать номер из БД пользователя
    • выполнить SQL-запрос с приоритетом 0 (по умолчанию секция «Unprocessed»)
      если номер есть, то перейти к шагу 2
    • выполнить SQL-запрос с приоритетом 1 (по умолчанию секция «Busy»)
      если номер есть, то перейти к шагу 2
    • выполнить SQL-запрос с приоритетом 2 (по умолчанию секция «NotAnswered»)
      если номер есть, то перейти к шагу 2
    • выполнить SQL-запрос с приоритетом 3 (по умолчанию секция «Other»)
      если номер есть, то перейти к шагу 2
  2. если номер есть
    • если SQL-запрос был из секций «Busy», «NotAnswered» или «Other»
      если с момента, когда завершился обзвон этого номера в предыдущий раз, прошло указанное в настройках время, то перейти к шагу 3
      иначе выйти из этой команды и подождать 5 сек.
      иначе перейти к шагу 3
    иначе завершить весь автообзвон
  3. получить данные об абоненте (числа, суммы, даты/время) - выполнить запрос из секции «UserValues»
  4. выполнить запрос из секции «BeforeDialNumber»
Команда «Закончить автообзвон» будет содержать следующие действие:
выполнить запрос из секции «AfterDialNumber»

Примеры использования альтернативного механизма автообзвона вы можете найти в папке установки:
«..\SpRobot\Client\Samples\Автообзвон\Альтернативный механизм».

Смотрите также:

Список номеров
Настройка дозвона
Соединения с БД пользователя
Конструктор
Расписание

Прим. 1. Код статуса, используемый в SpRobot:
0 | - | Не обработан
1 | - | Успех
2 | - | Занято
3 | - | Не отвечает
4 | - | Другое или неверный код

Прим. 2. Если в качестве списка номеров выбран xls-файл, то такую программу автообзвона можно запускать только на 1 канале. Также при работе автообзвона другие программы не должны открывать xls-файл на редактирование.


Журнал событий

Раздел «Журнал событий» отображает события и сообщения, зафиксированные Сервером. Благодаря этому разделу пользователь может в реальном времени следить за состоянием Сервера и алгоритмов, выполняющихся на каналах. Также журнал событий позволяет обнаруживать причины неполадок и сбоев в работе различных программных модулей Сервера.

Журнал событий в основном содержит служебную и специфическую информацию, которая не понадобится рядовым пользователям Автообзвона. Поэтому разумно открывать доступ к этому разделу только для пользователей с правами администратора.

Фильтр

Журнал событий имеет фильтр отображения данных. Он вызывается нажатием на панели инструментов кнопки «Задать фильтр» [image] или в меню выбором одноименного пункта.

В фильтре можно указать период, в течение которого фиксировались события Сервером, тип (типы) зафиксированных сообщений и канал (каналы), на котором фиксировались сообщения.

Обновление и сохранение в CSV файл

Обновление отображаемых данных в соответствии с выбранными настойками фильтра выполняется нажатием на панели инструментов кнопки «Обновить» [image] или через контекстное меню.

Содержимое журнала можно сохранить в файле формата CSV1, поддерживаемом MS Excel и OpenOffice Calc. Для этого необходимо на панели инструментов нажать кнопку «Сохранить в файл CSV» [image] или в меню выбрать соответствующий пункт.

Прим. 1. CSV файл — это текстовый файл, предназначенный для представления табличных данных. Каждая строка файла — это одна строка таблицы. Значения отдельных колонок разделяются разделительным символом: запятая (,), точка с запятой (;), верт. линия (|) или другие символы. Импорт и экспорт файлов такого типа возможен во многих программах, например: Microsoft Excel, OpenOffice.org Calc, SQL Server Management Studio и другие.


Администрирование пользователей

Автообзвон является многопользовательской системой с разграничением прав доступа к ее различным функциям. Такая организация программы позволяет свести к минимуму ошибки, возникающие по вине пользователей, и увеличивает стабильность ее работы.

Автосекретарь и Автообзвон имеют отдельный набор пользователей, ролей и прав. Таким образом, из Автосекретаря нельзя управлять пользователями и ролями Автообзвона, и наоборот.

Автообзвон предоставляет доступ только зарегистрированным активным пользователям. Как правило, ведение пользователей осуществляется администратором системы.

Каждый пользователь в системе имеет определенную роль, которая, в свою очередь, ассоциирована с некоторым набором прав, определяющих, что может, а что не может выполнять в системе пользователь с данной ролью. Принцип разграничения прав доступа пользователей с использованием ролей графически представлен на рисунке:

Пользователи «П1» и «П2» имеют общую роль «1» (а значит и одинаковые права), которая связана с некоторым набором прав «А». Аналогично для пользователей «П3» и «П4». Роль «3» присвоена только одному пользователю «П5».

Смотрите также:


Список пользователей

В этом разделе администратор системы может создавать и удалять пользователей, а также изменять их настройки (свойства). По умолчанию после установки в Автообзвоне заведено два пользователя: «ADMIN» (максимальные права) и «USER» (минимальные права).

Добавление и изменение свойств пользователей выполняется через панель инструментов или контекстное меню: кнопка «Добавить пользователя» [image] и кнопка «Свойства пользователя» [image] соответственно.

При добавлении пользователя в свойствах необходимо указать следующее: логин и пароль для входа в систему, роль и активность. Остальные поля не обязательны для заполнения. Логин пользователя должен быть уникальным в рамках Автообзвона.

При изменении свойств администратор не может изменять только логин пользователя.

Пользователь, имеющий доступ только к личным настройкам, может изменять из обязательных полей только пароль для входа в систему и пароль к личному ящику голосовой почты.

Операция удаления выполняется через панель инструментов или контекстное меню «Удалить пользователя» [image]. Удаление пользователей возможно только в случае, если они отмечены как неактивные и не имеют сообщений голосовой почты.

Обновление списка пользователей выполняется на панели инструментов нажатием на кнопку «Обновить» [image] или через контекстное меню.

Удалять или изменять роль и активность пользователя «ADMIN» запрещено.

Смотрите также:


Права

Список прав и их описание приведены в таблице:

Право | Описание
Программа: просмотр | Пользователь может просматривать программу автообзвона (список номеров, настройка дозвона, алгоритм и расписание)
Программа: редактирование | Пользователь может изменять программу автообзвона (список номеров, настройка дозвона, алгоритм и расписание)
Автообзвон: запуск, остановка | Пользователь может запускать и останавливать программы автообзвона (оповещения)
Автообзвон, список программ: просмотр | Пользователь может просматривать список программ автообзвона (оповещения)
Автообзвон, список программ: редактирование | Пользователь может изменять и удалять программы автообзвона (оповещения) в списке
Автообзвон, журнал обзвона: просмотр | Пользователь может просматривать журнал обзвона
Сервер: журнал событий | Пользователь может просматривать журнал событий
Сервер, список пользователей: просмотр | Пользователь может просматривать список пользователей, зарегистрированных в системе
Сервер, список пользователей: редактирование | Пользователь может изменять свойства всех пользователей, добавлять новых и удалять существующих пользователей
Сервер, список пользователей: редактирование собственной учетной записи | Пользователь может просматривать и изменять только личные настройки
Сервер, роли: просмотр | Пользователь может просматривать список ролей
Сервер, роли: редактирование | Пользователь может добавлять и удалять роли, но не может назначать права (см. право «Сервер, роли и права: редактирование»)
Сервер, роли и права: просмотр | Пользователь может получать от сервера список всех прав и список прав, установленных на определенную роль (необходима для раздела «Роли», функция «Назначить права»)
Сервер, роли и права: редактирование | Пользователь может назначать права на роль
Сервер: изменение настроек | Пользователь может изменять настройки Сервера (Автосекретарь и Автообзвон имеют общие настройки Сервера)
Автообзвон, состояние номеров: просмотр | Пользователь может просматривать состояние номеров
Автообзвон, справочник абонентов: просмотр | Пользователь может просматривать справочник абонентов
Автообзвон, справочник абонентов: редактирование | Пользователь может редактировать справочник абонентов

При назначении прав важно учитывать, что право на редактирование также дает право на просмотр.

Смотрите также:


Настройка Сервера

Раздел «Настройка Сервера» позволяет через Клиент Автообзвона настраивать различные параметры Сервера.

Автообзвон и Автосекретарь обращаются к одним и тем же настройкам Сервера.

После того как пользователь изменил настройки, необходимо нажать на кнопку «Сохранить», чтобы сделанные изменения были сохранены на Сервере.

Сохраненные настройки вступают в силу только после перезапуска Сервера.

Параметры базы данных

Тип источника данных

В этой настройке пользователь выбирает из всплывающего списка, где будут храниться данные: в MS SQL Server или в локальных таблицах формата Parodox 7. Поскольку изменения настроек начинают действовать не сразу, то под всплывающим списком в поле «сейчас» отображается текущий тип источника данных.

Имя SQL сервера

Имя SQL сервера можно ввести с клавиатуры или выбрать из списка.

Имя БД

В данном параметре указывается имя новой или уже существующей БД на SQL сервере. В этом случае возможны следующие варианты подключения к данным:
  • указанная БД не существует. В этом случае при запуске Сервера SpRobot база данных будет создана автоматически.
  • указанная БД существует. При запуске Сервер SpRobot проверит целостность БД:
    • если БД целостна, т.е. содержит все необходимые таблицы, то Сервер SpRobot будет использовать ее как источник данных.
    • если она не целостна, то Сервер SpRobot будет использовать локальные таблицы.

Идентификация

Здесь указывается способ идентификации (тип проверки подлинности) при подключении к MS SQL серверу: Windows или SQL Server.

Логин и пароль

Если была выбрана идентификация «SQL Server», то в параметрах «Логин» и «Пароль» необходимо указать соответственно имя пользователя и его пароль. Эти данные Сервер SpRobot будет использовать для подключения к MS SQL. Указанный пользователь должен иметь права на создание БД, таблиц внутри БД и модификацию содержимого таблиц.

Тайм-аут

Этот параметр определяет время, в течение которого Сервер SpRobot пытается подключиться к SQL серверу. Если за это время Сервер SpRobot не сможет подключиться, то в качестве источника данных будут выбраны локальные таблицы.

Параметры сервера

TCP/IP порт

В этой настройке пользователь устанавливает, какой порт будет использоваться при обмене данными между Сервером SpRobot и Клиентами по TCP/IP протоколу. Это может понадобиться, например, если порт, устанавливаемый по умолчанию в SpRobot, уже используется другой программой. Номер порта должен быть в диапазоне 1001 – 65535.

Flash-пауза

В режиме тонового набора перед выдачей номера можно кратковременно разомкнуть шлейф телефонной линии. Это позволяет эмитировать нажатие кнопки «Flash» на телефоне при переводе звонка на другого абонента мини-АТС. Длительность разрыва линии определяется параметром «Flash-пауза».

Реагировать на поднятие трубки оператором

Устройство SpRecord может распознавать поднятие трубки на параллельном телефоне. Если этот параметр установлен, то при поднятии трубки оператором во время работы алгоритма Автосекретаря или Автообзвона Сервер остановит выполнение текущей команды (например, прекратит выводить в линию звуковые данные) и будет ждать, пока оператор не завершит разговор и не положит трубку телефона. Данная настройка позволяет оператору «перехватывать» входящий/исходящий звонок. После завершения разговора Сервер продолжит выполнение с начала алгоритма. Если оператор поднял трубку во время обзвона абонентов, то такой номер будет отмечен как «успешно обработан».

Удалять записи из журналов

В этом параметре указывается количество дней, по истечении которых записи в журналах событий и обзвона будут удаляться.

Тоновый режим набора номера

Этот параметр определяет, в каком режиме Автосекретарь и Автообзвон будут набирать телефонные номера. Выключенный параметр устанавливает импульсный режим.

Смотрите также:

Вход в систему (авторизация)